Go to advanced search

by martk20
Thu Jan 17, 2019 12:20 pm
Forum: Camera board
Topic: Changing camera zoom/crop dynamically
Replies: 6
Views: 1232

Re: Changing camera zoom/crop dynamically

Thanks again for your help ethanol100 I have tried the script you supplied and it works fine. I have also taken the little for loop into my server script and it works there too. Now I am confused. I didn't write the server script that would be way beyond my ability. I have just hacked it to do as I ...
by martk20
Wed Jan 16, 2019 9:40 pm
Forum: Camera board
Topic: Changing camera zoom/crop dynamically
Replies: 6
Views: 1232

Re: Changing camera zoom/crop dynamically

Thank you for your rapid response ethanol100. The variables are definitely limited to between 0 and 1. Here is a copy from the script when it terminates. Frankly I do not understand them. Traceback (most recent call last): File "./server.py", line 237, in <module> main() File "./server.py", line 218...
by martk20
Wed Jan 16, 2019 6:41 pm
Forum: Camera board
Topic: Changing camera zoom/crop dynamically
Replies: 6
Views: 1232

Changing camera zoom/crop dynamically

Is it possible to change the Pi camera zoom dynamically? I have written a python script which changes the following:- camera.zoom = (a, b, c, d,); When I attempt to make a change to the zoom, 'a' for instance the camera module stops with lots of errors. I am using the camera as a cctv using the pist...
by martk20
Wed Mar 07, 2018 5:59 pm
Forum: Networking and servers
Topic: Openvpn server
Replies: 2
Views: 834

Openvpn server

I have just installed openvpn server on to a pi2 running raspbian jessie using this site:-https://www.1and1.co.uk/digitalguide/se ... d-openvpn/ I can not connect to it from my phone. I suspect that the server is not running. here is the response from "service openvpn status" [email protected]:/var/log...
by martk20
Wed Mar 07, 2018 4:39 pm
Forum: Beginners
Topic: openvpn server
Replies: 1
Views: 774

openvpn server

I have just installed openvpn server on to a pi2 running raspbian jessie using this site:-https://www.1and1.co.uk/digitalguide/server/configuration/vpn-server-set-up-via-raspberry-pi-and-openvpn/ I can not connect to it from my phone. I suspect that the server is not running. here is the response fr...
by martk20
Mon Dec 11, 2017 6:42 pm
Forum: Troubleshooting
Topic: Uv4l/webrtc not streaming from pi3 to android
Replies: 0
Views: 347

Uv4l/webrtc not streaming from pi3 to android

I have installed uv4l and all the appropriate packages to enable me to stream my picam to an Android Chrome browser. It does not work. I get a strange message from the pi as follows:- Failed to set remote description.OperationError.Failed to set remote offer sdp: Session error code: ERROR_CONTENT. S...
by martk20
Sat Jan 07, 2017 1:06 pm
Forum: Android
Topic: Android on official 7 inch display
Replies: 1
Views: 1982

Android on official 7 inch display

I am attempting to run android on the official 7 inch display. I can get android nougat to run on rpi3. It works well when displayed on dvi or hdmi screen. It gives no display on 7 inch screen and touch screen does not work. Can someone help me to get the screen and touchscreen working with android....
by martk20
Thu Dec 31, 2015 11:31 am
Forum: Official Foundation Display
Topic: Multitouch on 7 inch raspi display
Replies: 0
Views: 497

Multitouch on 7 inch raspi display

I have just assembled a new official 7 inch rpi screen with pi2 board driving it. It works well. However I want to use full multitouch(pinch,zoom ,rotate etc) Has anyone managed to get this working? If so I would like to hear how. I am using the latest raspbian jessie but would be prepared to use an...
by martk20
Wed Mar 13, 2013 9:15 pm
Forum: Media centres
Topic: Touchscreen XBMC Tablet Rpi Issue
Replies: 18
Views: 8998

Re: Touchscreen XBMC Tablet Rpi Issue

Please ignore my previous post regarding patching xbmc to enable touchscreen support.I was being stupid. I have now found the files and patched them successfully.
Regards
M. Knowles
by martk20
Wed Mar 13, 2013 8:55 pm
Forum: Media centres
Topic: Touchscreen XBMC Tablet Rpi Issue
Replies: 18
Views: 8998

Re: Touchscreen XBMC Tablet Rpi Issue

Thanks bboyandru, I am attempting to implement your solution to xbmc touchscreen problem. However when I try to apply your patches I find I have no /xbmc/input directory or even any .cpp files in the unpacked archive. The archive was obtained from the source you recommend. It appears to be source co...
by martk20
Wed Feb 20, 2013 9:23 am
Forum: Media centres
Topic: Touchscreen XBMC Tablet Rpi Issue
Replies: 18
Views: 8998

Re: Touchscreen XBMC Tablet Rpi Issue

I to have 10 inch display from Chalkboard Electronics with touchscreen. Like other people. When I use xbmc the touchscreen only works in the top left hand corner of the screen. Has anyone found a solution to this? I found this when googling http://forum.stmlabs.com/showthread.php?tid=564&page=3 It r...
by martk20
Sun Jan 13, 2013 6:40 pm
Forum: Other projects
Topic: 10" LCD LVDS bundle with capacitive touchscreen and ambient
Replies: 34
Views: 47545

Re: 10" LCD LVDS bundle with capacitive touchscreen and ambi

I have just received the screen and touch screen from Chalkboard Electronics. Generally I am very pleased with it. Works very well on Debian Wheezy. Some minor problems with touch screen on XBMC. However when I attempted to run my system on the Android 2.3 port. I get no display. Android just about ...
by martk20
Mon Dec 03, 2012 1:11 pm
Forum: Media centres
Topic: Terminal shown when playing video in XBMC
Replies: 5
Views: 2101

Re: Terminal shown when playing video in XBMC

On a slighty different matter. Is it possible to dynamically split the memory 128/128 on entry to xbmc and revert back to 64/192 on exit of xbmc to Debian?. Going in to xbmc should be no problem. A script to run an elf file should suffice. But I can see no way to change back on exit.
by martk20
Mon Dec 03, 2012 11:24 am
Forum: RISCOS
Topic: No Display with Riscos
Replies: 8
Views: 2043

Re: No Display with Riscos

Burngate,
How many partitions are there on your sdcard. I only have one. On Raspbian Wheezy, and all other os I have tried there have been two.
by martk20
Sun Dec 02, 2012 6:20 pm
Forum: RISCOS
Topic: No Display with Riscos
Replies: 8
Views: 2043

Re: No Display with Riscos

Joan,
The files on my sd card are exactly the files listed In Burngates reply. As read on my Linux laptop.
by martk20
Sun Dec 02, 2012 5:48 pm
Forum: RISCOS
Topic: No Display with Riscos
Replies: 8
Views: 2043

Re: No Display with Riscos

Thanks for your prompt reply. I get one flash on the green cpu led . It comes on for about 1 sec then goes off. If I remember correctly the only thing I changed in config.txt was the overscan so the window filled the screen. This is now done in raspi-config.
by martk20
Sun Dec 02, 2012 4:09 pm
Forum: RISCOS
Topic: No Display with Riscos
Replies: 8
Views: 2043

No Display with Riscos

I have an early model B pi. I have been using it mainly on Debian Wheezy and all works ok. I thought I would have a play with riscos. The 8 Mb sd card appears to have flashed correctly using dd on a linux laptop. The sd card has six files on it. When I plug it all together I get no display at all. I...
by martk20
Thu Sep 13, 2012 3:42 pm
Forum: Bare metal, Assembly language
Topic: Baking Pi
Replies: 168
Views: 30976

Re: Baking Pi

mister_wavey wrote:start with echo $PATH again and paste the output of make -d
I think I have found the problem my source directory was Source. The makefile was looking for source.
by martk20
Thu Sep 13, 2012 10:35 am
Forum: Bare metal, Assembly language
Topic: Baking Pi
Replies: 168
Views: 30976

Re: Baking Pi

oh, just read 'this is before I inserted the new kernel'. What size does it show now? Sorry I was so long in replying. Lots of things on at the moment. Your last reply prompted to me to do some checking and I notice that the new kernel.img file has zero bytes, an empty file. So it looks as if my co...
by martk20
Thu Sep 13, 2012 10:19 am
Forum: Bare metal, Assembly language
Topic: Baking Pi
Replies: 168
Views: 30976

Re: Baking Pi

oh, just read 'this is before I inserted the new kernel'. What size does it show now? Sorry I was so long in replying. Lots of things on at the moment. Your last reply prompted to me to do some checking and I notice that the new kernel.img file has zero bytes, an empty file. So it looks as if my co...
by martk20
Wed Sep 12, 2012 7:19 pm
Forum: Bare metal, Assembly language
Topic: Baking Pi
Replies: 168
Views: 30976

Re: Baking Pi

So your toolchain works now? Great. I just recompiled the model answer for lesson 2 and booted the pi with it. The screen does show the normal coloured pattern, but the OK LED flashes about twice a second in a loop forever. If you're not seeing this, it could be that you aren't copying the kernel.i...
by martk20
Wed Sep 12, 2012 3:09 pm
Forum: Bare metal, Assembly language
Topic: Baking Pi
Replies: 168
Views: 30976

Re: Baking Pi

yet with that PATH and that directory layout, you can't type arm-none-eabi-as from your home directory? weirdness. I'm bailing for the night. Happy to help more tomorrow. If you solve it, do please summarise :) Hello it's martk20 again Going back to last week. I have only just got back onto my pi a...
by martk20
Thu Sep 06, 2012 6:55 pm
Forum: Bare metal, Assembly language
Topic: Baking Pi
Replies: 168
Views: 30976

Re: Baking Pi

Did you untar your toolchain as root? Looks like it ended up in / if so, no one else will be able to read it. If it didn't end up in / then you need to edit your PATH to say where it really is. Plus it looks like you missed the /bin part of the arm2008q3 path maybe follow http://www.cl.cam.ac.uk/fr...
by martk20
Thu Sep 06, 2012 6:11 pm
Forum: Bare metal, Assembly language
Topic: Baking Pi
Replies: 168
Views: 30976

Re: Baking Pi

Alternatively this can be caused on a 64 bit linux without 32 bit compatibility libraries. Try: sudo apt-get install ia32-libs The ia32 libs do not seem to be available in any of the opensuse repositories. The only ia32-libs I can find anywhere seem to be associated with nvidia graphics drivers. Ar...
by martk20
Thu Sep 06, 2012 5:18 pm
Forum: Bare metal, Assembly language
Topic: Baking Pi
Replies: 168
Views: 30976

Re: Baking Pi

your error: make: arm-none-eabi-as: Command not found means that make still isn't finding your toolchain in the path. can you echo $PATH and see if it contains 2 dirs for yagarto tools and bin? I am using the linux gnu toolchain so no yagarto. Here is the output from echo $PATH "[email protected]:~...

Go to advanced search