Go to advanced search

by davehiggins21
Tue Jan 06, 2015 4:07 pm
Forum: General discussion
Topic: Power for an external HDD
Replies: 61
Views: 76289

Re: Power for an external HDD

I have 2 Pi's, an original model B with the polyfuses shorted out which I normally run with a Y cable off a 2.5A laptop power supply which I hacked to give me an on/off switch and 2 USB sockets. I've just bought a B+ to run XBMC on and possibly use as a mini NAS (if it will support it) which I run o...
by davehiggins21
Mon Sep 30, 2013 2:39 pm
Forum: Troubleshooting
Topic: Error -2 from Wunderground
Replies: 6
Views: 1715

Re: Error -2 from Wunderground

I've finally had some -2 errors but the updates restart after they occur! I haven't done anything to cause this and I've run the following script in the background to try to catch it happening but it doesn't do so despite the fact that it works when I run it from the terminal. Maybe Wunderground hav...
by davehiggins21
Sun Sep 01, 2013 5:47 pm
Forum: Troubleshooting
Topic: Error -2 from Wunderground
Replies: 6
Views: 1715

Re: Error -2 from Wunderground

Thanks for the response. I've finally found a few minutes to try a few things out and have set up a script to monitor for -2 errors and email me the result of the nslookup. I had to install nslookup but found the instructions in the forum. The last time I had a -2 error the updates started up after ...
by davehiggins21
Wed Aug 21, 2013 7:39 pm
Forum: Troubleshooting
Topic: Error -2 from Wunderground
Replies: 6
Views: 1715

Re: Error -2 from Wunderground

Wunderground say they had network problems at the times I had the problem last week so it does look like a DNS error. I don't understand why pywws doesn't restart sending once the website is fixed and it doesn't seem to happen on other hardware / software implementations - or at least no-one has rep...
by davehiggins21
Mon Aug 19, 2013 6:13 pm
Forum: Troubleshooting
Topic: Error -2 from Wunderground
Replies: 6
Views: 1715

Re: Error -2 from Wunderground

Yes I agree it may well be a wunderground fault, the problem is that I only know it's happened when I check the wunderground site to see if updates are running OK and by then the problem has always gone away since it only happens about once every 4 weeks or so. I suppose I could try processing the p...
by davehiggins21
Sun Aug 18, 2013 3:24 pm
Forum: Troubleshooting
Topic: Error -2 from Wunderground
Replies: 6
Views: 1715

Error -2 from Wunderground

I'm running pywws on my Pi to gather data from my weather station and send it to Wunderground and my own local website. This has been running for several months very reliably apart from one problem. Every few weeks I get an error message in the pywws log saying 2013-08-16 18:51:31:pywws.ToService(un...
by davehiggins21
Sat Mar 30, 2013 2:54 pm
Forum: Troubleshooting
Topic: Cron keeps sending me emails
Replies: 6
Views: 3991

Re: Cron keeps sending me emails

I installed ssmtp to send me mail as described in the following link.

https://groups.google.com/forum/?fromgr ... RwOEb5NDbQ

This worked very well apart from the fact that cron sends me emails every time a job runs.

Dave
by davehiggins21
Sat Mar 30, 2013 8:40 am
Forum: Troubleshooting
Topic: Cron keeps sending me emails
Replies: 6
Views: 3991

Re: Cron keeps sending me emails

The idea of continuously running a script works fine and has reduced the email I get to acceptable levels. Thanks very much.

Dave
by davehiggins21
Sat Mar 23, 2013 6:02 pm
Forum: Troubleshooting
Topic: Cron keeps sending me emails
Replies: 6
Views: 3991

Re: Cron keeps sending me emails

Sorry I've obvously not made it clear. I want to email an external email address any errors that cause pywws to crash and i've got that working fine. The problem is that cron itself appears to email me the output from running the script as if it were running from a terminal. I'm using cron because i...
by davehiggins21
Sat Mar 23, 2013 4:17 pm
Forum: Troubleshooting
Topic: Cron keeps sending me emails
Replies: 6
Views: 3991

Cron keeps sending me emails

I've just finished installing pywws to talk to my weather station and update Wunderground. I run a cron task to check that pywws is still running and to restart it if it fails. I installed ssmtp so that I could email myself the last few lines of the pywws log whenever it needs restarting so that I c...
by davehiggins21
Wed Mar 20, 2013 6:56 pm
Forum: Troubleshooting
Topic: Apt-get upgrade fails
Replies: 1
Views: 558

Apt-get upgrade fails

I've just done apt-get update and apt-get upgrade on my Raspbian system and got the following error mesage (after many other lines of messages). Processing triggers for shared-mime-info ... Errors were encountered while processing: /var/cache/apt/archives/xserver-common_2%3a1.12.4-5_all.deb /var/cac...
by davehiggins21
Mon Mar 04, 2013 10:57 am
Forum: Beginners
Topic: Setting up pywws / writing data to website
Replies: 57
Views: 16774

Re: Setting up pywws / writing data to website

Hi Paul - yes I have the images/forecast folder with all the .png files in it so that's not the problem. When I saw your message late last night I had hoped that was the problem but no joy. I'll have to find some time to have a quiet think about it and study the code in detail.

Cheers Dave
by davehiggins21
Sun Mar 03, 2013 6:11 pm
Forum: Beginners
Topic: Setting up pywws / writing data to website
Replies: 57
Views: 16774

Re: Setting up pywws / writing data to website

Many thanks Paul. I've added a forecast update to the logging section of .ini and I now get a text based forecast - no icon though. I'll see if I can now work out why. The php file is the same so it's something that pywws is doing I think. It may be the template file so I'll see if I can find detail...
by davehiggins21
Sun Mar 03, 2013 9:28 am
Forum: Beginners
Topic: Setting up pywws / writing data to website
Replies: 57
Views: 16774

Re: Setting up pywws / writing data to website

Paul could you do me a huge favour please and send me copies of your weather.ini and php.index files. I must have a typo somewhere as I can't get it to work. My email is [email protected].

Cheers dave
by davehiggins21
Sat Mar 02, 2013 6:37 pm
Forum: Beginners
Topic: Setting up pywws / writing data to website
Replies: 57
Views: 16774

Re: Setting up pywws / writing data to website

hi Paul - - I think I'm beginning to realise why it doesn't work. I don't have any entries for Zambretti in weather.ini and there isn't any documentation of it in Jim's documentation of the .ini file. I don't have a forecast_icon.txt file but I do have a forecast_icon_9am.txt which contains the foll...
by davehiggins21
Sat Mar 02, 2013 4:12 pm
Forum: Beginners
Topic: Setting up pywws / writing data to website
Replies: 57
Views: 16774

Re: Setting up pywws / writing data to website

Hi Paul - I'm still confused about the Zambretti forecasting. I've asked Jim and he pointed me at Weatherbyyou. Jacques said he doesn't know Linux but has run the system on a router with no problems and believes that the Pi is missing some software. You can run the Forecast function in pywws and get...
by davehiggins21
Thu Feb 28, 2013 4:20 pm
Forum: Beginners
Topic: Setting up pywws / writing data to website
Replies: 57
Views: 16774

Re: Setting up pywws / writing data to website

Paul - the light is suddenly shining in my addled brain. It's so long since I did any of this that I've forgotten the basics. I used many years ago to manage IBM and ICL mainframes so the principles are there but Linux and HTML are a steep learning curve - but enjoyable especially since there are pe...
by davehiggins21
Thu Feb 28, 2013 12:23 pm
Forum: Beginners
Topic: Setting up pywws / writing data to website
Replies: 57
Views: 16774

Re: Setting up pywws / writing data to website

Thanks for the help - index.txt was in the right place. The problem was that I'd put the data that Pywws was creating in a folder called text instead of data. Correcting that fixed the initial problems - i.e. no data display and now I'm correcting the other errors - slowly. index.php as supplied app...
by davehiggins21
Wed Feb 27, 2013 7:51 pm
Forum: Beginners
Topic: Setting up pywws / writing data to website
Replies: 57
Views: 16774

Re: Setting up pywws / writing data to website

Hi I've tried to contact weatherbyyou via their forum but can't register for the forum because I don't have a website, very silly. So I thought I'd ask my daft question here. I've got pywws writing data to /var/www/text as png and txt files but when i go to the webserver I only get the header. I kno...
by davehiggins21
Mon Feb 25, 2013 7:01 pm
Forum: Beginners
Topic: Setting up pywws / writing data to website
Replies: 57
Views: 16774

Re: Setting up pywws / writing data to website

That's brilliant thanks, I have now got a working webserver. Do the files need to be in /var/www when I unzip the files. I can't see any instructions as to location in the read.me file though it's not well formatted.

Thanks for the help

Dave
by davehiggins21
Mon Feb 25, 2013 1:26 pm
Forum: Beginners
Topic: Setting up pywws / writing data to website
Replies: 57
Views: 16774

Setting up pywws / writing data to website

I have been playing with Jim Easterbrook's excellent pywws to get and process data from my new Maplin weather station. I've got live logging working and once I've installed the weather station outside (I have to wait for my birthday as it's a present) I will start sending data to Wunderground (I hop...
by davehiggins21
Sun Feb 24, 2013 11:27 am
Forum: Troubleshooting
Topic: Error handle messages on boot DMA channel 6
Replies: 0
Views: 571

Error handle messages on boot DMA channel 6

I've been building pywws on my Pi for a few days using the latest copy of Wheezy with all updates as of about 2 weeks ago (firmware and Debian) and sometimes when I reboot it I get hundreds of the following messages and it never boots up (the message is something like this but scrolls very fast so i...
by davehiggins21
Tue Jan 22, 2013 12:09 pm
Forum: Graphics, sound and multimedia
Topic: Using RCA jack for audio
Replies: 23
Views: 13389

Re: Using RCA jack for audio

Yes that worked fine. I redid the build after issuing the 'sudo amixer cset numid=3 1' command and kept checking that it worked by doing a 'sudo speaker-test' after each section of the install - and it all works.

yippee

Dave
by davehiggins21
Tue Jan 22, 2013 8:56 am
Forum: Graphics, sound and multimedia
Topic: Using RCA jack for audio
Replies: 23
Views: 13389

Re: Using RCA jack for audio

Of course I didn't mean the Composite RCA Phono - I meant the 3.5 mm jack. The amixer command should switch the sound output from HDMI to the 3.5 mm jack but the command fails. I think I'll try reinstalling and setting it to the correct output before installing PulseAudio - might make the difference...
by davehiggins21
Mon Jan 21, 2013 7:00 pm
Forum: Graphics, sound and multimedia
Topic: Using RCA jack for audio
Replies: 23
Views: 13389

Re: Using RCA jack for audio

I've been trying to set up the DLNA streaming system as specified by Stephen Phillips which I've managed to get working apart from getting the sound out of the RCA jack. I get the sound out via the HDMI port and when I issue the amixer command I get the following. [email protected] ~ $ sudo amixer cset...

Go to advanced search