Go to advanced search

by ptamike
Sat Jul 06, 2019 10:49 am
Forum: Advanced users
Topic: PI4 Serial Ports
Replies: 2
Views: 1030

Re: PI4 Serial Ports

Hi John, I asked a similar question on the Device Tree section of the forum and received a reply, so I thought I'd share the answer here. There are four new overlays for hardware serial ports - uart2 to uart5. After loading they will be available as /dev/ttyAMA1-4. To activate one of the additional ...
by ptamike
Sat Jul 06, 2019 7:36 am
Forum: Device Tree
Topic: Pi-4 Activating additional UART ports
Replies: 35
Views: 4802

Re: Pi-4 Activating additional UART ports

Thanks for the answers. I'll look forward to seeing the new documentation.

In the meantime, can anyone suggest what I would need to add to /boot/config.txt to activate one of the new ports?

Thanks,

Mike
by ptamike
Sat Jul 06, 2019 4:18 am
Forum: Device Tree
Topic: Pi-4 Activating additional UART ports
Replies: 35
Views: 4802

Pi-4 Activating additional UART ports

The new Pi-4 features additional hardware UART ports but I've been unable to find any documentation explaining how to access them.

Can anyone help?
by ptamike
Fri Jun 24, 2016 1:42 pm
Forum: Troubleshooting
Topic: Pi-3 Bluetooth Audio with RN52 and headset profile
Replies: 5
Views: 1263

Re: Pi-3 Bluetooth Audio with RN52 and headset profile

Ok, thanks for that. I'll investigate some more. It would be nice to have a fully implemented Bluetooth solution for the Pi or at least have the capabilities and exceptions clearly set out somewhere. There appears to be quite a few people struggling with Bluetooth and it would save a lot of time if ...
by ptamike
Fri Jun 24, 2016 9:36 am
Forum: Troubleshooting
Topic: Pi-3 Bluetooth Audio with RN52 and headset profile
Replies: 5
Views: 1263

Pi-3 Bluetooth Audio with RN52 and headset profile

Hi, I'm trying to get a Microchip RN52 Bluetooth audio module to work with a Pi-3. The RN52 module starts in headset profile which is how I want to use, i.e. to send and receive audio. I can find and pair with the module using the Bluetooth manager on the top line of the screen. However, when I try ...
by ptamike
Mon Sep 28, 2015 1:56 pm
Forum: Official Foundation Display
Topic: Right and bottom cut-off
Replies: 3
Views: 989

Re: Right and bottom cut-off

Thanks both for your replies. I thought that might be the case but just wanted to check that there wasn't a display tweak available.

Fingers crossed for a nice big high-res 10" screen next :-)
by ptamike
Mon Sep 28, 2015 10:31 am
Forum: Official Foundation Display
Topic: Right and bottom cut-off
Replies: 3
Views: 989

Right and bottom cut-off

Official Pi Touchscreen Display: When running some applications with their window maximised they overflow to the right and bottom of the Pi display making them unusable. Also, if I run the same applications in their default window mode, the window resize controls are available but the windows will ...
by ptamike
Sat May 09, 2015 4:20 pm
Forum: Raspbian
Topic: Raspbian 5/5/15 release Audio Selection Problem?
Replies: 2
Views: 527

Re: Raspbian 5/5/15 release Audio Selection Problem?

Thanks for the suggestion. I tried that but no change, xfce4-mixer still won't remember USB card as the default or show the level controls except via the settings panel. The card itself is working fine and I have it linked-up to FLDIGI with no problems. It would just be nice to be able to use the xf...
by ptamike
Sat May 09, 2015 8:11 am
Forum: Raspbian
Topic: Raspbian 5/5/15 release Audio Selection Problem?
Replies: 2
Views: 527

Raspbian 5/5/15 release Audio Selection Problem?

The inclusion of the new audio controls is very welcome but I'm having a problem selecting an external USB soundcard (Daffodil US-01). The US-01 is well proven on previous Raspbian versions but on the latest release the card cannot be remembered as the default device. The initial process I've tried ...
by ptamike
Sun Feb 22, 2015 10:22 am
Forum: Advanced users
Topic: RPI RTL-SDR server: Segmentation fault.
Replies: 50
Views: 23005

Re: RPI RTL-SDR server: Segmentation fault.

Roop - Your best bet is to open a terminal session and enter: sudo yum install -y libusb-1.0-0 That will install the latest libusb and should be all you need. You will probably have to repeat the rtl-sdr build process as libusb is a dependency. The alternative is to move away from the Pidora OS and ...
by ptamike
Sat Feb 21, 2015 6:32 pm
Forum: Advanced users
Topic: RPI RTL-SDR server: Segmentation fault.
Replies: 50
Views: 23005

Re: RPI RTL-SDR server: Segmentation fault.

Solving the rtl-sdr Segmentation error on Raspbian (16-2-2015) The problem appears to linked with the 11.1 version of libusb-1.0 that is used in the current Raspbian build. Upgrading to the latest version, 19.1, overcomes the problem. The following procedure upgrades libusb-1.0 to the 19.1 release....
by ptamike
Fri Feb 20, 2015 11:15 pm
Forum: Advanced users
Topic: RPI RTL-SDR server: Segmentation fault.
Replies: 50
Views: 23005

Re: RPI RTL-SDR server: Segmentation fault.

The 16/2/15 release of Raspbian fixes the libusb problems so there's no need to use Pidora for RTL-Dongle streaming.
by ptamike
Wed Jan 07, 2015 3:11 pm
Forum: Advanced users
Topic: RPI RTL-SDR server: Segmentation fault.
Replies: 50
Views: 23005

Re: RPI RTL-SDR server: Segmentation fault.

I have now been through the loading of rtl-sdr onto to pidora and can confirm that the rtl_tcp server works fine. Here's a quick run through the installation steps: Pidora setup wizard: I've used pi as the username and raspberry as the password for the user and root for simplicity. When creating the...
by ptamike
Mon Jan 05, 2015 8:40 pm
Forum: Advanced users
Topic: RPI RTL-SDR server: Segmentation fault.
Replies: 50
Views: 23005

Re: RPI RTL-SDR server: Segmentation fault.

Hi All - This appears to be an issue with the later Raspian builds and may well be connected with libusb. Here are some of the things I have tried to narrow down the problem. Problem: When using SDR Sharp to connect to the Raspberry Pi RTL-SDR server you can only connect once. If you hit the SDR Sha...
by ptamike
Fri Nov 29, 2013 2:05 pm
Forum: HATs and other add-ons
Topic: raspberry pi doesn't boot [solved]
Replies: 50
Views: 25799

Re: raspberry pi doesn't boot

Gert, Mine now boots with the reset link in place so I've used avrdude to read back the code from the Mega48. I've attached the code to this message. I also noted that the Mega48 sends back the wrong device signature. Avrdude expects 1E 92 05 but the chip returns 1E 92 0A The avrdude command I used ...
by ptamike
Fri Nov 29, 2013 10:51 am
Forum: HATs and other add-ons
Topic: raspberry pi doesn't boot [solved]
Replies: 50
Views: 25799

Re: raspberry pi doesn't boot

Gert,

As a follow-up to my last post. I tried booting the Pi with the ATMega removed from its socket. That produced the same error message but the LEDs were all off but running a finger across the Mega socket will turn the LEDs on.

Hope that helps,

Mike

Go to advanced search