Go to advanced search

by punacmc
Sun Oct 08, 2017 11:18 pm
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1350
Views: 230625

Re: PiKrellCam: motion vector detect + OSD web interface

Bill, can you make it to where we can use the full resolution of the cameras? I'm ok with the reduced frame rates. I would like to use all 8MP of the v2 camera for a project. -Mike
by punacmc
Tue May 23, 2017 2:24 am
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1350
Views: 230625

Re: PiKrellCam: motion vector detect + OSD web interface

I changed the logical expression to a while loop for efficiency. I use 90% for my limit and it works well. Sure is nice not checking the cameras everyday to delete old files... #!/bin/bash #cdrof.sh (check disk remove oldest file) Created by PuNacMC on 04-17-2017. #[email protected].com for questions or...
by punacmc
Wed Apr 19, 2017 12:59 am
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1350
Views: 230625

Re: PiKrellCam: motion vector detect + OSD web interface

I'm sure that disk usage and clean up has been covered before, but I will share my script in case it helps others. I'm sure there are better ways to do this, but so far it has worked in the few tests I have done. If anyone sees any syntax errors or better ways to write the algorithm, just let me kno...
by punacmc
Thu Aug 25, 2016 9:21 pm
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1350
Views: 230625

Re: PiKrellCam: motion vector detect + OSD web interface

jbeale, I would like to research your project with the strobe. Have you complied your information anywhere other than this forum?
by punacmc
Thu Aug 25, 2016 9:18 pm
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1350
Views: 230625

Re: PiKrellCam: motion vector detect + OSD web interface

I altered the at-command file to include "@exposure_mode night" for sunset and "@exposure_mode auto" for sunrise. I checked the OSD, and the changes did not happen. Are you using the new RPi v2 camera? I am not sure but I have the impression that night mode does not work the same way on v2 as it di...
by punacmc
Thu Aug 25, 2016 4:27 pm
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1350
Views: 230625

Re: PiKrellCam: motion vector detect + OSD web interface

Ok I've got most of this figured out. The only setting I can not get to work is the exposure. I use the following in my at-commands.conf file. daily sunset "@exposure night" Use daily sunset "@exposure_mode night" The text you see on the OSD for settings arguments should be the same as you would us...
by punacmc
Thu Aug 25, 2016 1:52 am
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1350
Views: 230625

Re: PiKrellCam: motion vector detect + OSD web interface

I could use some assistance. I would like to use the at-command.conf to adjust the camera, picture, and exposure settings at sunrise and sunset. I have examined this file and the help file, but I do not see a list of possible commands that can be used. Are the commands the same as the labels in the...
by punacmc
Fri Aug 19, 2016 2:37 am
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1350
Views: 230625

Re: PiKrellCam: motion vector detect + OSD web interface

I could use some assistance. I would like to use the at-command.conf to adjust the camera, picture, and exposure settings at sunrise and sunset. I have examined this file and the help file, but I do not see a list of possible commands that can be used. Are the commands the same as the labels in the ...
by punacmc
Mon Apr 04, 2016 1:52 am
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1350
Views: 230625

Re: PiKrellCam: motion vector detect + OSD web interface

How would one use the at-commands to initiate night exposure? I was thinking it would look like

daily sunset "@????"

I don't see any actual FIFO commands that deal with the exposure or other camera settings? Am I just missing the command?
by punacmc
Wed Sep 30, 2015 11:13 pm
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1350
Views: 230625

Re: PiKrellCam: motion vector detect + OSD web interface

Bill, Thanks again for your hard work with this excellent software. I know I requested the full image video be implemented, however I was unaware of the binning used on the camera board. So in the end I'm not sure if the result would be worth the time. I really would like to have the highest resolu...
by punacmc
Sun Sep 27, 2015 10:52 pm
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1350
Views: 230625

Re: PiKrellCam: motion vector detect + OSD web interface

Bill, Thanks again for your hard work with this excellent software. I know I requested the full image video be implemented, however I was unaware of the binning used on the camera board. So in the end I'm not sure if the result would be worth the time. I really would like to have the highest resolut...
by punacmc
Tue Aug 25, 2015 6:17 pm
Forum: Camera board
Topic: PiKrellCam: motion vector detect + OSD web interface
Replies: 1350
Views: 230625

Re: PiKrellCam: motion vector detect + OSD web interface

Is there any plan to have an option for full video resolution? I know it's only 15fps, however I think that the increased resolution would be nice in some situations.
by punacmc
Thu Feb 05, 2015 4:14 am
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 4827
Views: 1054955

Re: RPi Cam Web Interface

Does anyone know how to take good nightime video? I guess the preview allows longer exposure time for pictures, but the video is really dark. Is it possible to record slower frame rates for longer exposure time? Or is there a way to take full res pictures with longer exposure? I want to leave motio...
by punacmc
Wed Feb 04, 2015 3:23 am
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 4827
Views: 1054955

Re: RPi Cam Web Interface

Does anyone know how to take good nightime video? I guess the preview allows longer exposure time for pictures, but the video is really dark. Is it possible to record slower frame rates for longer exposure time? Or is there a way to take full res pictures with longer exposure? I want to leave motion...
by punacmc
Fri Jan 23, 2015 2:44 am
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 4827
Views: 1054955

Re: RPi Cam Web Interface

I ended up changing the sudden brightness setting to 50%, the minimum motion frames to 2, and the precapture frames to 2 in motion.conf. I was not sure this would work as I was not sure how RPi Cam Web Interface uses motion and the config file.The changes solved my issue so far in my testing. I did ...
by punacmc
Thu Jan 22, 2015 3:05 am
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 4827
Views: 1054955

Re: RPi Cam Web Interface

Does anyone else have any issues when the video recording ends at the end of motion detection? My picam starts a new recording as soon as the last one is processed. I've changed the motion detection threshold in motion.conf, along with preview frames, and number of frames with motion. I end up with ...
by punacmc
Thu Jan 22, 2015 2:29 am
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 4827
Views: 1054955

Re: RPi Cam Web Interface

Cancel my last question. I checked the file permissions and realized other had no access. I gave it read access and all is well.
by punacmc
Thu Jan 22, 2015 2:25 am
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 4827
Views: 1054955

Re: RPi Cam Web Interface

I've got an easy question I am sure someone can answer. I have mounted a XFS on a usb drive at boot for my Pi. I have successfully recorded a video from the web interface, and it saves to the thumb drive (verified). When I go to the preview web page, it will not show the recorded files. Any suggesti...
by punacmc
Mon Jun 30, 2014 3:19 pm
Forum: Camera board
Topic: Need help with Camera Bug
Replies: 9
Views: 1876

Re: Need help with Camera Bug

Thanks for the responses, this is the first chance I've been able to get back to this project. All of my Pi's are powered by a 2 amp power supply so I do believe I am good on power. Also the network issues has been resolved by turning off the power management on the Edimax. I have tried running the ...
by punacmc
Mon Jun 30, 2014 2:59 pm
Forum: Networking and servers
Topic: Losing network connection
Replies: 2
Views: 930

Re: Losing network connection

Well, after several days of continuous uptime, it appears that it was a power management issue. So far I have been able to login without any issues. My connections actually respond quicker and the webserver displays are much faster. Who knew? Thanks for the help.
by punacmc
Wed Jun 25, 2014 2:03 am
Forum: Networking and servers
Topic: Losing network connection
Replies: 2
Views: 930

Losing network connection

I have a Pi revision 2 with an Edimax network adapter. I am running RPi_Cam_Web_Interface which runs 24/7. There are times when I can't connect to the Pi by SSH, or connect to the webserver. It is still running as the camera is still grabbing video. After several minutes it will reconnect. While the...
by punacmc
Wed Jun 25, 2014 1:50 am
Forum: Camera board
Topic: Need help with Camera Bug
Replies: 9
Views: 1876

Re: Need help with Camera Bug

No loose connectors that I can see. I've reset the cable numerous times without any success. The camera stays on for 15-20 seconds after turning on. I then get the following error: Error in RaspiMJPEG: Camera send invalid data Restart RaspiMJPEG(./RPi_Cam_Web_Interface_Installer.sh start) or the who...
by punacmc
Mon Jun 23, 2014 2:39 pm
Forum: Camera board
Topic: Need help with Camera Bug
Replies: 9
Views: 1876

Need help with Camera Bug

I am creating a surveillance camera using RPi Cam Web Interface, Edimax Wireless, and an Android app. I tested out the concept on a Pi (v2) with success. I then purchased several more Pi's and a camera module. I successfully built and started another Picam with the same software minus different IP a...
by punacmc
Tue Jun 10, 2014 3:00 am
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 4827
Views: 1054955

Re: RPi Cam Web Interface

Ok, I figured out one problem. The motion button was not working because I did not remember to add the local host port number in motion.conf where you can specify a network camera. Its under netcam_url if anyone else has the same issue. The older firmware does work much better with the web interface...
by punacmc
Mon Jun 09, 2014 8:13 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 4827
Views: 1054955

Re: RPi Cam Web Interface

I used the same settings in motion.conf that I used before. I then tried changing the threshold even lower as you suggested but it still doesn't capture motion videos...

Go to advanced search