Go to advanced search

by Hix
Fri Apr 03, 2015 4:47 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5288
Views: 1659361

Re: Motion working again [on one camera]

The other things to check in motion is to make sure it can access the cam.jpg which is where it is getting the stream of data to work from. It does this by using the netcam_url setting in motion to fetch it via cam_pic.php. If you have changed the access port of the web server then that must be in ...
by Hix
Fri Apr 03, 2015 4:19 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5288
Views: 1659361

Re: Motion working again [on one camera]

When motion is detected then it should send a '1' to FIFO1 which scheduler logs as a start request and then sends on the ON command ca 1 to initiate a recording. Similalry when motion says no further movement it sends a '0' which gets logged asa stop request and if a recording is in progress sends ...
by Hix
Fri Apr 03, 2015 2:57 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5288
Views: 1659361

Motion working again [on one camera]

So, I appear to have motion working again on one of the cameras. It seems it was the scheduler settings. ca 1 and ca 0 were missing from day when it was set to sun settings. I have added ca 1 and ca 0 to all profiles as I want it to monitor 24/7 http://i.imgur.com/UZzgr3z.png Strangely though the ot...
by Hix
Fri Apr 03, 2015 1:20 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5288
Views: 1659361

Re: Motion appears to be broken

It is on_event_start that matters. It should normally be echo -n '1' >/var/www/FIFO1 The scheduler log should have Start capture requested entries when motion sends this command through. Hi Robert, Yes this is what both GUIs indicate, though record is not functioning from motion. Manual is fine but...
by Hix
Fri Apr 03, 2015 9:37 am
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5288
Views: 1659361

Motion appears to be broken

Something has happened to motion it seems. I dug around and found /var/www/scheduleLog.txt this seems to pin-point when things started to go awry http://pastebin.com/Q28Cscvf line 3646 is where the problems appear to surface. From reading through. start capture is no longer issuing Send ca 1 in moti...
by Hix
Thu Apr 02, 2015 5:33 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5288
Views: 1659361

Re: RPi Cam Web Interface

I've had a few days of stable use now, however this morning something happened to both nestboxes. Motion seems to have stopped working. I've run an update on both Pis and they both reported tey were up-to-date v4.4.2R is on both. The settings are as they were when things were working but motion does...
by Hix
Fri Mar 27, 2015 9:59 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5288
Views: 1659361

Re: RPi Cam Web Interface

Thanks dude.
Excuse my ignorance but is the correct way to do updates:
Git pull....
Then
./...sh install
Then
Sudo reboot?
by Hix
Fri Mar 27, 2015 8:22 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5288
Views: 1659361

Re: RPi Cam Web Interface

Ahhhhh, completely missed the scheduler. Thanks Rob.
Assume 0 is infinite?
by Hix
Fri Mar 27, 2015 7:10 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5288
Views: 1659361

30 second record limit in motion

I appear to have interested parties that have been checking out the nestbox I installed the PiCam into. One quick question though. It appears that when using motion, the max time for record is 30 seconds. I've checked /etc/motion/motion.conf and the relevant line - max_mpeg_time 0 seems legit. /etc/...
by Hix
Fri Mar 20, 2015 3:28 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5288
Views: 1659361

Re: RPi Cam Web Interface

another reboot but I don't see the new annotation options and the flicker still exists :/ Not sure about the rpi-update I was just passing on what I've been told. As I'd done mine manually I didn't bother with that. I'll check a bit further. The extra annotation settings are at the bottom of the li...
by Hix
Fri Mar 20, 2015 2:34 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5288
Views: 1659361

Re: RPi Cam Web Interface

Latest version now has support for v3 annotation. It defaults to using the existing v2 scheme. If one wants to try v3 you really need the /boot/start_x.elf update that also fixes the flickering size experienced by some. See recent posts about this. V3 gives extra control over the annotation, in par...
by Hix
Fri Mar 20, 2015 2:21 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5288
Views: 1659361

Re: RPi Cam Web Interface

Have you got a external feed to the stream, I'd love to see that. Well, I got rid of the flicker. But i also got rid of the entire pi. Seems something was screwed with the start_x.elf as it fails to boot now. Unfortunately it's housed in a nestbox, so there's no getting to the card now :/ missed yo...
by Hix
Fri Mar 20, 2015 2:12 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5288
Views: 1659361

Re: RPi Cam Web Interface

Great news. Thanks all,
for the efforts!
by Hix
Thu Mar 19, 2015 7:27 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5288
Views: 1659361

Re: RPi Cam Web Interface

Well, I got rid of the flicker. But i also got rid of the entire pi.
Seems something was screwed with the start_x.elf as it fails to boot now.
Unfortunately it's housed in a nestbox, so there's no getting to the card now :/
by Hix
Thu Mar 19, 2015 5:38 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5288
Views: 1659361

Re: RPi Cam Web Interface

Oh joy!
I downloaded the start_x.elf and changed it, that solved the flicker, unfortunately it's screwed the annotation
it now reads RPi Cam 4d.2.d.2.d_2d:2d:2d
I mv'd the original start_x.elf back to how it was and now I have the screwed annotation AND the flicker :/
by Hix
Thu Mar 19, 2015 5:21 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5288
Views: 1659361

Re: RPi Cam Web Interface

I have been tracking the flickering issue via the thread http://www.raspberrypi.org/forums/viewtopic.php?f=43&t=97929 as it is not a RPi Cam issue but within the low level camera software. 6by9 has found that v2 annotation which is used here had an unitialised text size variable leading to the ...
by Hix
Thu Mar 19, 2015 5:00 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5288
Views: 1659361

Re: RPi Cam Web Interface

I've sent Silvan Melchior a PM with what I found out, though I don't think it is going to be sorted anytime soon.
Apparently in the next firmware the V2/V3 errors should be fixed, though I don't know when that'll be
by Hix
Thu Mar 19, 2015 4:52 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5288
Views: 1659361

Re: RPi Cam Web Interface

Does anyone know why the datetime on top of the picture is flickering all the time ? it seems as if the font would change between larger and smaller approx. 10 times a second ... quite annoying :) It seems to be to do with the line 416 in the .c file. It references V2 and it should be updated to V3...
by Hix
Thu Mar 19, 2015 4:24 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5288
Views: 1659361

Re: RPi Cam Web Interface

Hi Robert, Just to let you know that i have installed ssmtp and after populating the field 'on_motion_detected' with the following command: mail -s “Detection” my_email_address I am now getting emails upon motion detection. :mrgreen: Sorry, ignore me, I didn't realise you had branched the code to h...
by Hix
Thu Mar 19, 2015 4:18 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5288
Views: 1659361

Re: RPi Cam Web Interface

Does anyone know why the datetime on top of the picture is flickering all the time ? it seems as if the font would change between larger and smaller approx. 10 times a second ... quite annoying :) It seems to be to do with the line 416 in the .c file. It references V2 and it should be updated to V3...
by Hix
Thu Mar 19, 2015 4:13 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5288
Views: 1659361

Re: RPi Cam Web Interface

Hi Robert, Just to let you know that i have installed ssmtp and after populating the field 'on_motion_detected' with the following command: mail -s “Detection” my_email_address I am now getting emails upon motion detection. :mrgreen: In which file should I look for the field 'on_motion_detection'?
by Hix
Sat Mar 14, 2015 1:32 pm
Forum: Camera board
Topic: RPi Cam Web Interface
Replies: 5288
Views: 1659361

Re: RPi Cam Web Interface

Hi, Firstly, thank you for all the efforts in putting this together. I'm using it to stream a camera from a nestbox in my garden. I have 2 questions though; 1. the timestamp on the viewer is flickering and changing size every ~1.2 second, is this an easy fix? 2. I'm a git noob, so if I pulled down t...
by Hix
Wed Jan 01, 2014 2:51 pm
Forum: General discussion
Topic: RasPi power usage measurements ALL Models
Replies: 156
Views: 297477

Re: RasPi power usage measurements ~2 watts at idle

I bought Model A, I don't need networking but only to write pictures and videos on SD. SleepPi is really interesting (and, let me say, a bit expensive...) but my problem is that I cannot wait at least 10s of boot time to have RPi ready. I don't need RPi always on, but I need RPi "always ready&...

Go to advanced search