Go to advanced search

by peter.shea
Fri Nov 02, 2018 1:04 pm
Forum: Networking and servers
Topic: owncloud client/server incompatibility after upgrade
Replies: 8
Views: 498

Re: owncloud client/server incompatibility after upgrade

FYI .. Sébastien has now updated the wiki tutorial, and his downloadable binaries, to v2.5.0.
by peter.shea
Fri Nov 02, 2018 12:58 pm
Forum: Networking and servers
Topic: owncloud client/server incompatibility after upgrade
Replies: 8
Views: 498

Re: owncloud client/server incompatibility after upgrade

Does this fix the Android client problem with the latest OwnClound? I have no problem from a PC (Windows and Linux) just Android. Hi, Roken, I'm not aware of any problem with the android client - the version I have on my android phone and tablet works fine for me. The version I have on my android d...
by peter.shea
Thu Nov 01, 2018 2:41 pm
Forum: Networking and servers
Topic: owncloud client/server incompatibility after upgrade
Replies: 8
Views: 498

Re: owncloud client/server incompatibility after upgrade

If anyone wants to try it with the raspberry pi desktop on a PC, it works there too. You need two different/additional installs prior to the build (qttools5-dev-tools and libqtwebkit4) and in the os-build-deb.sh file, substitute each occurrence of armhf with i386 (there are 2 of them). Obviously, in...
by peter.shea
Thu Nov 01, 2018 9:49 am
Forum: Networking and servers
Topic: owncloud client/server incompatibility after upgrade
Replies: 8
Views: 498

Re: owncloud client/server incompatibility after upgrade

OK, in the end, the answer was simple … many thanks to Sébastien Gripon, the original author of the wiki. Change the oc-build-deb.sh file so that libqtkeychain0 (>=0.1.0) reads libqtkeychain1 (>=0.7.0) and Robert is your auntie's husband, as the saying goes. All up an running. Sébastien is rebuildin...
by peter.shea
Tue Oct 30, 2018 7:42 pm
Forum: Networking and servers
Topic: owncloud client/server incompatibility after upgrade
Replies: 8
Views: 498

Re: owncloud client/server incompatibility after upgrade

… 100%! the install script needed tweeking to work (csync/src needed to be replaced by src/csync). Unfortunately, it doesn't work still … it requires a libqtkeychain0 module at runtime, which I can't install as it's been obsoleted and replaced with libqtkeychain1. Anyone any ideas how I can install ...
by peter.shea
Tue Oct 30, 2018 4:07 pm
Forum: Networking and servers
Topic: owncloud client/server incompatibility after upgrade
Replies: 8
Views: 498

Re: owncloud client/server incompatibility after upgrade

Thanks, IanS, I'll take a look. I did notice early on in the procedure that it looked for QT5, couldn't find it, so was using Qt4 instead. Maybe the ownCloud devs have not tested that with due thoroughness, or maybe the documentation (very scarce) should be updated! I'll post back when I've had a ch...
by peter.shea
Mon Oct 29, 2018 10:54 pm
Forum: Networking and servers
Topic: owncloud client/server incompatibility after upgrade
Replies: 8
Views: 498

owncloud client/server incompatibility after upgrade

I've been royally screwed! My windows machines were not syncing because the newly auto-updated client suddenly stopped talking to my old (Rpi wheezy - I know, old, but don't beat me up, it worked) ownCloud v8 server. No problem, I thought, I've been meaning to upgrade the server for some time. I upg...
by peter.shea
Thu Sep 07, 2017 4:13 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: More than 2 SPI slaves
Replies: 19
Views: 7003

Re: More than 2 SPI slaves

chrishoj:
I will be attempting a chained setup with 6 AutoDrivers in the coming weeks, and will be happy to report back how it goes.
Did you ever get this working?
by peter.shea
Sun Nov 23, 2014 12:39 pm
Forum: Troubleshooting
Topic: web2py woes
Replies: 5
Views: 2923

Re: web2py woes

Did you ever make any progress on this? I have been pulling my hair out as well? Hi, jayleonbf99, Yes, I made some progress, as per my second post. It all works if you follow the steps there. My issue is that it should really work "out of the box" without having to do anything extra. I am not sure ...
by peter.shea
Wed Nov 05, 2014 2:17 pm
Forum: Troubleshooting
Topic: web2py woes
Replies: 5
Views: 2923

Re: web2py woes

OK, following a lot more editing, I've got something working that I can access, but it all seems a bit messy! I used htpasswd to create a password for a user in a file outside of the visible area of the web (for security reasons): htpasswd -c /home/www-data/web2py.passwords www-data In the setup scr...
by peter.shea
Wed Nov 05, 2014 1:12 pm
Forum: Troubleshooting
Topic: web2py woes
Replies: 5
Views: 2923

web2py woes

Has anyone actually managed to get web2py working in the raspbian environment? I've been battling this for a few days now. I followed the instructions on http://www.instructables.com/id/Raspberry-Pi-GPIO-home-automation/ but have not yet progressed beyond step 2 (setting up the server). The instruct...
by peter.shea
Tue Nov 12, 2013 5:05 pm
Forum: Troubleshooting
Topic: Canon MP640 and CUPS
Replies: 6
Views: 1843

Re: Canon MP640 and CUPS

My networked printer (not Canon) has a http server in it. When it's connected can you ping it? Can you point a web browser at it? Can you telnet w.x.y.z 515? Can you telnet w.x.y.z 9100? From your RPi. I can ping it. I can browse it (admin pages - very limited). I can telnet to it (now I've done an...
by peter.shea
Tue Nov 12, 2013 11:33 am
Forum: Troubleshooting
Topic: Canon MP640 and CUPS
Replies: 6
Views: 1843

Re: Canon MP640 and CUPS

Some progress! After digging in the logs with debug set on, I noticed buried in the depths of reams of info a single error saying that memory couldn't be allocated. I swapped the Pi for a 512MB model - I was previously using a 256MB model - and lo and behold! Output on the printer!!! Encouraged, I u...
by peter.shea
Tue Nov 12, 2013 9:18 am
Forum: Troubleshooting
Topic: Canon MP640 and CUPS
Replies: 6
Views: 1843

Re: Canon MP640 and CUPS

Try connecting it using a powered USB hub. Hi, Dougie, thanks for your reply. I tried your suggestion, but get exactly the same result. Just to be on the safe side, I deleted the printer first and went through the process of finding it (it found it as a local printer) and re-adding it. I should hav...
by peter.shea
Mon Nov 11, 2013 6:14 pm
Forum: Troubleshooting
Topic: Canon MP640 and CUPS
Replies: 6
Views: 1843

Canon MP640 and CUPS

Has anyone managed to get this combination working? If I directly plug the device into the USB port, the CUPS admin page recognises it as the correct device, and I can configure it to use the gutenprint driver for the device (it's in the list), but any attempt to print to it simply vanishes into the...

Go to advanced search