Go to advanced search

by RandomQuestion
Fri Jan 03, 2014 1:08 pm
Forum: Troubleshooting
Topic: Gstreamer - View and Record Stream
Replies: 4
Views: 5315

Re: Gstreamer - View and Record Stream

In case anyone is interested, the code below is a simple way to get the pi to both send the stream and and record the video at the same time: raspivid -t 999999 -h 720 -w 1080 -fps 25 -hf -b 2000000 -o - | tee YOURFILENAME.h264 | gst-launch-1.0 -v fdsrc ! h264parse ! rtph264pay config-interval=1 pt=...
by RandomQuestion
Fri Jan 03, 2014 11:59 am
Forum: Troubleshooting
Topic: Gstreamer - View and Record Stream
Replies: 4
Views: 5315

Re: Gstreamer - View and Record Stream

So it looks like it is doable using the 'tee' command: http://gstreamer-devel.966125.n4.nabble.com/Stream-video-and-save-on-file-td4663134.html The code that worked for these guys was: gst-launch -v -e --gst-plugin-path=/usr/local/lib/gstreamer-0.10/ v4l2src device=/dev/video0 ! 'video/x-raw-yuv,wid...
by RandomQuestion
Fri Jan 03, 2014 11:42 am
Forum: Troubleshooting
Topic: Gstreamer - View and Record Stream
Replies: 4
Views: 5315

Re: Gstreamer - View and Record Stream

jamesh wrote:Can you use the 'tee' command to split the stream and redirect to file and to where ever else?
Embarrassed to say that I know nothing about the 'tee' command. I am looking it up now...
by RandomQuestion
Fri Jan 03, 2014 11:28 am
Forum: Troubleshooting
Topic: Gstreamer - View and Record Stream
Replies: 4
Views: 5315

Gstreamer - View and Record Stream

Hi there. I know nothing about using Gstreamer and have just picked up some code from the web. I am transmitting video from a headless pi by to my laptop via ssh using the following: raspivid -vf -t 999999 -h 720 -w 1080 -fps 25 -hf -b 2000000 -o - | gst-launch-1.0 -v fdsrc ! h264parse ! rtph264pay ...
by RandomQuestion
Sun Nov 10, 2013 10:07 pm
Forum: Troubleshooting
Topic: Wifi won't start at boot / restart
Replies: 7
Views: 9033

Re: Wifi won't start at boot / restart

I have found a temporary fix for anyone who is having similar problems: http://unix.stackexchange.com/questions/93063/i-always-need-to-ifdown-ifup-wlan0-after-reboot I added the following to /etc/rc.local ifdown wlan0 ifup wlan0 Its a pretty messy fix so if anyone can suggest anything better please ...
by RandomQuestion
Sun Nov 10, 2013 9:23 pm
Forum: Troubleshooting
Topic: Wifi won't start at boot / restart
Replies: 7
Views: 9033

Re: Wifi won't start at boot / restart

Also I don't know if it has any relevance but I used ifup wlan0 and iwconfig and got this: wlan0 IEEE 802.11bgn ESSID:"Home" Mode:Managed Frequency:2.412 GHz Access Point: 40:CB:A8:5D:3F:A0 Bit Rate=6.5 Mb/s Tx-Power=20 dBm Retry long limit:7 RTS thr:off Fragment thr:off Power Management:on Link Qua...
by RandomQuestion
Sun Nov 10, 2013 8:22 pm
Forum: Troubleshooting
Topic: Wifi won't start at boot / restart
Replies: 7
Views: 9033

Re: Wifi won't start at boot / restart

Are you connecting both eth0 and wlan0 simultaneously? Thank you for the help. I don't have a monitor so the pi is plugged into the router. Trying to set up Wifi over SSH so I can move it. As soon as that is set up I won't need eth0 any more. Changed as you advised: auto lo iface lo inet loopback i...
by RandomQuestion
Sun Nov 10, 2013 8:02 pm
Forum: Troubleshooting
Topic: Wifi won't start at boot / restart
Replies: 7
Views: 9033

Wifi won't start at boot / restart

Hi there, Can anyone please advise me on how to get my wifi to start up at boot? I am running the latest version of Raspbian and set up my wifi using this guide: http://kerneldriver.wordpress.com/2012/10/21/configuring-wpa2-using-wpa_supplicant-on-the-raspberry-pi/ My network interfaces file: auto l...
by RandomQuestion
Sat Nov 02, 2013 3:38 pm
Forum: Troubleshooting
Topic: Crashing Non-Stop
Replies: 15
Views: 2188

Re: Crashing Non-Stop

It's possible the Pi is faulty. I've never seen a screen go black due to software issue I thought that the black screen might have had something to do with this, as the new SD is a SanDisk: http://www.raspberrypi.org/phpBB3/viewtopic.php?p=430499 I went back to my Windows machine and used the SD Fo...
by RandomQuestion
Sat Nov 02, 2013 2:13 pm
Forum: Troubleshooting
Topic: Crashing Non-Stop
Replies: 15
Views: 2188

Re: Crashing Non-Stop

Back to square one. I bought a new SanDisk Ultra 16GB SD card. Used the normal process got getting NOOBs 1.3.2 on it: http://www.raspberrypi.org/downloads Rasbpian will start installing. First time round it got to about 50% when the screen went black - No signal. Had solid red and solid green light....
by RandomQuestion
Fri Nov 01, 2013 9:20 pm
Forum: Troubleshooting
Topic: Crashing Non-Stop
Replies: 15
Views: 2188

Re: Crashing Non-Stop

Can anyone recommend a good card? I was thinking of something like this:
http://www.ryman.co.uk/1490040003/SanDi ... GB/Product

Any thoughts?
by RandomQuestion
Fri Nov 01, 2013 8:26 pm
Forum: Troubleshooting
Topic: Crashing Non-Stop
Replies: 15
Views: 2188

Re: Crashing Non-Stop

So.. PiWriter worked like a charm. Got Raspian up and running. Made my changes in config and then rebooted. Didn't actually turn back on. Got a solid red light. Ignored it. Power out and then back in. Managed to give it a static IP. Logged in using SSH. Seemed to work fine. "Host is down" after a co...
by RandomQuestion
Fri Nov 01, 2013 6:34 pm
Forum: Troubleshooting
Topic: Crashing Non-Stop
Replies: 15
Views: 2188

Re: Crashing Non-Stop

That thread was resolved as being specifically about 16GB Sandisk cards, and a beta of a fixed version has been released and acknowledged by the poster on that thread as satisfactory. I noticed this but was hoping that the fix might have worked on my Sandisk card. Wishful (and uneducated) thinking ...
by RandomQuestion
Fri Nov 01, 2013 6:06 pm
Forum: Troubleshooting
Topic: Crashing Non-Stop
Replies: 15
Views: 2188

Re: Crashing Non-Stop

Can you try power from the power supply direct to the Pi itself? Not via the hub. It may be the hub output isn't powerful enough (500mA). Remove all other devices and plug keyboard direct in to Pi, just leaving that and the HDMI and SD card inserted. I cannot try power from the power supply direct ...
by RandomQuestion
Fri Nov 01, 2013 5:02 pm
Forum: Troubleshooting
Topic: Crashing Non-Stop
Replies: 15
Views: 2188

Re: Crashing Non-Stop

Method 1 Switching power adapter is: Model : dve dsa-15p-05 uk 050125 Output: 5V, 2.5A This feeds a belkin usb 2.0 7-port mobile powered hub F4U018-BLK. Standard Usb to micro usb from hub to pi. Method 2 2200mAh version: http://thepihut.com/products/portable-power-pack-for-the-raspberry-pi Have tri...
by RandomQuestion
Fri Nov 01, 2013 4:44 pm
Forum: Troubleshooting
Topic: Crashing Non-Stop
Replies: 15
Views: 2188

Crashing Non-Stop

Hi there, I am trying to install an OS on the Pi. I have tried using NOOBS 1.3 but I get a black screen a couple seconds into the Raspbian instillation. A quick search shows that I am not the only one with problems: http://www.raspberrypi.org/phpBB3/viewtopic.php?f=28&t=57125&hilit=noobs+1.3+crash I...
by RandomQuestion
Mon Oct 14, 2013 3:29 pm
Forum: Troubleshooting
Topic: Pi Cam Quick Streaming over Network
Replies: 2
Views: 1763

Pi Cam Quick Streaming over Network

Hi there, I know this has been asked a couple times but I have yet to find the "best" solution. I would like to be able to stream video from the raspberry pi cam over a wireless network to a computer. This does not necessarily need to be accessible outside my home network (so uploading to a web serv...
by RandomQuestion
Thu Oct 03, 2013 4:52 pm
Forum: Troubleshooting
Topic: Pi Cam and OMXPlayer
Replies: 1
Views: 1697

Re: Pi Cam and OMXPlayer

Okay so I found my answer: http://www.raspberrypi.org/phpBB3/viewt ... 43&t=48060.

Is there any way to see hardware-accelerated stuff when the pi is headless?
by RandomQuestion
Thu Oct 03, 2013 4:43 pm
Forum: Troubleshooting
Topic: Pi Cam and OMXPlayer
Replies: 1
Views: 1697

Pi Cam and OMXPlayer

So I am having some issues with the Pi Cam and OMXplayer. When I VNC into the Pi using TightVNC and run the command: raspistill -v -o test.jpg I get the following output but no preview: raspistill Camera App v1.2 Width 2592, Height 1944, quality 85, filename test.jpg Time delay 5000, Raw no Thumbnai...
by RandomQuestion
Sun Sep 29, 2013 8:02 pm
Forum: Troubleshooting
Topic: Large Ping Times - Headless
Replies: 2
Views: 1267

Re: Large Ping Times - Headless

Its now working fine. Getting nice low ping times. I powered it down for the night and when I rebooted it in the morning it worked like a charm. Strange. Thanks for the suggestion though. Putty and TightVnc are working great!
by RandomQuestion
Sat Sep 28, 2013 6:32 pm
Forum: Troubleshooting
Topic: Large Ping Times - Headless
Replies: 2
Views: 1267

Large Ping Times - Headless

Hi there. I am a complete novice with the Pi and Linux. I am trying to set up the Pi headless so that I can login to it remotely from anywhere. So far I have: Installed NOOBS - Rasbian Updated my PI (apt-get update , apt-get upgrade) Set a static IP address (https://www.modmypi.com/blog/tutorial-how...

Go to advanced search