Go to advanced search

by foul_owl
Tue Jul 23, 2019 5:08 am
Forum: Troubleshooting
Topic: Defective gpio?
Replies: 1
Views: 107

Defective gpio?

I have two rpi zero ws. One is connected to some neopixels, using pins 1,2,6,12. Using a level shift circuit. I tried running strandtest.py on RPi A, it works great. Tried the same with RPi B, no output. I kept the same neopixels, just swapped the rpis. I then tried putting the sd card from RPi A in...
by foul_owl
Sat Jul 20, 2019 10:58 pm
Forum: Beginners
Topic: Do I need a series resistor using gpio pins for inputs?
Replies: 5
Views: 304

Re: Do I need a series resistor using gpio pins for inputs?

So I would strongly prefer to omit the series resistors if they are not needed. Is that acceptable? It's up to you, or anyone else that will use it, whether it's acceptable or not. The series resistors are protection in case the GPIO pins are configured as output and the switch is closed. The conse...
by foul_owl
Sat Jul 20, 2019 10:56 pm
Forum: Beginners
Topic: Do I need a series resistor using gpio pins for inputs?
Replies: 5
Views: 304

Re: Do I need a series resistor using gpio pins for inputs?

would prefer to not have any resistors hanging directly off one side of the switch, it's a bit annoying and a design weakness imo. It is not a design weakness. If series resistors were designed in, the current available from GPIOs when used as outputs would be markedly less. I meant it's a design w...
by foul_owl
Thu Jul 18, 2019 11:24 pm
Forum: Beginners
Topic: Do I need a series resistor using gpio pins for inputs?
Replies: 5
Views: 304

Do I need a series resistor using gpio pins for inputs?

I'm trying to connect 20 buttons to my rpi. The buttons will connect the gpio pin to ground if pressed, or float if not pressed. I use the internal pull up resistors then to avoid the float, like so: GPIO.setup(11, GPIO.IN, pull_up_down=GPIO.PUD_UP) (et al) which works great. But I'm currently using...
by foul_owl
Mon Jul 01, 2019 12:27 am
Forum: Troubleshooting
Topic: apt update hangs
Replies: 0
Views: 53

apt update hangs

It's stuck on:

Code: Select all

99% [4 Contents-armhf store 0 B]
It is stuck for hours.

Speedtest shows 12Mb down.

How do I fix this?

RPi Zero W.
by foul_owl
Thu Jun 27, 2019 4:36 am
Forum: Beginners
Topic: Replacement bolts for infrared pi camera?
Replies: 1
Views: 295

Replacement bolts for infrared pi camera?

I'm an idiot and I lost two of the bolts that came with the infrared camera. (the ones that attach the light and photocell to the main camera board)

I have a huge junk box of bolts but of course none of them fit.

Where can I order replacements?
by foul_owl
Wed Jun 12, 2019 8:06 am
Forum: General discussion
Topic: Running an RPI outside?
Replies: 12
Views: 621

Re: Running an RPI outside?

Please don't worry about the 3d printed aspect of this, my tests have been completely water tight.

Plus primer, several coats of paint, and several coats of polyurethane. It will be fine.

What about the power supply though?
by foul_owl
Wed Jun 12, 2019 5:21 am
Forum: General discussion
Topic: Running an RPI outside?
Replies: 12
Views: 621

Running an RPI outside?

I have an outdoor grade extension cord, but how do you get from the extension cord to the rpi? I was going to 3d print an enclosure but I'm guessing no common wall wart style supplies are rated for outdoors. I'm guessing the usb connector needs to be completely sealed so I'm planning on that and not...
by foul_owl
Thu Oct 11, 2018 7:34 pm
Forum: Troubleshooting
Topic: amsynth delay
Replies: 4
Views: 404

Re: amsynth delay

Bump. Thank you!
by foul_owl
Mon Oct 08, 2018 3:27 am
Forum: Troubleshooting
Topic: amsynth delay
Replies: 4
Views: 404

Re: amsynth delay

Bump. Still can't get this working. Thank you!
by foul_owl
Sun Sep 30, 2018 1:59 am
Forum: Troubleshooting
Topic: amsynth delay
Replies: 4
Views: 404

Re: amsynth delay

Bump...any thoughts on this?

I know plenty of people use an rpi as a soft synth, so I'm not sure what could be going on with my system.

Thanks!
by foul_owl
Thu Sep 27, 2018 3:57 am
Forum: Troubleshooting
Topic: amsynth delay
Replies: 4
Views: 404

amsynth delay

I'm getting a ~1 second delay with amsynth on my rpi 3b. Fresh install of latest raspbian. Adjusting the niceness does not help. Repro with: sudo apt install amsynth vkeybd -y amsynth utils ... virtual keyboard Go nuts! It's a really fun program. Obviously though, delay with a musical application is...
by foul_owl
Mon Jul 23, 2018 5:25 pm
Forum: Beginners
Topic: Creating a bridge for LXC
Replies: 9
Views: 1013

Re: Creating a bridge for LXC

I did:
sudo systemctl stop dhcpcd

and I lost networking on my system.

What is the correct way to do things here?
by foul_owl
Thu Jul 19, 2018 7:45 pm
Forum: Beginners
Topic: Creating a bridge for LXC
Replies: 9
Views: 1013

Re: Creating a bridge for LXC

Disable dhcpcd?

I realize I can do this, and revert to "standard" Debian style networking, but I am trying to learn the correct, rpi way to do things here.
by foul_owl
Thu Jul 19, 2018 1:05 am
Forum: Beginners
Topic: Creating a bridge for LXC
Replies: 9
Views: 1013

Creating a bridge for LXC

LXC needs a bridge interface in order to get networking on containers without NAT. Running latest Raspbian. Contents of: /etc/network/interfaces.d/br0: auto br0 iface br0 inet static bridge_ports wlan0 address 192.168.0.35 netmask 255.255.255.0 gateway 192.168.0.1 wpa-conf /etc/wpa_supplicant/wpa_su...
by foul_owl
Tue Jan 03, 2017 8:25 am
Forum: Troubleshooting
Topic: [Solved] Mouse lag
Replies: 9
Views: 5600

Re: Mouse lag

My mistake! (And I forgot to update)

I dumped that line into config.txt, not cmdline.txt!

Sorry about that!
by foul_owl
Mon Jan 02, 2017 5:33 am
Forum: Troubleshooting
Topic: Extreme amount of webcam lag
Replies: 1
Views: 760

Extreme amount of webcam lag

Hi folks, Running an rpi2 with the pi camera. wifi card is RTL8188CUS. Getting about 0.1-0.5 fps with the camera stream in octoprint (ie, just hitting <ip>:8080/?action=stream) I'm guessing the culprit is network lag, as the cpu load is reported as 0.1, and getting some latency with ssh. What tool c...
by foul_owl
Mon Nov 28, 2016 4:31 am
Forum: Troubleshooting
Topic: [Solved] Mouse lag
Replies: 9
Views: 5600

Re: Mouse lag

Well...I thought it was fixed.

The other day my system didn't boot, so I wiped it and installed a fresh image.

Now the mouse is back to being super laggy.

I added that line back in, but the mouse is still just as laggy.

Any ideas?

Thanks!
by foul_owl
Thu Sep 22, 2016 9:35 pm
Forum: Troubleshooting
Topic: [Solved] Mouse lag
Replies: 9
Views: 5600

Re: Mouse lag

No USB 3.0.

I actually found a fix, which is to append:

Code: Select all

usbhid.mousepoll=0
to /boot/cmdline.txt

I wonder why that isn't default?

Thanks!
by foul_owl
Wed Sep 21, 2016 11:52 pm
Forum: Troubleshooting
Topic: [Solved] Mouse lag
Replies: 9
Views: 5600

[Solved] Mouse lag

Hi folks,

Brand new Tecknet wireless mouse. It works fine on my Debian 8 x86 desktop, but lags by about 2 seconds or so on my RPi 2b.

What could be going on with the rpi that would cause this?

Thanks!
by foul_owl
Mon Jan 18, 2016 6:41 pm
Forum: Beginners
Topic: Cheapest off the shelf powered usb hub?
Replies: 2
Views: 681

Re: Cheapest off the shelf powered usb hub?

I saw those and was considering getting one, but I wasn't sure if I would have the same problem as the other hubs I bought. Thanks for the recommendation!

I actually prefer backpowering as well. What's the downside, if any?
by foul_owl
Thu Jan 14, 2016 12:32 am
Forum: Beginners
Topic: Cheapest off the shelf powered usb hub?
Replies: 2
Views: 681

Cheapest off the shelf powered usb hub?

Hi folks, I have seen this page: http://elinux.org/RPi_Powered_USB_Hubs But it seems to be a mishmash of random old hardware. I'm trying to find the cheapest four port hub I can buy off the shelf (say from newegg) that can supply a decent amount of peripherals and doesn't backfeed. Basically I'm try...
by foul_owl
Wed Jun 10, 2015 7:20 pm
Forum: Beginners
Topic: Static IP with wifi
Replies: 1
Views: 353

Static IP with wifi

Hi folks, How do I set up a static IP with my wifi card? Here's my current interfaces file: auto lo iface lo inet loopback iface eth0 inet dhcp allow-hotplug wlan0 iface wlan0 inet manual wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf iface default inet dhcp Since the only item using dhcp is "defa...
by foul_owl
Mon Jun 08, 2015 10:11 pm
Forum: Beginners
Topic: Powering RPi via USB hub
Replies: 5
Views: 639

Powering RPi via USB hub

Hi folks, I have a USB hub that is connected to the single port on my A+. This USB hub is powered by a DC adapter. However, I have _no_ connection going to the micro usb connector on the A+ board, yet my RPi is powered on! It's a really cool feature, but unsure if this is intentional or not. 1. Is t...
by foul_owl
Sat Jun 06, 2015 2:02 am
Forum: Beginners
Topic: Cheapest webcam for RPi?
Replies: 1
Views: 1132

Cheapest webcam for RPi?

Hi folks,

I need a really cheap webcam for my OctoPi server. What's the cheapest webcam that works with Debian on the RPi? Resolution can be dismal, I just need to ensure my print hasn't gone south.

Thanks!!

Go to advanced search