Go to advanced search

by leopheard
Tue Feb 12, 2019 3:23 am
Forum: Networking and servers
Topic: Email external IP address
Replies: 27
Views: 54323

Re: Email external IP address

Only a quick thing to add, but I wanted to add that in the email script .sh file, I had the following as the first few lines: #!/bin/sh SUBJ="Home IP" EMAIL="[email protected].com" It turns out that the recipient email entered in the email part above AND the subject were being used as addresses to mai...
by leopheard
Wed Aug 09, 2017 2:03 pm
Forum: General discussion
Topic: cgminer on raspberrian
Replies: 15
Views: 65225

Re: cgminer on raspberrian

ukanonymous wrote:
Sun Jul 07, 2013 12:55 pm
If anyone can help me to get cgminer running on my pi I will give them 0.5 bit coins
Seeing as 0.5 BTC is currently around $1,600 USD, can I offer any help! :D
by leopheard
Sat Jul 29, 2017 1:08 am
Forum: Beginners
Topic: Autostart terminal window to be kept open after command
Replies: 3
Views: 1109

Re: Autostart terminal window to be kept open after command

W. H. Heydt wrote:
Sat Jul 29, 2017 12:19 am

Code: Select all

lxterminal --geometry=58x6 -e mplayer -cache 512 -volume 100 -playlist http://payerservices.streamtheworld.com/pls/KDFCFMAAC.pls
Aaah thanks, was it the -t or was it the Terminal=false ?
by leopheard
Fri Jul 28, 2017 11:39 pm
Forum: Beginners
Topic: Autostart terminal window to be kept open after command
Replies: 3
Views: 1109

Autostart terminal window to be kept open after command

Hi all, I'm trying to get the RPi to autostart a terminal window, run a command and keep it open indefinitely. I've made the following .desktop file to add the to autostart section of 'default apps for lxsession': [Desktop Entry] Name=BFGMiner Comment=Run BFGMiner Icon=/usr/share/pixmaps/openbox.xpm...
by leopheard
Tue Jun 27, 2017 7:44 am
Forum: Troubleshooting
Topic: Unable to expand file system
Replies: 2
Views: 561

Unable to expand file system

Hi all, To clear some space I unfortunately used Bleachbit but must have cleared something to do with the FS being expanded like when you first do it through Raspi-config when you do the initial setup. Unfortunately, the RPi boots into a black screen and even if I press Ctrl+alt+F2 it comes up with ...
by leopheard
Thu Jun 22, 2017 11:38 pm
Forum: Troubleshooting
Topic: su login: root account is locked, starting shell
Replies: 5
Views: 3629

Re: su login: root account is locked, starting shell

Not sure if this is the same issue, but I just had the same issue after trying to get the RPi1 to auto-mount a USB attached HDD /etc/fstab. I'm not sure exactly, what I did, but adding the line: /dev/sda1 /mnt/foldertomountto ext4 defaults 0 0 seemed to case the boot process to fail. One or all of t...
by leopheard
Thu May 18, 2017 4:34 am
Forum: Troubleshooting
Topic: Right ethernet cable to use for Raspberry Pi (1)
Replies: 4
Views: 1560

Right ethernet cable to use for Raspberry Pi (1)

Hi all, I'm a bit confused re: the right ethernet cable to use with my RPi (version 1). This laptop is connected with what I assume is a crossover cable from its ethernet port to a switch, which itself goes into the gateway/modem. I understand it's basically crossover for connecting a switch / hub t...
by leopheard
Thu May 18, 2017 4:15 am
Forum: Automation, sensing and robotics
Topic: Automating a web page
Replies: 1
Views: 582

Automating a web page

Hi all, I was wondering, would it be possible to automate a webpage to simply click on a box? The KODI box I use sometimes needs me to simply go to a webpage to authorise the feed for 3 hours. The thing is, it often doesn't ask the 'are you a human' question so I'm thinking would there be a way to a...
by leopheard
Thu May 18, 2017 4:06 am
Forum: Media centres
Topic: Media server pi3
Replies: 3
Views: 1475

Re: Media server pi3

It sounds like this is exactly what you're after:
https://www.mythtv.org/wiki/MythTV_Light

or at least Kodi does the same PVR/DVR thing
by leopheard
Wed Jun 15, 2016 12:35 am
Forum: Beginners
Topic: login / startx automatically
Replies: 2
Views: 953

login / startx automatically

Once again, I setup my RPi, worked for a few days and now it's inexplicably asking for a login. I've tried all combinations and nothing is accepted. I can't login to a terminal as it goes straight into the GUI and editing the /etc/inittab isn't possible as it's not there when I put the SD card in my...
by leopheard
Mon Apr 14, 2014 10:34 pm
Forum: Raspbian
Topic: Autostart commands in terminal window after boot
Replies: 2
Views: 831

Autostart commands in terminal window after boot

Hi all, How would I go about making a program autorun in a terminal window (and remaining visible) after boot? I'd like to run some Cryptocurrency mining software (BFGminer), have it still visible so I can see it's still mining and also run at a higher memory priority? Would I need to make a script ...
by leopheard
Mon Apr 14, 2014 10:22 pm
Forum: Raspbian
Topic: Auto boot x11vnc issue
Replies: 5
Views: 1868

Re: Auto boot x11vnc issue

I personally use TightVNC server as X11 just knackered my RPi time and time again. It depends what the issue is, is the RPi booting up okay after the power off then on? A good guide here: http://elinux.org/RPi_VNC_Server There is an easier alternative to the autostart section though, I did as follow...
by leopheard
Sun Mar 02, 2014 11:46 am
Forum: Other projects
Topic: Unable to run Peercoin mining software - command not found
Replies: 1
Views: 1007

Unable to run Peercoin mining software - command not found

Hi all, I'm trying to run Peercoining mining software on my RPi. As per http://peercoin.net/downloads I've done the following: Unpack ppcoin-0.3.0-linux.tar.gz Run bin/32/ppcoin-qt (requires libqt4-gui) Create ppcoin.conf in ~/.ppcoin Run bin/32/ppcoind Your wallet is located in ~/.ppcoin. I've done...
by leopheard
Thu Feb 13, 2014 12:14 am
Forum: Beginners
Topic: Using dd to backup a PI SD
Replies: 31
Views: 214495

Re: Using dd to backup a PI SD

dd if=/dev/mmcblk0 of=/some/file/name/here BS=1M That reads the raw device and creates a complete (fuzzy) image of all partitions. It's fuzzy because the filesystem is in use while you're doing it. Cheers Dougie, I have given that a try and it appears to be churning away. Only diff. is that I came ...
by leopheard
Wed Feb 12, 2014 11:54 pm
Forum: Beginners
Topic: Using dd to backup a PI SD
Replies: 31
Views: 214495

Re: Using dd to backup a PI SD

I'm unsure how I would get this to work in one go when my SD card with Raspbian on is in two partitions:

/dev/mmcblk0p0
/dev/mmcblk0p1

The former containing the boot data.

Any ideas?
by leopheard
Mon Feb 03, 2014 3:27 pm
Forum: Troubleshooting
Topic: CUPS printing issues - garbage text
Replies: 0
Views: 569

CUPS printing issues - garbage text

Hi all, I have so far install CUPS and have it running on a local port at a set IP. I have installed the printer (HP Laserjet 6MP) using the PPD file various times and others using the Gutenprint / CUPs suggestions. I know this printer works on a RPi using Raspbian as I've done it a few weeks ago (a...
by leopheard
Thu Jan 30, 2014 9:24 pm
Forum: General discussion
Topic: Unable to install git
Replies: 13
Views: 3926

Re: Unable to install git

Think I solved it, was a permission issue with some backup file:

http://www.raspberrypi.org/forum/viewto ... 08#p496508

Thanks anyway! Your solution may solve it next time, as I'm sure I'll still have a few issues with this thing!
by leopheard
Thu Jan 30, 2014 9:16 pm
Forum: Troubleshooting
Topic: Making RPi boot into LXDE desktop
Replies: 2
Views: 646

Re: Making RPi boot into LXDE desktop

I have tried this (option going straight to the GUI logged in), but it still comes up with the same session / frontend?
by leopheard
Wed Jan 29, 2014 11:10 pm
Forum: Troubleshooting
Topic: Making RPi boot into LXDE desktop
Replies: 2
Views: 646

Making RPi boot into LXDE desktop

Hi all, As per my other post today http://www.raspberrypi.org/phpBB3/viewtopic.php?f=28&t=68010 - whatever issue caused my LXDE software to become messed up is now not totally fixed as it automatically boots into the (what I assume) is a stadnard Debian interface rather than the LXDE. How do I make ...
by leopheard
Wed Jan 29, 2014 10:28 pm
Forum: Troubleshooting
Topic: apt-get dependency / permission issues
Replies: 0
Views: 1065

apt-get dependency / permission issues

Hi all, I actually managed to fix a problem fairly simply, so I wanted to post it here incase anyone else had the same issue. I can't remember how it happened, but lxappearance wouldn't update properly and consequently, the frontend desktop LXDE wouldn't boot as the above was a dependency for it. Th...
by leopheard
Wed Jan 29, 2014 8:06 pm
Forum: Troubleshooting
Topic: Pi keeps powering off
Replies: 10
Views: 1170

Re: Pi keeps powering off

What lights on the board are on when this happens and are any flashing?
by leopheard
Sun Jan 26, 2014 3:05 pm
Forum: General discussion
Topic: Unable to install git
Replies: 13
Views: 3926

Re: Unable to install git

I kept having the above problem but with a package called 'lxappearance'. I tried : sudo rm /var/lib/dpkg/info/lxapperance.list sudo apt-get install --reinstall lxapperance But hasn't worked as I now get: sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state infor...
by leopheard
Thu Jan 23, 2014 3:40 am
Forum: Troubleshooting
Topic: Can't Get VNCServer to Autostart
Replies: 19
Views: 22984

Re: Can't Get VNCServer to Autostart

I found this document http://help.directadmin.com/item.php?id=379 where is explained that it's just a warning. Today I will try to remove the: #!/bin/sh because it's the only difference with the example of the script on the link. Thanks for that, although it explains why a bit, their solution is to...
by leopheard
Sun Jan 05, 2014 6:51 pm
Forum: Raspbian
Topic: Change screen resolution over VNC
Replies: 16
Views: 61783

Re: Change screen resolution over VNC

To login, I type: xtightvncviewer 192.168.0.12:1 (password then logs in fine) But then have to open a terminal on the RPi and type: xtightvncserver -geometry 1280x800 -depth 16 then logout and back in under: xtightvncviewer 192.168.0.12:2 to be able to view it at a resolution I can work with. Is the...
by leopheard
Sun Jan 05, 2014 6:39 pm
Forum: Troubleshooting
Topic: Not recognizing USB devices?
Replies: 6
Views: 1106

Re: Not recognizing USB devices?

I doubt all your pieces of kit are all faulty - I've had problems with two things: 1) Too many USB devices drawing too much power (which is why some use a powered USB hub) but more importantly 2) the RPi not recognising a device when plugged in via a hub. I've plugged a few things in directly and th...

Go to advanced search