Go to advanced search

by skywatch
Tue Nov 12, 2019 5:37 pm
Forum: Troubleshooting
Topic: Rpi 3B+ network crashing?
Replies: 6
Views: 174

Re: Rpi 3B+ network crashing?

Thanks - after 5 hours running vcgencmd get_throttled gives 0x0 - So seems OK then ?
by skywatch
Tue Nov 12, 2019 4:12 pm
Forum: Troubleshooting
Topic: Rpi 3B+ network crashing?
Replies: 6
Views: 174

Re: Rpi 3B+ network crashing?

@ejolson Thanks for the tips. vcgencmd won't return anything on it's own, will it? :?: Still, I have today changed the power connectors used on this and another pi that has had 'issues' recently. Maybe a batch of out of tolerance connectors? Only time will tell.....until then the mystery remains. ;)
by skywatch
Tue Nov 12, 2019 12:14 pm
Forum: Troubleshooting
Topic: Rpi 3B+ network crashing?
Replies: 6
Views: 174

Rpi 3B+ network crashing?

I have been trying to solve the issue of a pi 3B+ 'crashing' after a few days or weeks. :evil: I have used various power supplies (3A and 6A) as well as different power cables. The pi boots and runs from an SSD so should not be due to SD card corruption. Today I found it had stopped responding to ht...
by skywatch
Sat Apr 27, 2019 10:35 am
Forum: Troubleshooting
Topic: Raspberry Pi "crashes", unable to SSH until hard reboot
Replies: 5
Views: 400

Re: Raspberry Pi "crashes", unable to SSH until hard reboot

In my case the pi will run for days or weeks without a problem and then it stops responding to all network traffic. No response to ping No response to http No response to ssh The pi just sits there until I force a reboot by pulling the power and waiting 30 seconds and reconnecting power. Then it all...
by skywatch
Sat Apr 27, 2019 10:32 am
Forum: Troubleshooting
Topic: Raspberry pi 3 just stops responing.
Replies: 5
Views: 290

Re: Raspberry pi 3 just stops responing.

Anyone can help please?

Seems like the same issue reported here also viewtopic.php?f=28&t=238211&p=1458468#p1458468
by skywatch
Sun Apr 21, 2019 11:02 am
Forum: Troubleshooting
Topic: Raspberry Pi "crashes", unable to SSH until hard reboot
Replies: 5
Views: 400

Re: Raspberry Pi "crashes", unable to SSH until hard reboot

I have the same issue with wired rpi 3 model b units (two of them doing it).
by skywatch
Sun Apr 21, 2019 10:50 am
Forum: Troubleshooting
Topic: Why do I receive unreadable data via serial Port on Raspberry Pi?
Replies: 3
Views: 237

Re: Why do I receive unreadable data via serial Port on Raspberry Pi?

Serial on pi 3 version is not as stable as previous models of pi in my experience.

I suggest you get a serial to usb adaptor (about $1 or so) and try using that instead.
by skywatch
Sat Apr 20, 2019 7:58 pm
Forum: Troubleshooting
Topic: Raspberry pi 3 just stops responing.
Replies: 5
Views: 290

Re: Raspberry pi 3 just stops responing.

Thanks for the reply. The green LED flashing means it's not booted. Which green flashing led? The network one or the activity one? How does it become 'not booted' after days or weeks of running? What is the likely process for this please? The stuff on your SDCard is either not correctly written or t...
by skywatch
Sat Apr 20, 2019 10:26 am
Forum: Troubleshooting
Topic: Raspberry pi 3 just stops responing.
Replies: 5
Views: 290

Raspberry pi 3 just stops responing.

For some reason this happens regularly to me. SETUP AND WHAT I HAVE DONE SO FAR....... rpi 3 running latest and updated raspbian from usb connected Kingston ssd hdd (previously tried several brand new Sandisk uSD cards and same result). Tried many different power cables and power supplies. Now using...
by skywatch
Wed Dec 19, 2018 10:20 am
Forum: Advanced users
Topic: Rpi3 B SSD boots but won't reboot....?
Replies: 3
Views: 1073

Re: Rpi3 B SSD boots but won't reboot....?

Thank you both for your suggestions. The full upgrade didn't seem to do it, so I replaced the sata-usb cable with a sata-usb clam shell enclosure. Now it works fine, so maybe a different chip in the sata-usb case? I will leave it like it is now and maybe try some more after the festive season ends! ...
by skywatch
Tue Dec 18, 2018 11:07 am
Forum: Advanced users
Topic: Rpi3 B SSD boots but won't reboot....?
Replies: 3
Views: 1073

Rpi3 B SSD boots but won't reboot....?

Hi all, I have a pi3B which boots fine from power on with a Kingston A400 120Gb SSD and latest raspbian image fully updated. It works like a charm until I go to reboot it, then it always just seems to hang and I need to manually cycle the power to get it back on. At this point it boots fine. Can any...
by skywatch
Wed May 25, 2016 9:14 pm
Forum: Graphics, sound and multimedia
Topic: Pi with MCLK - Will it ever happen?
Replies: 1
Views: 812

Pi with MCLK - Will it ever happen?

Hi all,

Just wondering if we are ever likely to see a rpi with MCLK for use with high end I2S DAC boards?
As far as I can see there is no way to use them on the current range of pi boards released?

Cheers! :)

S.
by skywatch
Thu May 05, 2016 6:15 pm
Forum: Device Tree
Topic: Upcoming Device Tree changes
Replies: 62
Views: 20780

Re: Upcoming Device Tree changes

@skywatch The next Raspbian release (being prepared now) will include changes to the DTBs, overlays, utilities and lxpanel to make it possible to dynamically load and remove audio devices. There are almost bound to be some problem cases, but we'll be a few steps closer to a system that is fully rec...
by skywatch
Sat Apr 23, 2016 10:19 pm
Forum: Device Tree
Topic: Upcoming Device Tree changes
Replies: 62
Views: 20780

Re: Upcoming Device Tree changes

Well at least that is better than "No way will it ever work" ;) I would imagine that this could pave the way to plug and play on linux at some point? If you want any help testing it out, let me know (but I will need some clear instructions on what to do)! Thanks for the update and your time on this ...
by skywatch
Thu Apr 21, 2016 6:04 pm
Forum: Device Tree
Topic: Upcoming Device Tree changes
Replies: 62
Views: 20780

Re: Upcoming Device Tree changes

@Dirks No need to swap modules. The stereo dac only has 3 I2S wires to it and so I should be able to wire this in parallel with the digi board. Then, when I want 5.1 sound I load the hifiberry-digi and select passthrough in kodi. This is already tested on it's own. If I want better quality stereo, I...
by skywatch
Wed Apr 20, 2016 8:14 pm
Forum: Device Tree
Topic: Upcoming Device Tree changes
Replies: 62
Views: 20780

Re: Upcoming Device Tree changes

This looks very interesting for my application....But would it work? I currently have 2xpi (1 for music with a I2S dac and another with digi dac for surround sound on films). I have to do this as I cannot get both dacs to work with a single DT overlay. So my question is this, could I add a script to...
by skywatch
Mon Mar 28, 2016 12:13 pm
Forum: Beginners
Topic: Problem Putty SSH passwordless
Replies: 9
Views: 2064

Re: Problem Putty SSH passwordless

Please check permissions on the authorized_keys file and the .ssh directory.

If that fails, try removing " rsa-key-20111111" from the end of the file. It may be the extra characters causing a problem. I remember doing this a few years back, but maybe not needed now, still it is worth a try!
by skywatch
Sun Feb 21, 2016 8:00 pm
Forum: General programming discussion
Topic: Pi-toPi communication via SSH possible?
Replies: 2
Views: 716

Re: Pi-toPi communication via SSH possible?

So a simple bash/cron script is all I need then?

So it would be ......

SSH 192.168.x.x "sudo poweroff"

Thank you! :D
by skywatch
Sun Feb 21, 2016 7:45 pm
Forum: General programming discussion
Topic: Pi-toPi communication via SSH possible?
Replies: 2
Views: 716

Pi-toPi communication via SSH possible?

Hi, I would like to know if it is possible to have a pi automatically SEND a command over SSH to another machine when a certain condition occurs. Lets say if the temperature gets too hot then the pi can send a shutdown signal to a heater or server via an SSH link. I would assume it can be done, but ...
by skywatch
Tue Feb 09, 2016 10:03 pm
Forum: Advanced users
Topic: RPI 2B to Arduino pro mini
Replies: 4
Views: 1492

Re: RPI 2B to Arduino pro mini

Two things spring to mind here. 1. Easy way. Have arduino give output from single gipo to pi (direct if arduino is powered by 3V, or level shifter if it is powered by 5V) and read that. The arduino could also have an interrupt to listen for a input from the pi on a pin, check it is running OK and th...
by skywatch
Sun Sep 27, 2015 10:06 am
Forum: Troubleshooting
Topic: NTP not syncing with script.
Replies: 9
Views: 2137

Re: NTP not syncing with script.

Oddly, if left overnight and called from cronjob it syncs. Running from a @reboot cron (with or without a 20 minute delay) and it always fails. I am stumped by this behaviour!
by skywatch
Wed Sep 23, 2015 9:28 am
Forum: Troubleshooting
Topic: Power supply went down after upgrade
Replies: 4
Views: 930

Re: Power supply went down after upgrade

A coincidence for sure. I have many pis here and never an issue with rpi-update. I have had issues with power supplies in a lot of situations over the years. Power supplies are not all made the same. You need to find a good brand that is powerfull enough for your pi and anything you have connected t...
by skywatch
Tue Sep 22, 2015 1:41 pm
Forum: Automation, sensing and robotics
Topic: Fully Automated Rainwater Purification Center.
Replies: 1
Views: 692

Re: Fully Automated Rainwater Purification Center.

Just a dumb thought, but boiling a large quantity or water will consume a lot of power. I have heard of UV sterilisation using UV LED's or UV tube lights. Maybe worth looking into ?
by skywatch
Tue Sep 22, 2015 1:18 pm
Forum: Troubleshooting
Topic: NTP not syncing with script.
Replies: 9
Views: 2137

Re: NTP not syncing with script.

#!/bin/sh /usr/sbin/ntp-wait -n 5 -s 3 RETVAL=$? if [ "$RETVAL" != "0" ];then echo "Timesync not done, exiting " exit 1 fi This still fails to sync. ntp is running. ntpq -p works. but this script (called from cron @reboot) always returns the fail message. Even running the script from the cli fails ...
by skywatch
Mon Sep 21, 2015 9:35 pm
Forum: Troubleshooting
Topic: NTP not syncing with script.
Replies: 9
Views: 2137

Re: NTP not syncing with script.

Thanks Dougie, that seems to have sorted the issue. ntpq -p now works after a reboot from the CLI.

I guess ntp was corrupted somehow?

I will test the network NTP service to other Rpis this week (I hope)....

Thank you!

Go to advanced search