Go to advanced search

by fgimenez
Wed Mar 28, 2018 10:58 am
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 1010113

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Agreed. Luckily your driver is usually available since you target rpi-update and apt-get is lagging way behind :-)
by fgimenez
Tue Mar 27, 2018 11:51 pm
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 1010113

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

The main issue I have is being able to determine the kernel that will be installed if using apt-get upgrade/dist-upgrade before running upgrade/dist-upgrade so I can check if a driver is available. Right, but I run the script *after* doing the apt-get so the kernel is already installed, just not ye...
by fgimenez
Sat Mar 24, 2018 3:32 am
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 1010113

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Speaking of install scripts, I'm using a slightly modified version of your scripts. My version, instead of checking the current kernel and looking for a matching driver, it checks for the next boot's kernel by looking at /boot/kernel.img and installs the driver for that version. That way I can updat...
by fgimenez
Thu Mar 22, 2018 9:51 pm
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 1010113

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

@mrengman, With new stable kernel 4.9.80-1098 , may you release your driver suite? Thanks! The URL has changed but the initial post on page 1 still has the old info. Check the post in page 53 ( https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=62371&start=1300#p1271965 ) where it explains the...
by fgimenez
Mon Mar 19, 2018 8:32 pm
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 1010113

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Directly to Pi and no other usb device plugged in.
I guess my power source is on the edge and newer kernels push it harder than older kernels... that’s the only idea I have so far.
by fgimenez
Mon Mar 19, 2018 1:34 am
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 1010113

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

ok... now I'm seeing the issue with 4.9.66+
There must be something wrong on my setup and/or tests...
by fgimenez
Mon Mar 19, 2018 1:24 am
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 1010113

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

In my case those enter/leave lines keep repeating forever and the association with the router is dropped with the kernels that show the issue and they show only a couple of times with the kernels that work OK, similar to what you saw. I tried a few kernels and it starts with 4.9.67+ #1061. Before th...
by fgimenez
Mon Mar 19, 2018 12:01 am
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 1010113

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Interesting stuff... I was re-testing 4.9.80+ #1092 and after failing it reconnected OK. Looking at the logs it looks like the whole USB bus/controller/hub/something got reset twice and all USB devices (onboard ethernet and the wifi dongle, the only ones I have) show up as being removed and re-added...
by fgimenez
Sun Mar 18, 2018 11:24 pm
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 1010113

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

It's a strange thing. My wifi dongle is: Bus 001 Device 004: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter I do have the /etc/modprobe.d/8188eu.conf just like it comes from your driver since I use your install script from the tar.gz file. I run raspbian stretch...
by fgimenez
Sun Mar 18, 2018 6:28 pm
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 1010113

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

Dear MrEngman, It seems there might be an issue with mt7610 driver somewhere in between kernel 4.9.59 (working) and 4.9.65 (failing) as per this . Is there a known issue with this driver on recent kernels, or would you have any suggestion? Thanks. I have a similar issue with 8818eu, working perfect...
by fgimenez
Sun Mar 18, 2018 6:51 am
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 1010113

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

I see kernel 4.9.80 has been mentioned in some posts but I can't find this one:
8188eu-4.9.80-1098.tar.gz
Is it in the queue or was it missed for some reason?

Thanks.

UPDATE:

Nevermind, I just saw the URL has changed. Maybe the first post should be updated as well.
by fgimenez
Thu Dec 14, 2017 11:15 pm
Forum: Raspbian
Topic: kodi 17.6-1 broken on RPI1 - SIGILL, Illegal instruction (Tag_CPU_arch: v7)
Replies: 3
Views: 478

Re: kodi 17.6-1 broken on RPI1 - SIGILL, Illegal instruction (Tag_CPU_arch: v7)

Rascas wrote:
Thu Dec 14, 2017 6:32 pm
It should be fixed, you just need to update Kodi or the system.
yup, it works!

Thanks!
by fgimenez
Sun Dec 10, 2017 11:07 pm
Forum: Raspbian
Topic: kodi 17.6-1 broken on RPI1 - SIGILL, Illegal instruction (Tag_CPU_arch: v7)
Replies: 3
Views: 478

kodi 17.6-1 broken on RPI1 - SIGILL, Illegal instruction (Tag_CPU_arch: v7)

Looks like the latest Kodi package was compiled only for "Tag_CPU_arch: v7" Both kodi.bin and kodi_v7.bin (under /usr/lib/arm-linux-gnueabihf/kodi/) show "Tag_CPU_arch: v7" with readelf. Some libraries are also built for v7, one of those showed up in my crashlog: Program terminated with signal SIGIL...
by fgimenez
Fri Mar 25, 2016 10:38 pm
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 1010113

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.1.xx+

After a long time compiling my own module I've now switched to the one on this forum. Great work MrEngman! I have just one question. Maybe it was already asked in the previous 43 pages. If it was asked before maybe you should consider adding a comment on the first post about it. The question is: Is ...
by fgimenez
Sun Jun 28, 2015 10:09 pm
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 1010113

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.0.xx+

Apparently I'll have to keep compiling my own :( For some reason I get much better results with v4.1.8 on my setup (nothing fancy, just a tp-link wdr3600 router running openwrt). What really bothers me is not being able to find out what's going on. There are no errors or anything. My testcase is sim...
by fgimenez
Sun Jun 28, 2015 7:44 pm
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 1010113

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.0.xx+

The led is blinking on my wifi on my Pi 2B using my driver. Thanks for the pointer to the update. MrEngman Strange... mine doesn't blink with the driver downloaded from this thread (I have a B model, the old one). I'm running the latest firmware with kernel 4.0.6+. I'm also having some strange issu...
by fgimenez
Sun Jun 28, 2015 6:50 am
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 1010113

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.0.xx+

After a long time of compiling my own module now I've switched to MrEngman's module which is awesome. BTW... I noticed you are using v4.3.0.7 now (no blinking led). Is it much better than 4.1.8 (blinking led) ? EDIT: after posting I found v4.3.0.8 source here: http://dl.lazyzhu.com/file/RTL8188EU/ T...
by fgimenez
Sun Jun 07, 2015 4:05 pm
Forum: Add-ons
Topic: TinyTOSLINK (digital audio output) now for B+, too
Replies: 313
Views: 123201

Re: TinyTOSLINK (digital audio output) now for B+, too

Anyone here migrating to this model who would be willing to sell his or her old Pi1 B tinytoslink (viewtopic.php?f=45&t=75225) ?
Please PM me if you want to sell your used Pi1 B model add-on.
by fgimenez
Sat Mar 21, 2015 1:55 pm
Forum: Add-ons
Topic: Introducing my tiny (case-friendly) digital audio out addon
Replies: 57
Views: 29756

Re: Introducing my tiny (case-friendly) digital audio out ad

Wow, this is awesome.
I have a few questions:
- does it work with kodi (formerly xbmc) when playing videos? Does it support passthru?
- How do I get one? Can I get the schematics to build one myself?

Thanks!
by fgimenez
Wed Feb 18, 2015 2:05 am
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 1010113

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.12.36+

MrEngman wrote: I downloaded your files and tried compiling your version of v4.1.8_9499, with gcc 4.8.3 on a Pi 2. It came up with some warnings
MrEngman
Thanks for the tip.
I didn't see any warning on my Pi (B model) with gcc 4.8.2 but I'll keep your patch handy :)
by fgimenez
Sun Feb 15, 2015 8:37 am
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 1010113

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.12.36+

Works great! Thank you :) Update: Ok, it's not that great. Max speed I could get was 900 kB/s while previously it was about 1400kB/s. Also after tansmitting 300MBs it suddenly slowed down to about 4kB/s and from that moment everything was very slow (samba, http server, ssh) until I rebooted. Make s...
by fgimenez
Sun Feb 15, 2015 8:29 am
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 1010113

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.12.36+

Glad to see it works for someone else too :) If you want to really test the bandwidth you should write to /dev/null , that way you remove the SD card limit since /dev/null writes litterally nowhere. You can also use a tool like "iperf" which runs on both sides as client/server. Or if you want to set...
by fgimenez
Sat Feb 14, 2015 6:09 am
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 1010113

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.12.36+

I've tested the module that comes with the firmware and apparently it doesn't work very well. So I compiled the one that I was using before which has proven to be very reliable: the realtek's v4.1.8_9499 module. I've uploaded some files here: https://drive.google.com/file/d/0B2wdCXXIc98bZGR6c3c1X3VM...
by fgimenez
Mon Feb 02, 2015 10:16 am
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 1010113

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.12.36+

Hi After updating to 3.18.3+ and installing the driver (thanks MrEngMan) my Pi disconnects from the network every few hours and I need to restart the networking service. Any ideas? Thanks I experienced the same. Setting this into /etc/modprobe.d/r8188eu.conf seems to improve it a little bit: option...
by fgimenez
Mon Feb 02, 2015 9:27 am
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1355
Views: 1010113

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 3.12.36+

Hi After updating to 3.18.3+ and installing the driver (thanks MrEngMan) my Pi disconnects from the network every few hours and I need to restart the networking service. Any ideas? Thanks I experienced the same. Setting this into /etc/modprobe.d/r8188eu.conf seems to improve it a little bit: option...

Go to advanced search