Go to advanced search

by airlomba
Wed Feb 22, 2017 2:26 pm
Forum: C/C++
Topic: I2C device memory dump
Replies: 0
Views: 386

I2C device memory dump

Hello all, I just posted in my blog a simple C code that, once compiled, dumps on a terminal screen the contents of the registers between two addresses of any I2C device. It's available for download here: http://www.airlomba.net/blog/2017/02/22/simple-c-code-to-dump-i2c-device-memory/ Feel free to u...
by airlomba
Thu Jan 26, 2017 10:31 am
Forum: C/C++
Topic: Where is the bug? C operation with wrong result?
Replies: 7
Views: 1168

Re: Where is the bug? C operation with wrong result?

Hello PeterO, Thank you for your answer and comments. About the 'l', I guess I have inherited it from some other language. Anyway thank you for explaining that it is useless here. About my "bug", what really bugs me is that the result of the division of 701580000 by 25000000 is precisely 28,0632. I ...
by airlomba
Thu Jan 26, 2017 9:34 am
Forum: C/C++
Topic: Raspberry Pi software driven PWM using C++
Replies: 5
Views: 3598

Re: Raspberry Pi software driven PWM using C++

Hello, Forgive me for the following question but since I already saw more than once a related problem, I must ask. Is there any power driver between the GPIO pins and the motor? The GPIO can't provide enough power to drive a motor; you need some driver circuit (e.g., an H-bridge). Best regards, Emma...
by airlomba
Thu Jan 26, 2017 9:26 am
Forum: C/C++
Topic: Where is the bug? C operation with wrong result?
Replies: 7
Views: 1168

Where is the bug? C operation with wrong result?

Hello all, I've been away from RasPi for some time, but now that I am back, trying to build an application for the Si5351 clock chip, I am loosing my hair around the following problem for the last two days. For the sake of your health, I have reduced the code to the essential: /* where_is_the_bug.c ...
by airlomba
Wed Oct 15, 2014 7:30 pm
Forum: Camera board
Topic: Distortion
Replies: 4
Views: 1643

Re: Distortion

Use it a long long time ago...
I hope this helps:
http://www.vision.caltech.edu/bouguetj/calib_doc/

Kind regards,
Emmanuel.
by airlomba
Thu Jun 05, 2014 9:06 pm
Forum: Beginners
Topic: Access Point (AP) for TP-Link TL-WN725N V2
Replies: 31
Views: 62988

Re: Access Point (AP) for TP-Link TL-WN725N V2

What was the performance of RTL8188EU as access point? could you measure the throughput? Hi, I am not an expert in Network Programming. If you can point some method to measure the performance, I can measure it for you and post the results. However, from my point of view, I have no complaint about t...
by airlomba
Thu Apr 17, 2014 10:06 am
Forum: Beginners
Topic: Access Point (AP) for TP-Link TL-WN725N V2
Replies: 31
Views: 62988

Re: Access Point (AP) for TP-Link TL-WN725N V2

Hello all,

I just edited my previous post with the solution to my troubles.
All is working fine now.

Best regards,
Emmanuel.
by airlomba
Wed Apr 16, 2014 2:33 pm
Forum: Beginners
Topic: Access Point (AP) for TP-Link TL-WN725N V2
Replies: 31
Views: 62988

Re: Access Point (AP) for TP-Link TL-WN725N V2

Hello all, After a while, I spent the last couple of days reading a lost of posts on this and other forums, blogs and other webpages. And after several trials I finally got my Access Point up and running! $ sudo apt-get update $ sudo apt-get upgrade $ uname -a returned: Linux ADB-rpi3 3.10.25+ #622 ...
by airlomba
Tue Dec 10, 2013 3:06 pm
Forum: Beginners
Topic: Access Point (AP) for TP-Link TL-WN725N V2
Replies: 31
Views: 62988

Re: Access Point (AP) for TP-Link TL-WN725N V2

Hello all, Did not work for me... My setup is: Raspberry Pi Model B with TP-Link TL-WN725N v2 (0bda:8179) Running Raspbian: 3.1.23+ #608 PREEMPT Mon Dec 9 21:11:23 GMT armv61 GNU/Linux with appropriated dongle drivers from MrEngmann. Executing command: $ sudo hostapd -dd /etc/hostapd/hostapd.conf I ...
by airlomba
Mon Nov 18, 2013 5:27 pm
Forum: Troubleshooting
Topic: (UPDATE) Driver for TL-WN725N V2 and update 3.10.18+ and 19+
Replies: 14
Views: 15427

Re: (UPDATE) Driver for TL-WN725N V2 and update 3.10.18+ and

Hello all, Last weekend, I've been struggling with the WN725N v2 for an entire afternoon, trying to make it work on my Pi model B under Raspbian 3.6.11+ #557. Everything went fine except that my Pi didn't received any IP address from my router. However, other devices such as my phone or another comp...
by airlomba
Thu Mar 21, 2013 9:39 pm
Forum: General discussion
Topic: STICKY: Introduce yourself!
Replies: 3498
Views: 84175

Re: Introduce yourself!

Hello everyone,

I'm Emmanuel, a newbie tasting the Pi and already loving it.

Best regards to all, from Portugal,
Emmanuel.

Go to advanced search