Go to advanced search

by macintoshgeek
Wed Mar 27, 2013 2:37 am
Forum: Java
Topic: Using SSHJ to send SSH commands to Raspberry Pi in Java App
Replies: 20
Views: 10415

Re: Using SSHJ to send SSH commands to Raspberry Pi in Java

Sorry for the late response, but this worked like a charm! Thanks for all your help! It's much appreciated.
by macintoshgeek
Thu Mar 21, 2013 12:03 am
Forum: Java
Topic: Using SSHJ to send SSH commands to Raspberry Pi in Java App
Replies: 20
Views: 10415

Re: Using SSHJ to send SSH commands to Raspberry Pi in Java

Hmmm. Still doesn't seem to want to work. For reference, here is the code I'm working with: import java.awt.EventQueue; public class MainWindow extends JFrame { private JPanel contentPane; /** * Launch the application. */ public static void main(String[] args) { EventQueue.invokeLater(new Runnable()...
by macintoshgeek
Wed Mar 20, 2013 7:10 pm
Forum: Java
Topic: Using SSHJ to send SSH commands to Raspberry Pi in Java App
Replies: 20
Views: 10415

Re: Using SSHJ to send SSH commands to Raspberry Pi in Java

First of all, thank you so much for all your help. I truly do appreciate it. I got all the correct Jar files in there now and when I run it the only error I get is: [AWT-EventQueue-0] INFO net.schmizz.sshj.common.SecurityUtils - BouncyCastle not registered, using the default JCE provider Is that som...
by macintoshgeek
Wed Mar 20, 2013 4:05 pm
Forum: Java
Topic: Using SSHJ to send SSH commands to Raspberry Pi in Java App
Replies: 20
Views: 10415

Re: Using SSHJ to send SSH commands to Raspberry Pi in Java

I added the library to the projects build path and the same area is being returned. I must be missing an extra step in here somewhere to make sure this library is in the project.

Here is my build path in Eclipse
http://imgur.com/5NjMmzs
by macintoshgeek
Wed Mar 20, 2013 2:57 am
Forum: Troubleshooting
Topic: Problems using Dropbox Uploader Bash Script
Replies: 0
Views: 505

Problems using Dropbox Uploader Bash Script

Hello, Newb here. I'm having trouble getting a bash script to run on my Pi. I'm trying to follow the instructions from here: http://mogshade.wordpress.com/2012/12/23/simple-home-security-with-raspberry-pi-and-dropbox/ and here http://www.webupd8.org/2013/01/dropbox-uploader-bash-script-useful-for.ht...
by macintoshgeek
Wed Mar 20, 2013 2:46 am
Forum: Java
Topic: Using SSHJ to send SSH commands to Raspberry Pi in Java App
Replies: 20
Views: 10415

Re: Using SSHJ to send SSH commands to Raspberry Pi in Java

Eclipse is returning a whole jumble of errors when trying to execute one of the commands from a button click. Exception in thread "AWT-EventQueue-0" java.lang.NoClassDefFoundError: org/slf4j/LoggerFactory at net.schmizz.sshj.DefaultConfig.<init>(DefaultConfig.java:92) at net.schmizz.sshj.SSHClient.<...
by macintoshgeek
Tue Mar 19, 2013 6:38 pm
Forum: Java
Topic: Using SSHJ to send SSH commands to Raspberry Pi in Java App
Replies: 20
Views: 10415

Re: Using SSHJ to send SSH commands to Raspberry Pi in Java

A few questions, what's the purpose of the "22" in this line?: ssh.connect("192.168.1.xxx, 22"); Also, is this working code or just an example? I'm away from my Pi at the moment, but if I were to add the code into an ActionListener for a button and change the "xxx" to my pi's actual IP, should every...
by macintoshgeek
Tue Mar 19, 2013 2:53 am
Forum: Java
Topic: Using SSHJ to send SSH commands to Raspberry Pi in Java App
Replies: 20
Views: 10415

Using SSHJ to send SSH commands to Raspberry Pi in Java App

Hello, I want to make a java application that will do some simple comands for my Raspberry Pi using SSH. I found that the SSHJ library should do the trick, but I'm having trouble trying to figure out exactly how to use it. Does anyone have any experience with it? The examples don't seem to help me m...
by macintoshgeek
Tue Mar 19, 2013 1:49 am
Forum: Networking and servers
Topic: Uploading Motion files to Google Drive on Raspbian?
Replies: 9
Views: 7403

Re: Uploading Motion files to Google Drive on Raspbian?

No error is returned in motion. So I can't figure out where a problem could be coming from. I've adjusted the script as the tutorial said to to. And I would assume that it should be working with raspbian. I just can't seem to figure out where the problem is coming from.
by macintoshgeek
Mon Mar 18, 2013 8:54 pm
Forum: Troubleshooting
Topic: Script file for uploading files to Google Drive not working
Replies: 2
Views: 1545

Script file for uploading files to Google Drive not working

Hello, I've been playing around with Motion on my Rapsberry Pi running Raspbian and came across this post that sounded like fun to do: http://through-the-interface.typepad.com/through_the_interface/2012/09/creating-a-motion-detecting-security-cam-with-a-raspberry-pi-part-2.html I've been trying to t...
by macintoshgeek
Mon Mar 11, 2013 3:08 am
Forum: Java
Topic: Putting a Motion Webcam Feed into a JFrame
Replies: 1
Views: 1255

Putting a Motion Webcam Feed into a JFrame

I have a Raspberry Pi running Motion that sets up a server with a video feed. I want to create a Java application that will run on another computer and for part of this application I want to incorporate the feed into it. Would it be possible to some how gain access to the feed from the IP or some ot...
by macintoshgeek
Sun Mar 10, 2013 10:38 pm
Forum: Networking and servers
Topic: Uploading Motion files to Google Drive on Raspbian?
Replies: 9
Views: 7403

Uploading Motion files to Google Drive on Raspbian?

Hello, I've been playing around with Motion on my Rapsberry Pi running Raspbian and came across this post that sounded like fun to do: http://through-the-interface.typepad.com/through_the_interface/2012/09/creating-a-motion-detecting-security-cam-with-a-raspberry-pi-part-2.html I've been trying to t...
by macintoshgeek
Sun Mar 10, 2013 7:08 pm
Forum: Troubleshooting
Topic: Motion Server Crashes Upon Motion in Feed
Replies: 10
Views: 15361

Re: Motion Server Crashes Upon Motion in Feed

Also, here is the output I get while motion is running. When the server freezes, I don't get an error. Motion just seems to stop completely. [1] - STREAMING [1] Test palette YUYV (640x640) [1] Adjusting resolution from 640x640 to 640x480. [1] Using palette YUYV (640x480) bytesperlines 1280 sizeimage...
by macintoshgeek
Sun Mar 10, 2013 7:06 pm
Forum: Troubleshooting
Topic: Motion Server Crashes Upon Motion in Feed
Replies: 10
Views: 15361

Re: Motion Server Crashes Upon Motion in Feed

YEAH! I found a solution for the above mentioned problem using my Logitech webcam with Raspberry Pi! (E.g.: see “http://www.raspberrypi.org/phpBB3/viewtopic.php?f=37&t=11745” and referenced links for further details.) Summary: Try the following and test it if runs with your webcam problem: sudo rmm...
by macintoshgeek
Tue Mar 05, 2013 9:23 pm
Forum: Troubleshooting
Topic: Motion Server Crashes Upon Motion in Feed
Replies: 10
Views: 15361

Re: Motion Server Crashes Upon Motion in Feed

Hi, Very probably a bandwidth problem. Movement in front of the camera increases bandwidth. Lock ups when moving the hand led me to the discovery of the fix in this thread: http://www.raspberrypi.org/phpBB3/viewtopic.php?f=28&t=35689&p=300710&hilit=opencv#p300710 (one more tip: If you get no error ...
by macintoshgeek
Tue Mar 05, 2013 3:29 am
Forum: Troubleshooting
Topic: Motion Server Crashes Upon Motion in Feed
Replies: 10
Views: 15361

Motion Server Crashes Upon Motion in Feed

Hello all, Hopefully this is the correct place to post this. I'm having some trouble with my motion webcam server. It was working just fine until I played around with some settings. Unfortunately I may have played with too many settings at once and can't seem to figure out what's gone wrong. If I po...
by macintoshgeek
Tue Mar 05, 2013 1:40 am
Forum: Troubleshooting
Topic: Static IP Messing up Wireless
Replies: 4
Views: 836

Re: Static IP Messing up Wireless

Thanks for the help, guys! Changed some 0s to 1s on both of those files and got it to ping google!
by macintoshgeek
Tue Mar 05, 2013 1:36 am
Forum: Beginners
Topic: Switching OS on my SD Card
Replies: 5
Views: 1127

Re: Switching OS on my SD Card

Thanks for the help guys, turns out my laptop decided it only wants to read SD cards now. So I just had to borrow a friend's laptop for the dirty work.

Thanks!
by macintoshgeek
Mon Mar 04, 2013 3:42 am
Forum: Troubleshooting
Topic: Static IP Messing up Wireless
Replies: 4
Views: 836

Static IP Messing up Wireless

I have my Raspberry Pi running Raspbian with a static IP address assigned to it. I can SSH into the Pi from my laptop and can also access a video feed from motion from it, but when on the Pi I can't seem to ping any websites. The wireless was working just fine before I assigned it a static IP. Here ...
by macintoshgeek
Sun Feb 24, 2013 8:08 pm
Forum: Beginners
Topic: Switching OS on my SD Card
Replies: 5
Views: 1127

Switching OS on my SD Card

Hello, I want to switch from Wheezy to Arch Linux Arm on my SD card. I can't seem to get the SD card to remove the old OS. I have the SD card in my Macbook and Disc Utility doesn't want to erase it. And it also won't let me delete any of the files off it directly. It appears to be write locked. How ...
by macintoshgeek
Sun Feb 24, 2013 6:43 pm
Forum: Networking and servers
Topic: Port Forwarding Problem
Replies: 6
Views: 3839

Re: Port Forwarding Problem

When I got to 192.168.1.127:8088 motion is displayed just fine, but my pi can't seem to ping google.com or any other site for that matter. Could this be part of my problem?
by macintoshgeek
Sun Feb 24, 2013 6:16 pm
Forum: Networking and servers
Topic: Port Forwarding Problem
Replies: 6
Views: 3839

Re: Port Forwarding Problem

That was a mistype, it is set to 8089. But it still doesn't seem to work.
by macintoshgeek
Sun Feb 24, 2013 1:39 am
Forum: Networking and servers
Topic: Port Forwarding Problem
Replies: 6
Views: 3839

Port Forwarding Problem

Hello, I've got motion installed on my Raspberry Pi and am trying to get port forwarding set up on my Linksys router. I just want to make sure I'm doing everything right because it doesn't seem to be working. I have the server set up locally at 192.168.1.127:8088. I went into my router and set up po...

Go to advanced search