Go to advanced search

by NF3RN0
Tue Mar 29, 2016 3:41 am
Forum: Troubleshooting
Topic: Terrible OpenArena Performance on New Pi 3
Replies: 7
Views: 3716

Re: Terrible OpenArena Performance on New Pi 3

ghans wrote:This version might still work :

viewtopic.php?f=35&t=8673&start=25#p270142


ghans

Yup this one works. Just tried it on my Raspberry Pi 3.

Cheers.
by NF3RN0
Sat Mar 19, 2016 7:10 am
Forum: Gaming
Topic: WIP: Playable Nintendo 64 Emulator Available
Replies: 382
Views: 295871

Re: WIP: Playable Nintendo 64 Emulator Available

@Chips


Ok so it looks like there a missunderstanding on the github and the NEON flag are already set by default from the build script if you run it on a RPI 2 or 3.

No need to use NEON=1 as the script does this automatically.
by NF3RN0
Wed Feb 10, 2016 4:33 pm
Forum: Gaming
Topic: OpenRA and Raspberry Pi?
Replies: 16
Views: 7234

Re: OpenRA and Raspberry Pi?

I upgraded the distro, downloaded the experimental driver and enabled it with dtoverlay=vc4-kms-v3d. I got OpenRA to compile successfully with the Mono framework (using the Xamarin packages) and SDL2 following the instructions on the OpenRA Github wiki. I had to change one of the setup scripts for i...
by NF3RN0
Mon Jan 11, 2016 9:20 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: 8 Channel DAC requires four 4 data lines but Pi has only one
Replies: 7
Views: 3400

Re: 8 Channel DAC requires four 4 data lines but Pi has only

Have you found it in a board or are you going to do SMT work? I had planned on doing the SMT work myself as I have not found a board. I will be honest and say I am not sure how big of a task this is going to be but I am prepared to put in the work. Do you have a suggestion for another DAC? I requir...
by NF3RN0
Mon Jan 11, 2016 3:10 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: 8 Channel DAC requires four 4 data lines but Pi has only one
Replies: 7
Views: 3400

Re: 8 Channel DAC requires four 4 data lines but Pi has only

Did you come to any conclusion on if the Raspberry Pi could support the PCM1690? I am looking to use it in a Car Computer setup.
by NF3RN0
Wed Dec 02, 2015 4:17 am
Forum: C/C++
Topic: Random Number Generator Using Build In Hardware
Replies: 103
Views: 14791

Random Number Generator Using Build In Hardware

It is my understanding that the Raspberry Pi has a build in random number generator. Is there a library, or a way that I can use the built in hardware random number generator in a C Program?


Cheers.
by NF3RN0
Thu Nov 05, 2015 10:12 pm
Forum: General discussion
Topic: DJ-ing application
Replies: 3
Views: 1148

Re: DJ-ing application

You should try Mixxx with the Cirrus Logic board. Recently there has also been an experimental feature added to the master branch of Mixxx on Github. Some one wrote the code for a OpenGL ES waveform output. I have compiled this code with the additional support of the Cirrus Logic board and Raspbian ...
by NF3RN0
Tue Mar 24, 2015 4:16 am
Forum: Beginners
Topic: How do I get kodi now?
Replies: 5
Views: 1122

Re: How do I get kodi now?

Download the latest NOOBS from the download section.

Put NOOBS on an SD card.

Boot up the RPI 2.

When it ask for what to install just select openelec "for Raspberry Pi 2".

Hit install.

Enjoy!

I used to use raspbmc for a while but openelec is much better now IMO.
by NF3RN0
Tue Mar 24, 2015 1:35 am
Forum: Gaming
Topic: WIP: Playable Nintendo 64 Emulator Available
Replies: 382
Views: 295871

Re: WIP: Playable Nintendo 64 Emulator Available

Ktb and dennmtr -

I have ran into this issue before, I don't remember what I did to fix it.

First check how much memory you have to the GPU before you run mupen. It has to be 128 I believe.

Also, do you have the console ouput from the build script?
by NF3RN0
Thu Mar 12, 2015 3:10 am
Forum: Advanced users
Topic: Possible to Change ALSA Buffer Size
Replies: 3
Views: 2524

Re: Possible to Change ALSA Buffer Size

Ok so from your comment I figured that HDMI is actually device 0 subdevice 0. So, I had the device wrong all along. But I am still unable to change prealloc_max. AFAIK that is the buffer maximum. Also, the value in prelatic_max is that in megabytes? I am still not sure if I am going about this the r...
by NF3RN0
Wed Mar 11, 2015 9:02 pm
Forum: Advanced users
Topic: Possible to Change ALSA Buffer Size
Replies: 3
Views: 2524

Possible to Change ALSA Buffer Size

I am curious to see if it is possible to increase the buffer size in ASLA. I am trying to do this with the HDMI device. It is currently set to 64 and my attemps to change it have failed. I have tried: sudo echo 128 | sudo tee /proc/asound/card0/pcm1p/sub0/prealloc_max Is there another way because th...
by NF3RN0
Mon Mar 09, 2015 10:04 pm
Forum: Gaming
Topic: WIP: Playable Nintendo 64 Emulator Available
Replies: 382
Views: 295871

Re: WIP: Playable Nintendo 64 Emulator Available

Sorry, I'm blind sometimes.
by NF3RN0
Sat Mar 07, 2015 7:30 am
Forum: Gaming
Topic: WIP: Playable Nintendo 64 Emulator Available
Replies: 382
Views: 295871

Re: WIP: Playable Nintendo 64 Emulator Available

hello , i fresh compiled ric's mupen64plus using pi2 but i cannot start gaming. Mupen64plus doesnt open any window to play. game starts, i here the sound (mario64) but no window only text in the console. besides that, i use n64-video, rice video plgin gives me an error that cannot start resolution ...
by NF3RN0
Thu Jan 22, 2015 11:26 pm
Forum: Beginners
Topic: new os
Replies: 2
Views: 625

Re: new os

You should try a wired connection with your NOOBS install. Just connect you Raspberry Pi to your home router with a ethernet cable. Then after you complete your NOOBS setup try to set up your wifi connection.
by NF3RN0
Thu Jan 15, 2015 8:38 pm
Forum: Gaming
Topic: Starcraft working on the Pi !!! =D
Replies: 6
Views: 14135

Re: Starcraft working on the Pi !!! =D

I was looking into getting Stratagus working on my pi too. I will try this out toninght! You could try startx <path/to/stargus/bin> from console without starting x first. This should start a x window without the whole GUI. AFAIK, you would just need to control+alt+delete to quit the application. Gre...
by NF3RN0
Thu Dec 18, 2014 9:03 pm
Forum: Bare metal, Assembly language
Topic: Yagarto Installation
Replies: 5
Views: 3827

Re: Yagarto Installation

Instead of starting a new thread I figured I would just ask my question here. I have the kernel successfully compliling under terminal but I would like to use xcode to do the same thing. I am running into the same problem as before where as Xcode does not know where yagarto is installed. Does anyone...
by NF3RN0
Fri Nov 21, 2014 4:41 am
Forum: General discussion
Topic: X11,GLES,EGL,Wayland/Weston,vc4,GPU,CPU,DMA,MMU for idiots?
Replies: 17
Views: 5317

Re: X11,GLES,EGL,Wayland/Weston,vc4,GPU,CPU,DMA,MMU for idio

I just thought I should maybe post this link as it looks like a really great piece of literate script, lots of comments and links to relevant info for DMA and other memory stuff, I have not fully read it, it looks like most of the same as rpio and servoblaster but with better comments, the comments...
by NF3RN0
Wed Nov 12, 2014 5:42 am
Forum: OpenMAX
Topic: Are there any audio hardware decoders available
Replies: 2
Views: 2306

Re: Are there any audio hardware decoders available

I would also like to have a definitive answer as well. From what I have read so far the VC4 side of the Rpi has the capablility to decode audio but does not have the license yet?? Also, I would like to know if the information that Broadcom released on the aniversary of the Rpi had any effect on the ...
by NF3RN0
Mon Nov 10, 2014 2:18 am
Forum: General discussion
Topic: X11,GLES,EGL,Wayland/Weston,vc4,GPU,CPU,DMA,MMU for idiots?
Replies: 17
Views: 5317

Re: X11,GLES,EGL,Wayland/Weston,vc4,GPU,CPU,DMA,MMU for idio

I feel like I am in the same boat, trying to learn the same things. Maug, have you had any information as of late that was enlightening to you? like you, I am also trying to learn how to create GUI aplications that run efficently (with hardware acceleration) on the raspberry pi. Did you develop for...
by NF3RN0
Sat Oct 25, 2014 3:23 am
Forum: General discussion
Topic: X11,GLES,EGL,Wayland/Weston,vc4,GPU,CPU,DMA,MMU for idiots?
Replies: 17
Views: 5317

Re: X11,GLES,EGL,Wayland/Weston,vc4,GPU,CPU,DMA,MMU for idio

I feel like I am in the same boat, trying to learn the same things. Maug, have you had any information as of late that was enlightening to you? like you, I am also trying to learn how to create GUI aplications that run efficently (with hardware acceleration) on the raspberry pi.
by NF3RN0
Tue Aug 19, 2014 10:58 pm
Forum: Gaming
Topic: PrBoom Plus on Rpi?
Replies: 4
Views: 2267

Re: PrBoom Plus on Rpi?

sudo apt-get install prboom

It worked for me yesterday.

Make a directory in your user folder called doom and put the .wad files in that folder.

prboom

and your good to go!

prboom help if you need to know where the config files are.
by NF3RN0
Fri Aug 08, 2014 1:01 am
Forum: Gaming
Topic: WIP: Playable Nintendo 64 Emulator Available
Replies: 382
Views: 295871

Re: WIP: Playable Nintendo 64 Emulator Available

The best settings for games can be found on the wiki. https://github.com/ricrpi/mupen64plus/w ... ility-List
by NF3RN0
Fri Jul 25, 2014 7:14 am
Forum: Gaming
Topic: mupen64pi
Replies: 17
Views: 7016

Re: mupen64pi

Could this be an issue with runcommand.sh and emulationstation.sh? Looks like there is a value set for video before the emulator runs. Maybe the value is set wrong in emulationstation.sh? I cannot test this because I do not have Retro Pie.
by NF3RN0
Thu Jul 17, 2014 12:57 am
Forum: Gaming
Topic: WIP: Playable Nintendo 64 Emulator Available
Replies: 382
Views: 295871

Re: WIP: Playable Nintendo 64 Emulator Available

I have not used emulation station in a while. ric_rpi or welshy might be able to help you out or maybe post it in the emulation forum by itself. I have uploaded a video to youtube with the current build and how Super Mario 64 plays. I did not enable --nospeedlimit, or use OMX in this one but I have ...

Go to advanced search