Go to advanced search

by DanR
Thu Jun 20, 2019 4:38 pm
Forum: Graphics, sound and multimedia
Topic: HDMI to CSI-2 via TC358743 on kernel 4.1
Replies: 584
Views: 179973

Re: HDMI to CSI-2 via TC358743 on kernel 4.1

More testing with disconnects and reconnects on my part needs to be done, but yes I agree the edid should be fine after being set from boot. Maybe I just need to be less cautious for a change :)

Thanks for the info, as always great advice.

Cheers, Dan
by DanR
Thu Jun 20, 2019 3:21 pm
Forum: Graphics, sound and multimedia
Topic: HDMI to CSI-2 via TC358743 on kernel 4.1
Replies: 584
Views: 179973

Re: HDMI to CSI-2 via TC358743 on kernel 4.1

Ok, ignore that last request. FYI, if you run the v4l2-ctl command to set the EDID, then set the timings and then start capturing immediately you get this issue. If you pause for 500ms and then capture it works a treat. I guess the I2C bus hasn't completed or the TC358743 hasn't sync'd its PLL or so...
by DanR
Thu Jun 20, 2019 3:05 pm
Forum: Graphics, sound and multimedia
Topic: HDMI to CSI-2 via TC358743 on kernel 4.1
Replies: 584
Views: 179973

Re: HDMI to CSI-2 via TC358743 on kernel 4.1

Hiya 6by9, I have a problem with capturing more than 1 set of images. The first time it runs absolutely perfectly, the same v4l2_mmal demo you have on github works flawlessly with the ADV7280A-M and using it with the TC358743 works once and once only. I get the following: We're encoding to /media/us...
by DanR
Fri May 24, 2019 9:21 pm
Forum: Graphics, sound and multimedia
Topic: HDMI to CSI-2 via TC358743 on kernel 4.1
Replies: 584
Views: 179973

Re: HDMI to CSI-2 via TC358743 on kernel 4.1

Wasn't the original white Now TV box based on a raspberry pi using the same SoC? It does seem as though sky went to some trouble to prevent it being used as anything else though which is a shame as they're now obsolete :(
by DanR
Tue May 21, 2019 8:34 pm
Forum: Graphics, sound and multimedia
Topic: HDMI to CSI-2 via TC358743 on kernel 4.1
Replies: 584
Views: 179973

Re: HDMI to CSI-2 via TC358743 on kernel 4.1

geosapien,

are you using a directly connected screen / monitor on the pi or using vnc? If you're using vnc then you won't see the video stream due to the way the gpu renders the video.

HTH, Dan
by DanR
Tue May 21, 2019 11:24 am
Forum: Graphics, sound and multimedia
Topic: HDMI to CSI-2 via TC358743 on kernel 4.1
Replies: 584
Views: 179973

Re: HDMI to CSI-2 via TC358743 on kernel 4.1

Hiya 6by9, Thank you ever so much, I added back in the cma=96M, put the gpu_mem=64 back to 128, rebooted and it's working, hurrah!! You're a very helpful person and have made my day, week, month. If I could send you a beer I would send 10 and my debt would still never be paid enough!!! Kind Regards,...
by DanR
Tue May 21, 2019 10:20 am
Forum: Graphics, sound and multimedia
Topic: HDMI to CSI-2 via TC358743 on kernel 4.1
Replies: 584
Views: 179973

Re: HDMI to CSI-2 via TC358743 on kernel 4.1

Hi 6by9, I have got my newer Toshiba dev board up and running and after setting the EDID file and setting the timings I can see that it sees the video stream, however when I test it with yavta and v4l2_mmal I get the following memory allocation errors (I've tried the GPU ram set to 64Mb and 128Mb wi...
by DanR
Mon Apr 01, 2019 10:30 am
Forum: Graphics, sound and multimedia
Topic: HDMI to CSI-2 via TC358743 on kernel 4.1
Replies: 584
Views: 179973

Re: HDMI to CSI-2 via TC358743 on kernel 4.1

Hiya 6by9, Thanks I'll check that between my board and the B101 I have. I think you're spot on with the i2c master on the edid lines so I can rule that out. I think it's more likely the hot plug lines being my issue and I may have a dead chip so I'll be checking against my second dev board when I ge...
by DanR
Mon Apr 01, 2019 8:37 am
Forum: Graphics, sound and multimedia
Topic: HDMI to CSI-2 via TC358743 on kernel 4.1
Replies: 584
Views: 179973

Re: HDMI to CSI-2 via TC358743 on kernel 4.1

Hiya Cyphercolt et al, Yep, I'm setting the EDID fine, I have the B101 board which I bought to check that the TC358743 did what I wanted. However the hardware needs to be all inclusive so I've designed the board with the TC358743 on board. As I say I can communicate with it fine and the input signal...
by DanR
Fri Mar 29, 2019 5:38 pm
Forum: Graphics, sound and multimedia
Topic: HDMI to CSI-2 via TC358743 on kernel 4.1
Replies: 584
Views: 179973

Re: HDMI to CSI-2 via TC358743 on kernel 4.1

Hi All, Has anyone else tried to produce their own board with the TC358743 on it? I'm having issues with it detecting a video input and I get the message "vidioc_query_dv_timings: failed: link has been severed". I've checked the usual, clean supplies, 27MHz clock present, device listed under lsmod, ...
by DanR
Fri Feb 15, 2019 12:00 pm
Forum: Advanced users
Topic: [Tutorial] How to move away from NOOBS
Replies: 23
Views: 8275

Re: [Tutorial] How to move away from NOOBS

I have tried everything I can find on moving the boot and root partitions to a new sd card without noobs and nothing has worked. I tried this tutorial, cp -a, rsync etc and the most I get is boot to pixel splash screen and then a message: "You are in emergency mode. After logging in, type "journalct...
by DanR
Thu Feb 07, 2019 4:42 pm
Forum: Raspbian
Topic: Kernel configuration - driver missing
Replies: 2
Views: 193

Re: Kernel configuration - driver missing

Ok, will do. Thanks Doug much appreciated ;)
by DanR
Thu Feb 07, 2019 2:09 pm
Forum: Raspbian
Topic: Kernel configuration - driver missing
Replies: 2
Views: 193

Kernel configuration - driver missing

Hi, I really hope someone can help me with this one as I've looked everywhere pretty much. I'm trying to get the AD1938 driver compiled into the kernel, the source is there and I've downloaded the latest, updated the pi etc etc etc. However when I run make menuconfig I can't see the driver listed at...
by DanR
Tue Jan 15, 2019 3:18 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: STICKY: The I2S sound thread.
Replies: 908
Views: 438234

Re: STICKY: The I2S sound thread.

It wasn't the mixer volume or muting it was me misreading the datasheet and crossing the wiring for i2s DIN and DOUT. I will now sink into the background and quietly accept the doughnut award!! Thanks for your reply though, it made me realise it must be something stupid or a broken codec. It was som...
by DanR
Mon Jan 14, 2019 4:39 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: STICKY: The I2S sound thread.
Replies: 908
Views: 438234

Re: STICKY: The I2S sound thread.

Hi All, I've produced some hardware with Video codec's on which work perfectly but the audio side is giving me tons of issues. The codec is the SGTL5000 with a 12.288MHz oscillator module connected up to i2c-1 and it can be seen at address 0x0a. I can see the i2s data reaching it and the lrclk and b...
by DanR
Thu Aug 30, 2018 1:02 pm
Forum: Troubleshooting
Topic: USB Name Changes Upon Boot
Replies: 3
Views: 1618

Re: USB Name Changes Upon Boot

Outstanding find! I had this exact problem, once in a blue moon my service would start before the usb device was mounted and wrote everything to a 'virtual location' which seems to be a null bit bucket hence not stored. The application had no exceptions or faults reported by the OS so just carried o...
by DanR
Tue Aug 14, 2018 7:44 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: ADV7280A-M Image Capture Issues
Replies: 10
Views: 773

Re: ADV7280A-M Image Capture Issues

Hi, I'm having a little trouble with some understanding of MMAL, in particular the vc.ril.video_encode and vc.ril.image_encode and their connection to vc.ril.isp. Can they both be connected at the same time or do I need a splitter between them? The reason I ask is that they're all MMAL_COMPONENT_T a...
by DanR
Thu Aug 09, 2018 7:48 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: ADV7280A-M Image Capture Issues
Replies: 10
Views: 773

Re: ADV7280A-M Image Capture Issues

Great, thanks Dave much appreciated. I've been hounded for support on our other hardware yesterday so I lost a days work yet again and only had a little time to look through it. I'll have a look through the code now.

Many many thanks,

Dan
by DanR
Wed Aug 08, 2018 9:48 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: ADV7280A-M Image Capture Issues
Replies: 10
Views: 773

Re: ADV7280A-M Image Capture Issues

Am I right in thinking the routes or data paths are as that the ADV7280 data over MIPI goes to V4L2 so I need to set up: MMAL isp -> MMAL renderer -> MMAL Encoder Where the Encoder can be 3 encoders, one for MMAL_ENCODING_BMP for still captures, two for MMAL_ENCODING_H264 one of which will record a ...
by DanR
Wed Aug 08, 2018 8:57 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: ADV7280A-M Image Capture Issues
Replies: 10
Views: 773

Re: ADV7280A-M Image Capture Issues

I was mistaken about the rtspserver, I have two RasPi 3B+'s on my desk on with an official camera on it and the other with the 7280 on it and I was hot, bothered and confused. I can record video with Yavta from the 7280 and I currently have no way of capturing stills. Management also dumped the requ...
by DanR
Tue Aug 07, 2018 11:48 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: ADV7280A-M Image Capture Issues
Replies: 10
Views: 773

ADV7280A-M Image Capture Issues

Hi All, I have a working board with an ADV7280A-M and I can grab video fine but single image capture is proving a problem. I can save a raw frame which is UYVY data and when I view it, the very first frame I grab is perfect but each subsequent frame is shifted down. For example the top of the image ...
by DanR
Thu Feb 06, 2014 4:18 am
Forum: Troubleshooting
Topic: SD Card Corruption
Replies: 36
Views: 24188

Re: SD Card Corruption

Well that didn't work either, the card fails after some time on both Rpi's. I'm going to pursue this as it's driving me nuts! I hope the parallella board (when it arrives) doesn't exhibit this issue :shock:
by DanR
Wed Feb 05, 2014 8:49 pm
Forum: Troubleshooting
Topic: SD Card Corruption
Replies: 36
Views: 24188

Re: SD Card Corruption

I've found that one of my RPi's which has the self resettable fuses on the usb power lines causes me issues but the other RPi with 0ohm links instead of the fuses works perfectly with the same card type as the one that failed. Both were overclocked. I've soldered 2010 style 0ohm resistors over the t...
by DanR
Sat Feb 09, 2013 1:03 am
Forum: Beginners
Topic: SSH Problem
Replies: 16
Views: 63327

Re: SSH Problem

Awesome, this fixed my issue which was driving me insane. Many Thanks!!
by DanR
Wed Feb 06, 2013 5:51 pm
Forum: Beginners
Topic: Boot with number lock on
Replies: 19
Views: 18764

Re: Boot with number lock on

Thanks LinkCloud,

Much appreciated, I used nano instead of vim as I just can't get used to the annoying semantics of vim, I start gnawing keyboards whenever vim is mentioned :)

Dan

Go to advanced search