Go to advanced search

by dan-youd
Wed Jul 17, 2013 10:43 pm
Forum: Other projects
Topic: CarPi Project (CarPC)
Replies: 11
Views: 21512

Re: CarPi Project

Here's the pics of what I've done so far: The voltage regulator from the old car charger http://i1289.photobucket.com/albums/b517/dan-youd/IMG_20130716_141517_zps66c41edf.jpg http://i1289.photobucket.com/albums/b517/dan-youd/IMG_20130716_141726_zpsbbb7495a.jpg http://i1289.photobucket.com/albums/b51...
by dan-youd
Wed Jul 17, 2013 10:19 pm
Forum: Other projects
Topic: CarPi Project (CarPC)
Replies: 11
Views: 21512

CarPi Project (CarPC)

I have been doing a lot of work on my car lately (sub, amp, speakers, lcd ect...) and I've decided to put a spare Raspberry Pi in it as a CarPC. I could do with some ideas/help. Here is what I've done so far: Installed 17cm JBL speakers in the front, installed 5x7" Kenwood speakers in the rear, inst...
by dan-youd
Wed Jan 23, 2013 9:18 pm
Forum: General discussion
Topic: Dosbox. What have you got running.
Replies: 46
Views: 19413

Re: Dosbox. What have you got running.

Just got Duke Nukem working, got C&C Red Alert to start but it was extremely slow. Still can't get worms to load though
by dan-youd
Wed Jan 23, 2013 6:36 pm
Forum: General discussion
Topic: Dosbox. What have you got running.
Replies: 46
Views: 19413

Re: Dosbox. What have you got running.

chromebookbob wrote:I got civilisation 1, elite, simcity & worms working.
I realise this is an old post but how did you get worms working on dosbox on the pi? I have tried but it just freezes on the dos protect mode startup. Did you try it on soft floating point or hard floating point?
by dan-youd
Wed Jan 09, 2013 6:20 pm
Forum: Other projects
Topic: Control a Hornby Train Set With a Raspi
Replies: 11
Views: 5880

Re: Control a Hornby Train Set With a Raspi

Analogue Hornby trainsets were 12Vdc, where reversing the polarity would reverse the direction of the locomotive. I would do this in steps... Control speed and direction : As already mentioned an H-bridge and PWM. Actually PWM will probably make your old locomotive work better than it used to on th...
by dan-youd
Wed Jan 09, 2013 5:55 pm
Forum: Other projects
Topic: Control a Hornby Train Set With a Raspi
Replies: 11
Views: 5880

Re: Control a Hornby Train Set With a Raspi

Oh I've just thought - if the track runs off say 12V AC instead, there might be a diode / rectifier thing inside the train to convert it to DC. In that case it might not be possible to run it backwards (without modifications that is). So that's another thing to check before building anything. I hav...
by dan-youd
Wed Jan 09, 2013 5:44 pm
Forum: Other projects
Topic: Control a Hornby Train Set With a Raspi
Replies: 11
Views: 5880

Re: Control a Hornby Train Set With a Raspi

It does sound achievable. And it does sound like a good idea. I don't do trains (I'm more of a scalextric guy) but there have been quite a few posts on wiring up train sets. I haven't seen anyone post any real technical details, though it's probably worth searching the forums (if you can work out h...
by dan-youd
Wed Jan 09, 2013 3:39 pm
Forum: Other projects
Topic: Control a Hornby Train Set With a Raspi
Replies: 11
Views: 5880

Control a Hornby Train Set With a Raspi

Not sure if the automation section might be the best place for this but if so feel free to move it mods. I have had and idea to try and control a Hornby Train Set from a Raspi. I have an old set from when I was younger up in my loft unassembled but fully working with enough track to make a decent ra...
by dan-youd
Mon Jan 07, 2013 7:35 pm
Forum: Troubleshooting
Topic: 50% Packet loss on Wifi!
Replies: 47
Views: 26888

Re: 50% Packet loss on Wifi!

Fair enough. Well I think you'd agree that the iperf test was a deffinate improvement over LAN than over WLAN right? Yes. I'm not understanding why the second iperf test was much worse that the first. Was there any change in setup? Is it just random chance on bootup whether you get first behaviour ...
by dan-youd
Mon Jan 07, 2013 3:52 pm
Forum: Troubleshooting
Topic: 50% Packet loss on Wifi!
Replies: 47
Views: 26888

Re: 50% Packet loss on Wifi!

Still comes up with 1 datagrams received out-of-order but I'm still not sure if thats good or bad? but as you can see no lost packets this time. That's not a problem. http://en.wikipedia.org/wiki/User_Datagram_Protocol "there is no guarantee of delivery, ordering or duplicate protection" Higher lev...
by dan-youd
Mon Jan 07, 2013 3:32 pm
Forum: Troubleshooting
Topic: 50% Packet loss on Wifi!
Replies: 47
Views: 26888

Re: 50% Packet loss on Wifi!

I have just got around to testing the Pi with a Powerline adapter and so far its working well. Ping test to www.google.co.uk got 0% packet loss, Ping tests to the Pi got 0% packet loss, ifconfig shows no dropped packets both RX and TX, this is my new iperf results by running iperf from my MyBook Wor...
by dan-youd
Mon Jan 07, 2013 10:38 am
Forum: Troubleshooting
Topic: 50% Packet loss on Wifi!
Replies: 47
Views: 26888

Re: 50% Packet loss on Wifi!

Just to make extra sure I'm not going mad I did one last test. I have a fresh install of ubuntu on a 16Gb sandisk flash drive with presistant storage so I plugged it into a spare usb port on my girlfriends netbook and booted into it. I then put the wireless adapter that I'm using in my Pi in the net...
by dan-youd
Sun Jan 06, 2013 9:37 pm
Forum: Troubleshooting
Topic: 50% Packet loss on Wifi!
Replies: 47
Views: 26888

Re: 50% Packet loss on Wifi!

Just did a new test with the iperf command: ~ # iperf -c 192.168.1.10 -b 20M -i 1 -t 5WARNING: option -b implies udp testing ------------------------------------------------------------ Client connecting to 192.168.1.10, UDP port 5001 Sending 1470 byte datagrams UDP buffer size: 104 KByte (default) ...
by dan-youd
Sun Jan 06, 2013 9:07 pm
Forum: Troubleshooting
Topic: 50% Packet loss on Wifi!
Replies: 47
Views: 26888

Re: 50% Packet loss on Wifi!

Actually forget that last post. I've just restarted the Pi and now the packet loss has started back up again. It doesn't make sense. It's to inconsistent to see what's even causing it because seconds after it was working it now decides its not working again.
by dan-youd
Sun Jan 06, 2013 8:39 pm
Forum: Troubleshooting
Topic: 50% Packet loss on Wifi!
Replies: 47
Views: 26888

Re: 50% Packet loss on Wifi!

I tried it out: I SSH'd into my MyBook World and used it to do the iperf command on the Pi. This is the result: --------------- Server listening on UDP port 5001 Receiving 1470 byte datagrams UDP buffer size: 160 KByte (default) ------------------------------------------------------------ [ 3] loca...
by dan-youd
Sat Jan 05, 2013 5:16 pm
Forum: Troubleshooting
Topic: 50% Packet loss on Wifi!
Replies: 47
Views: 26888

Re: 50% Packet loss on Wifi!

My conclusion is that its definately the wireless thats the issue but now I need a solution. Your wireless is on channel 8. This is not good if there are ANY other wireless about !!! Change the channel to either 1, 6 or 11. The ijuts who designed the 2.4 WiFi did not understand RF transmissions - a...
by dan-youd
Sat Jan 05, 2013 4:51 pm
Forum: Troubleshooting
Topic: 50% Packet loss on Wifi!
Replies: 47
Views: 26888

Re: 50% Packet loss on Wifi!

Ill give that a try in a bit. Out of interest what do them commands actually do? The iperf command sends UDP packets at a rate of 20 Mbits/s. UDP is lossy, so if there are errors/dropped packets they won't be retransmitted. The recieiving end will report what % of packets it actually received. With...
by dan-youd
Fri Jan 04, 2013 8:21 pm
Forum: Troubleshooting
Topic: 50% Packet loss on Wifi!
Replies: 47
Views: 26888

Re: 50% Packet loss on Wifi!

I have just got around to doing more tests on my Pi using my ethernet cable and these are the results I got: Pi Store opens fine on ethernet but gives me an error over wireless, Pinging www.google.co.uk from ethernet gives 0% packet loss but wireless gives me about 9% packet loss, pinging my Pi from...
by dan-youd
Fri Jan 04, 2013 6:49 pm
Forum: Troubleshooting
Topic: 50% Packet loss on Wifi!
Replies: 47
Views: 26888

Re: 50% Packet loss on Wifi!

Can you try: ("sudo apt-get install iperf" if you don't have it already) On Pi run: iperf -su -i 1 & On another machine run: iperf -c [IP address of Pi] -b 20M -i 1 -t 5 what is reported as packet loss? (final number in brackets) Ill give that a try in a bit. Out of interest what do them commands a...
by dan-youd
Fri Jan 04, 2013 6:09 pm
Forum: Troubleshooting
Topic: 50% Packet loss on Wifi!
Replies: 47
Views: 26888

Re: 50% Packet loss on Wifi!

I have finally had a chance today to test some more things out. I have tried with the Pi closer to the router with no change, I tried pinging www.google.co.uk which got 9% packet loss, I changed my MTU using ifconfig to 1450 as my ISP (talktalk) doesn't use the default 1500, but that just seemed to ...
by dan-youd
Tue Jan 01, 2013 10:43 pm
Forum: Troubleshooting
Topic: 50% Packet loss on Wifi!
Replies: 47
Views: 26888

Re: 50% Packet loss on Wifi!

by bgirardot » Tue Jan 01, 2013 6:11 pm What does CODE: SELECT ALL sudo iwlist scanning return for the access point you are connected to? [email protected] ~ $ sudo iwlist scanning lo Interface doesn't support scanning. wlan0 Scan completed : Cell 01 - Address: FC:75:16:AE:FD:28 ESSID:"AOL" Protocol:I...
by dan-youd
Tue Jan 01, 2013 5:48 pm
Forum: Automation, sensing and robotics
Topic: RPi as a security camera using Logitech Sphere MP with PTZ
Replies: 6
Views: 5457

Re: RPi as a security camera using Logitech Sphere MP with P

BerryPicker wrote:I came across this page today.
http://www.lavrsen.dk/foswiki/bin/view/Motion/WebHome
The faq features your camera.
Thanks will have to have a look at that when I get chance.

First things first, I've got to solve my packet loss problem over wlan which I've just recently found :(
by dan-youd
Tue Jan 01, 2013 5:44 pm
Forum: Troubleshooting
Topic: 50% Packet loss on Wifi!
Replies: 47
Views: 26888

50% Packet loss on Wifi!

I have been using my Raspberry Pi over wireless recently with a TP-Link Nano Wireless N adapter using the Realtek RTL8192CU chipset. The problem I'm having is that I have started using SSH to get into the RPi through my android tablet and phone but have been having trouble with SSH freezing constant...
by dan-youd
Mon Dec 31, 2012 3:54 pm
Forum: Automation, sensing and robotics
Topic: RPi as a security camera using Logitech Sphere MP with PTZ
Replies: 6
Views: 5457

RPi as a security camera using Logitech Sphere MP with PTZ

I'm not sure if this has already been done, but I have a Logitech Sphere MP which can pan tilt and zoom. My plan is to do a project using the camera on my raspberry pi as an automated security camera. Any suggestions or has it already been done? Thanks
by dan-youd
Thu Dec 13, 2012 11:44 pm
Forum: Media centres
Topic: Help stuck in windowed mode on raspbmc!
Replies: 2
Views: 1481

Help stuck in windowed mode on raspbmc!

I think I pressed something by mistake on my keyboard and now its stuck in windowed mode on raspbmc. Any ideas how to get back to full screen?

P.S I tried changing it from windowed mode in the settings but it doesn't do anything.

Go to advanced search