Go to advanced search

by exabrial
Sat Mar 26, 2016 4:45 am
Forum: General discussion
Topic: RPI3: Module nl80211 not found, required for HostAPD?
Replies: 8
Views: 18821

Re: RPI3: Module nl80211 not found, required for HostAPD?

Thanks! I think there were two keys to getting this working: one, /etc/network/interfaces needed wireless-mode master source-directory /etc/network/interfaces.d auto lo iface lo inet loopback auto eth0 iface eth0 inet manual auto wlan0 iface wlan0 inet manual wireless-mode Master auto lan0 iface lan...
by exabrial
Fri Mar 25, 2016 10:29 pm
Forum: General discussion
Topic: RPI3: Module nl80211 not found, required for HostAPD?
Replies: 8
Views: 18821

Re: RPI3: Module nl80211 not found, required for HostAPD?

Strange, also this might be of interest... wlan0 is not joining the bridge I have setup: [email protected]:~ $ sudo brctl show bridge name bridge id STP enabled interfaces lan0 8000.b827eb6728f2 no eth0 So I tried adding it manually: [email protected]:~ $ sudo brctl addif lan0 wlan0 can't add wlan0 to bri...
by exabrial
Fri Mar 25, 2016 10:08 pm
Forum: General discussion
Topic: RPI3: Module nl80211 not found, required for HostAPD?
Replies: 8
Views: 18821

RPI3: Module nl80211 not found, required for HostAPD?

Hey guys, I'm trying to use my RaspberryPi as a backup router for a 4G LTE connection. The great news is, NAT/DHCP works fantastic over ethernet, so I know I have that part of the problem solved. (I can plug a device into the pi and it pulls an address from DnsMasq running on the PI and uses the PI ...
by exabrial
Sun Jun 01, 2014 8:37 pm
Forum: Raspbian
Topic: Update OpenSSH to more current version
Replies: 3
Views: 1561

Re: Update OpenSSH to more current version

ooo... tempting. Thanks for the info!
by exabrial
Sun Jun 01, 2014 4:21 pm
Forum: Raspbian
Topic: Update OpenSSH to more current version
Replies: 3
Views: 1561

Update OpenSSH to more current version

Hey guys, I'd like to install Openssh 6.6. The reason behind this is for security and features. The big missing feature in the currently outdated version is the AuthorizedKeysCommand directive, which allows me to write a script to pull SSH public keys from LDAP. Anyway, I tried installing openssh fr...
by exabrial
Thu Oct 31, 2013 10:49 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Did I "blow" my SPI output somehow
Replies: 0
Views: 372

Did I "blow" my SPI output somehow

Hey guys, I had a lpd8806 hooked up to my SPI interface. I was playing around with https://code.google.com/p/lpd8806-tools/ and had everything working just great. Anyway, after some rewiring, I can't get the code to work anymore. I downloaded and compiled spitest.c and I get all 0s from the mosi->mo...
by exabrial
Fri Jan 04, 2013 5:13 am
Forum: Troubleshooting
Topic: Incredible delay, lag, and packet loss over USB Wifi
Replies: 4
Views: 2535

Re: Incredible delay, lag, and packet loss over USB Wifi

I will gladly help! I've got tons of time, and while I've never picked apart the network stack, I'm linux savvy and a programmer. Point me in the direction and I'll learn the skills to help out.
by exabrial
Thu Jan 03, 2013 6:16 pm
Forum: Troubleshooting
Topic: USB redux
Replies: 514
Views: 201480

Re: USB redux

I'm having problems with WiFi I suspect are related to USB. I've done the normal fixes (get a powered hub, try a different card, mess endlessly with your router and wireless) and the raspberrypi is the only device suffering on my network. I certainly don't want to impede the progress on this thread,...
by exabrial
Thu Jan 03, 2013 6:10 pm
Forum: General discussion
Topic: best wifi dongle
Replies: 18
Views: 8456

Re: best wifi dongle

It may not be your adapter... many of us are having these sorts of problems it seems

http://www.raspberrypi.org/phpBB3/viewt ... 6&p=249720
by exabrial
Thu Jan 03, 2013 6:32 am
Forum: Troubleshooting
Topic: Incredible delay, lag, and packet loss over USB Wifi
Replies: 4
Views: 2535

Incredible delay, lag, and packet loss over USB Wifi

Hey guys, I have a Model B running on a wireless N network using a Tenda w311m (firmware-rarlink) wireless card. The card is plugged into a 1am powered USB2.0 hub. It's sitting 6ft from the router, I'm running on an empty channel, and no other devices on my network are having this sort of problem. I...
by exabrial
Fri Dec 14, 2012 8:23 pm
Forum: Raspbian
Topic: can't install gcj-4.7-jdk, package error on libecj-java-gcj
Replies: 2
Views: 1014

Re: can't install gcj-4.7-jdk, package error on libecj-java-

It installs now :) I'm testing it
by exabrial
Tue Nov 27, 2012 12:02 am
Forum: Raspbian
Topic: can't install gcj-4.7-jdk, package error on libecj-java-gcj
Replies: 2
Views: 1014

can't install gcj-4.7-jdk, package error on libecj-java-gcj

Hello everyone, This problem is being looked into, but I figured i'd post here in case anyone else has the same issue: [email protected] ~ $ sudo aptitude install gcj-4.7-jdk The following NEW packages will be installed: ecj{a} ecj-gcj{a} ecj1{a} fastjar{a} g++-4.7{a} gcj-4.6-base{a} gcj-4.6-jre-headle...

Go to advanced search