Go to advanced search

by SR-71
Thu Apr 07, 2016 5:30 am
Forum: Troubleshooting
Topic: [RPi3] SSH not working via wifi
Replies: 155
Views: 101911

Re: [RPi3] SSH not working via wifi

Edit: Adding "IPQoS cs0 cs0" to /etc/ssh/sshd_config worked for me, too. It would be nice if the man page for sshd gave a more informative explanation of the various IPQoS config values. I'm having the same problem using ssh or scp from a MacBook Pro. It gets far enough into the protocol that I don...
by SR-71
Tue Mar 29, 2016 2:21 pm
Forum: Troubleshooting
Topic: WiFi ONLY works if Ethernet is plugged in
Replies: 57
Views: 34205

Re: WiFi ONLY works if Ethernet is plugged in

I have the same issue on RPI 2. WiFi only works when Ethernet cable is plugged in. Reading through this thread, I still have not figured out how to resolve the issue. From the discussions, it seems like the solution is somewhere in one of these files: /etc/dhcpcd.conf /etc/network/interfaces probab...
by SR-71
Sat Mar 26, 2016 10:37 pm
Forum: Troubleshooting
Topic: [RPi3] SSH not working via wifi
Replies: 155
Views: 101911

Re: [RPi3] SSH not working via wifi

Add IPQoS cs0 cs0 to /etc/ssh/sshd_config Next you have to restart the daemon: sudo service ssh restart Ok, just an update, I was having a blonde moment lastnight and was editing /etc/ssh/ssh_config . Whereas it should be /etc/ssh/sshd_config as SR-71 indicated. Apologies! And the iptables mangling...
by SR-71
Sat Mar 26, 2016 9:02 pm
Forum: Troubleshooting
Topic: Time does not sync on Pi 3 and with official dongle [Solved]
Replies: 57
Views: 35466

Re: Time does not sync on Pi 3 or when official dongle is us

Hi all, ntpd emits IP/UDP packets with ToS field set to 0xc0. So that is quite similar to the other issue I (and many others) have with RPI3 when operated over WiFi internal interface. Try to reconfigure ntpd in such way it uses ToS = 0. If confirmed, that definitively points to some firmware/drive...
by SR-71
Sat Mar 26, 2016 8:50 pm
Forum: Troubleshooting
Topic: Time does not sync on Pi 3 and with official dongle [Solved]
Replies: 57
Views: 35466

Re: Time does not sync on Pi 3 or when official dongle is us

Hi all, ntpd emits IP/UDP packets with ToS field set to 0xc0. So that is quite similar to the other issue I (and many others) have with RPI3 when operated over WiFi internal interface. EDIT: As workaround, add the following command /sbin/iptables -t mangle -I POSTROUTING 1 -o wlan0 -p udp --dport 12...
by SR-71
Fri Mar 25, 2016 11:37 pm
Forum: Troubleshooting
Topic: [RPi3] SSH not working via wifi
Replies: 155
Views: 101911

Re: [RPi3] SSH not working via wifi

Yup, no joy with that. Might this be of relevance: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=650512 ? I don't think so, that bug is referring to a very old release of OpenSSH. Where are you running the SSH client ? If you are on a *nix platform, try to start the client as follows: ssh -oIPQ...
by SR-71
Fri Mar 25, 2016 10:53 pm
Forum: Troubleshooting
Topic: [RPi3] SSH not working via wifi
Replies: 155
Views: 101911

Re: [RPi3] SSH not working via wifi

Just to catch up, /etc/ssh/sshd_config should be: Host * IPQoS cs0 cs0 Correct? As that doesn't seem to work here... I'm confused as to what's exactly at fault now. Out of all the people reporting this, all the dongles, routers etc, the Pi 3 WiFi is the common denominator. How does changing the Pi ...
by SR-71
Fri Mar 25, 2016 10:46 pm
Forum: Troubleshooting
Topic: [RPi3] SSH not working via wifi
Replies: 155
Views: 101911

Re: [RPi3] SSH not working via wifi

It seems that the Raspberry wireless driver is not able to forward IPv4 packets with ToS != 0. No, it is not the Raspberry wireless driver, it is your ssh-Client or your WLAN-Router (for ssh over PI3 Wifi onboard) that is not able to forward IPv4 packets with ToS != 0. I just took a trace using the...
by SR-71
Fri Mar 25, 2016 10:25 pm
Forum: Troubleshooting
Topic: [RPi3] SSH not working via wifi
Replies: 155
Views: 101911

Re: [RPi3] SSH not working via wifi

..., but no joy, it is locking exactly as before. Try additionally with IPQoS cs1 cs1 in the /etc/ssh/sshd_config Using IPQoS cs1 cs1 locked even IPv6 ! I had to reconnect the ethernet cable in order to regain the control... BUT, IPQoS cs0 cs0 did the trick !! Many thanks for the help ! EDIT: with ...
by SR-71
Fri Mar 25, 2016 9:42 pm
Forum: Troubleshooting
Topic: [RPi3] SSH not working via wifi
Replies: 155
Views: 101911

Re: [RPi3] SSH not working via wifi

It seems that the Raspberry wireless driver is not able to forward IPv4 packets with ToS != 0. No, it is not the Raspberry wireless driver, it is your ssh-Client or your WLAN-Router (for ssh over PI3 Wifi onboard) hat is not able to forward IPv4 packets with ToS != 0. [/code] When I connect to othe...
by SR-71
Fri Mar 25, 2016 9:04 pm
Forum: Troubleshooting
Topic: [RPi3] SSH not working via wifi
Replies: 155
Views: 101911

Re: [RPi3] SSH not working via wifi

An IPv4 workaround, that works for me: /sbin/iptables -t mangle -I PREROUTING 1 -i wlan0 -p tcp --dport 22 -j TOS --set-tos 0x00 /sbin/iptables -t mangle -I POSTROUTING 1 -o wlan0 -p tcp --sport 22 -j TOS --set-tos 0x00 So, apparently the problem is triggered by the SSH client behavior: it is chang...
by SR-71
Sat Mar 19, 2016 3:32 pm
Forum: Troubleshooting
Topic: Working well on Ethernet but no on WiFi (RDP/SSH)
Replies: 17
Views: 14184

Re: Working well on Ethernet but no on WiFi (RDP/SSH)

I am a happy owner of a 512Mb B Pi. I have it running Raspbian (all updated and upgraded). It has a 4 port powered USB hub with a wireless keyboard (and built in trackpad) dongle (working perfectly) and an external 1Tb disk (stuffed with movies and the like). This is connected to one of the Pi USB ...
by SR-71
Sat Mar 19, 2016 3:28 pm
Forum: Troubleshooting
Topic: [RPi3] SSH not working via wifi
Replies: 155
Views: 101911

Re: [RPi3] SSH not working via wifi

I found a workaround: just connect to RPI3 using the link local IPv6 address.
You find that address with ifconfig.
Irrispective of the wired ethernet status, it always works.
Of course that makes sense only on a bridged network: I didn't test using a global IPv6 address.
by SR-71
Fri Mar 18, 2016 10:00 pm
Forum: Troubleshooting
Topic: [RPi3] SSH not working via wifi
Replies: 155
Views: 101911

Re: [RPi3] SSH not working via wifi

As suggested upthread I did update / upgrade / rpi-update but no luck: the SSH is not surviving to ethernet cable detaching. So, I setup a small netcat based telnet server and verified that really , when I detach the cable, only SSH seems to be impacted: the crude telnet server is still working. I e...
by SR-71
Fri Nov 23, 2012 9:40 pm
Forum: Troubleshooting
Topic: Ethernet dies after about 12 hours, nothing connected to USB
Replies: 12
Views: 6325

Re: Ethernet dies after about 12 hours, nothing connected to

I solved the problem using suggestions found in

https://github.com/raspberrypi/linux/issues/151

It seems that a rpi-update cured definitively that problem.
by SR-71
Fri Nov 23, 2012 8:00 pm
Forum: Troubleshooting
Topic: Ethernet dies after about 12 hours, nothing connected to USB
Replies: 12
Views: 6325

Re: Ethernet dies after about 12 hours, nothing connected to

Same problem here: I have an unattended system with one only device attached to the USB and of course the ethernet.
Nokia power supply as provided.
The system freezes every 6-24 hours.

uname -a
Linux raspberrypi 3.2.27+ #160 PREEMPT Mon Sep 17 23:18:42 BST 2012 armv6l GNU/Linux

Go to advanced search