Go to advanced search

by andig2
Thu Mar 08, 2018 9:18 pm
Forum: Advanced users
Topic: Moving Linux kernel to 4.9
Replies: 289
Views: 106739

Re: Moving Linux kernel to 4.9

Hi,

is there any way to get kernel headers for current 4.14 kernel versions? I need to compile the usb2can driver and am totally failing to do so :(

Thanks,
Andi
by andig2
Sat Sep 02, 2017 10:57 am
Forum: Troubleshooting
Topic: Making TFTP boot robust?
Replies: 13
Views: 2064

Re: Making TFTP boot robust?

I don't even get that far. I've noticed my single Pi3 doesn't net boot at all with out bootcode.bin. It gets its IP address and I see it ask for the TFTP service IP on the network but that's that. No TFTP. Only ever got it working with bootcode.bin present. No answer to the firmware issue on github ...
by andig2
Sat Sep 02, 2017 10:52 am
Forum: Troubleshooting
Topic: [help] Raspi3 fails to boot from network
Replies: 2
Views: 940

Re: [help] Raspi3 fails to boot from network

For anybody coming here I've opened two issues: https://github.com/raspberrypi/firmware/issues/862 for Raspi not connecting to TFTP without SD card and https://github.com/raspberrypi/firmware/issues/863 for Raspi not able to mount root filesystem over NFS The latter- not mentioned in the tutorial- c...
by andig2
Sun Aug 27, 2017 11:53 am
Forum: Raspbian
Topic: PXE boot requires NFS v2 but Raspbian Lite (stretch) doesn't support it?
Replies: 1
Views: 539

PXE boot requires NFS v2 but Raspbian Lite (stretch) doesn't support it?

I'm coming from https://github.com/raspberrypi/firmware/issues/863.

It seems PXE boot demands NFS v2 but that's not available with raspi server running debian 9/stretch (only v3 and v4 are supported).

:arrow: Catch 22?

Thanks,
Andreas
by andig2
Sat Aug 26, 2017 12:18 pm
Forum: Troubleshooting
Topic: [help] Raspi3 fails to boot from network
Replies: 2
Views: 940

[help] Raspi3 fails to boot from network

I've received a new raspi3 that I'm trying to prepare for network boot following https://www.raspberrypi.org/documentation/hardware/raspberrypi/bootmodes/net_tutorial.md. Client config has been completed, so has server config. Upon booting, I can see the raspi's request: [email protected]:~ $ sudo tcpdump -...
by andig2
Fri Feb 17, 2017 7:41 am
Forum: Troubleshooting
Topic: SSD via USB boot
Replies: 2
Views: 1219

Re: SSD via USB boot

Tried some more and added program_usb_timeout=1 to config.txt, the rebooted for programming and rebooted again without SD. Raspi booted without SD now, however green led blinks continuously now at a slow pace. Everything else seems to be working, felt performance is better than with SD. Thanks for M...
by andig2
Thu Feb 16, 2017 7:40 pm
Forum: Troubleshooting
Topic: SSD via USB boot
Replies: 2
Views: 1219

SSD via USB boot

I've followed https://www.raspberrypi.org/documentation/hardware/raspberrypi/bootmodes/msd.md for setting up USB boot without SSD for Transcend 32GB m.2 SSD via Renkforce adapter. Unfortunately, after removing the SD card, the Pi3 doesn't come up and flashes green 4 times. This is the "normal" dmesg...
by andig2
Fri Jan 27, 2017 5:43 pm
Forum: Raspbian
Topic: [SOVLED] apt-get segfaults
Replies: 6
Views: 3731

Re: apt-get segfaults

ok.... fixed by reinstalling apt (however these seem to be the same versions as originally present). Whatever :roll: cd /tmp wget -r -nH -nd -np http://mirrordirector.raspbian.org/raspbian/pool/main/a/apt/ sudo dpkg -i apt-utils_1.0.9.8.4_armhf.deb apt_1.0.9.8.4_armhf.deb libapt-inst1.5_1.0.9.8.4_ar...
by andig2
Fri Jan 27, 2017 5:11 pm
Forum: Raspbian
Topic: [SOVLED] apt-get segfaults
Replies: 6
Views: 3731

Re: apt-get segfaults

There is a report here https://bugs.launchpad.net/ubuntu/+sour ... ug/1457754 that indicates underlying curl/gnu tls or similar might be the issue. Need to figure out if/how I could downgrade those. :ugeek:
by andig2
Fri Jan 27, 2017 5:03 pm
Forum: Raspbian
Topic: [SOVLED] apt-get segfaults
Replies: 6
Views: 3731

Re: apt-get segfaults

I have no clue what the apt http module is, but apt itself seems to be the jessie package: [email protected]:~ $ apt-cache policy apt apt: Installed: 1.0.9.8.4 Candidate: 1.4~beta2 Version table: 1.4~beta2 0 500 http://mirrordirector.raspbian.org/raspbian/ stretch/main armhf Packages *** 1.0.9.8.4 0 500 htt...
by andig2
Fri Jan 27, 2017 4:50 pm
Forum: Raspbian
Topic: [SOVLED] apt-get segfaults
Replies: 6
Views: 3731

Re: apt-get segfaults

Not much of a back story. Several raspies running for ages. Moved my webserver to new raspi3 and just got warned that my letsencrypt certificates are expiring. Looking into the logfile I see certbot complains about missing apache modules (but doesn't say which). Trying to upgrade certbot and bamm. B...
by andig2
Fri Jan 27, 2017 4:06 pm
Forum: Raspbian
Topic: [SOVLED] apt-get segfaults
Replies: 6
Views: 3731

[SOVLED] apt-get segfaults

[email protected]:~ $ sudo apt update E: Method http has died unexpectedly! E: Sub-process http received a segmentation fault. [email protected]:~ $ sudo apt-get -v apt 1.0.9.8.4 for armhf compiled on Dec 13 2016 22:26:22 Supported modules: *Ver: Standard .deb *Pkg: Debian dpkg interface (Priority 30) Pkg: Debian ...
by andig2
Sat Jan 14, 2017 9:41 am
Forum: Raspbian
Topic: [solved] Apache: Can't install mod_proxy_html?
Replies: 9
Views: 2139

[Solved] Apache: Can't install mod_proxy_html?

Thank you for all the advice- I finally got it. I have php7 installed from stretch- that seems to force the apache from stretch. It seems to proxy modules are now bundled with apache core and the install therefore no longer necessary- which I didn't notice due to the wrong a2enmod command. I finally...
by andig2
Fri Jan 13, 2017 7:52 pm
Forum: Raspbian
Topic: [solved] Apache: Can't install mod_proxy_html?
Replies: 9
Views: 2139

Re: Apache: Can't install mod_proxy_html?

... and after removing apache I'm in the same spot. Stretch takes precedence: [email protected]:~/volkszaehler.org $ sudo apt install -t jessie apache2 The following packages have unmet dependencies: apache2 : Depends: apache2-bin (= 2.4.10-10+deb8u7) but 2.4.25-1 is to be installed Depends: apache2-data (=...
by andig2
Fri Jan 13, 2017 7:46 pm
Forum: Raspbian
Topic: [solved] Apache: Can't install mod_proxy_html?
Replies: 9
Views: 2139

Re: Apache: Can't install mod_proxy_html?

Update: it looks- if I interpret the *** in the output correctly, as if apt is still preferring stretch? Arggh, I see- it already did install the stretch version apparently? [email protected]:~/volkszaehler.org $ apt-cache policy libapache2-mod-proxy-html apache2-bin libapache2-mod-proxy-html: Installed: (n...
by andig2
Fri Jan 13, 2017 7:37 pm
Forum: Raspbian
Topic: [solved] Apache: Can't install mod_proxy_html?
Replies: 9
Views: 2139

Re: Apache: Can't install mod_proxy_html?

Here we go: [email protected]:~/volkszaehler.org $ apt-cache policy libapache2-mod-proxy-html apache2-bin libapache2-mod-proxy-html: Installed: (none) Candidate: 1:2.4.10-10+deb8u7 Version table: 1:2.4.10-10+deb8u7 0 600 http://mirrordirector.raspbian.org/raspbian/ jessie/main armhf Packages apache2-bin: In...
by andig2
Fri Jan 13, 2017 6:50 pm
Forum: Raspbian
Topic: [solved] Apache: Can't install mod_proxy_html?
Replies: 9
Views: 2139

Re: Apache: Can't install mod_proxy_html?

To add, this is my sources.list: deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi deb http://mirrordirector.raspbian.org/raspbian/ stretch main contrib non-free rpi deb http://httpredir.debian.org/debian jessie-backports main contrib non-free apt preferences: Package...
by andig2
Fri Jan 13, 2017 6:28 pm
Forum: Raspbian
Topic: [solved] Apache: Can't install mod_proxy_html?
Replies: 9
Views: 2139

[solved] Apache: Can't install mod_proxy_html?

This is what happens: [email protected]:~/volkszaehler.org $ sudo apt-get install php-cgi libapache2-mod-proxy-html Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or ...
by andig2
Thu Jul 28, 2016 6:07 pm
Forum: Troubleshooting
Topic: Shell corrupted - virus or SD failure?
Replies: 14
Views: 1829

Re: Shell corrupted - virus or SD failure?

Checking back in for an update. > Swap out everything, the usb cable, the power supply, the sdcard with one from known working system, run with nothing but display and keyboard. Is there still a reoccurring problem? There wasn't much so swap- only the PSU with fixed cable is attached plus ethernet. ...
by andig2
Sun Jul 24, 2016 12:53 pm
Forum: Troubleshooting
Topic: Shell corrupted - virus or SD failure?
Replies: 14
Views: 1829

Re: Shell corrupted - virus or SD failure?

I didn't even switch it off in between. If I do when shutdown first and remove power then. This last SD died right in the middle of apt-get, without mechanical influence or anything. Have not seen such behaviour with the older Bs I was using sofar...
by andig2
Sun Jul 24, 2016 12:05 pm
Forum: Troubleshooting
Topic: Shell corrupted - virus or SD failure?
Replies: 14
Views: 1829

Re: Shell corrupted - virus or SD failure?

For sure, but- this has just happened again- on a 3rd SD. Broke while updating: [email protected]:~ $ sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... The following packages were automatically installed and are no longe...
by andig2
Sun Jul 24, 2016 11:33 am
Forum: Troubleshooting
Topic: Shell corrupted - virus or SD failure?
Replies: 14
Views: 1829

Re: Shell corrupted - virus or SD failure?

Thanks for the help. I didn't get as far as the mem test: [email protected]:~ $ sudo apt-get install memtester Reading package lists... Done Building dependency tree Reading state information... Done The following NEW packages will be installed: memtester 0 upgraded, 1 newly installed, 0 to remove and ...
by andig2
Sat Jul 23, 2016 1:53 pm
Forum: Troubleshooting
Topic: Shell corrupted - virus or SD failure?
Replies: 14
Views: 1829

Shell corrupted - virus or SD failure?

Just tried installing some node modules on a pi2 that I've recently setup and noticed this: [email protected]:~ $ npm -bash: /usr/local/bin/npm: /bin/sh: bad interpreter: No such file or directory [email protected]:~ $ ls -l /bin/sh* lrwxrwxrwx 1 root root 4 Jan 21 2014 /bin/sh -> da3h [email protected]:~ $ ...
by andig2
Fri May 13, 2016 6:43 am
Forum: Raspbian
Topic: Minimal image broken or weird SD card issue?
Replies: 1
Views: 693

Minimal image broken or weird SD card issue?

I've just installed a Pi2 with the latest minimal raspbian image. Updated software plus firmware and then went about installing software when the problems started: [email protected]:~/vzlogger $ sudo apt-get install cmake Reading package lists... Done Building dependency tree Reading state information....
by andig2
Thu Oct 22, 2015 6:29 am
Forum: Python
Topic: Reading Audio stream for FFT
Replies: 63
Views: 81752

Re: Reading Audio stream for FFT

snd_loopback was included in the last Wheezy image; not sure of Jessie. I'm following the instructions here https://github.com/karlstav/cava . I got the loopback device just fine via modprobe and have setup an asound.conf as in https://github.com/karlstav/cava/blob/master/example_files/etc/asound.c...

Go to advanced search