Go to advanced search

by ByteArts
Fri Oct 05, 2018 8:19 pm
Forum: Compute Module
Topic: COMPUTE MODULE 3 obsolescence
Replies: 5
Views: 2669

Re: COMPUTE MODULE 3 obsolescence

Replying to my own post...

I found the answer I was looking for here: https://www.raspberrypi.org/documentati ... CM_2p0.pdf

They say all versions of the compute module will be produced until at least Jan 2023.
by ByteArts
Fri Oct 05, 2018 7:55 pm
Forum: Compute Module
Topic: COMPUTE MODULE 3 obsolescence
Replies: 5
Views: 2669

Re: COMPUTE MODULE 3 obsolescence

Is there any more information on this? I'm wanting to make a recommendation to a client to use the CM3, but they are concerned about how long it will be available.
by ByteArts
Fri Dec 29, 2017 7:11 pm
Forum: Networking and servers
Topic: isc-dhcp-server fails to start.
Replies: 29
Views: 48425

Re: isc-dhcp-server fails to start.

I've used this and dnsmasq, and dnsmasq seems easier to set up. Just my opinion. https://github.com/SurferTim/documentation/blob/6bc583965254fa292a470990c40b145f553f6b34/configuration/wireless/access-point.md I agree! I followed your instructions and got my Pi access point working right away. I was...
by ByteArts
Thu Dec 28, 2017 1:36 am
Forum: Troubleshooting
Topic: Pi B+ boards ELPIDA/Samsung
Replies: 3
Views: 999

Re: Pi B+ boards ELPIDA/Samsung

Can you provide any more details about which files need to be updated? I'm having the same problem as the OP. Thanks!
by ByteArts
Mon Nov 14, 2016 4:29 pm
Forum: Compute Module
Topic: Cannot flash the Compute Module
Replies: 2
Views: 1315

Re: Cannot flash the Compute Module

Have you tried more than one CM? I've programmed many of them, but have a couple which do exactly what you describe -- no matter what I tried I couldn't get them programmed. Maybe you have one of these bad modules?

-Scott
by ByteArts
Fri Jun 10, 2016 4:45 pm
Forum: Other programming languages
Topic: Lazarus on R 3B
Replies: 5
Views: 1444

Re: Lazarus on R 3B

I used the install script at getlazarus.org and it worked fine. Lazarus runs great on the Pi 3!
-Scott
by ByteArts
Fri May 08, 2015 2:25 pm
Forum: General programming discussion
Topic: Can't install libhid-dev
Replies: 8
Views: 2700

Re: Can't install libhid-dev

Realized I haven't updated this in awhile... I have a working version of the Microchip HID bootloader that runs from the command line and doesn't include any GUI, so it can be compiled with a minimum of dependencies. (It can be compiled for Windows as well). Just send me a PM for more info... I'm ha...
by ByteArts
Tue Feb 10, 2015 1:03 am
Forum: General programming discussion
Topic: Can't install libhid-dev
Replies: 8
Views: 2700

Re: Can't install libhid-dev

Just a quick update -- I've been able to strip out all the GUI stuff from Microchip's "cross-platform" bootloader code and turn it into a command-line program that can be compiled without needing the Qt GUI libraries. I'm still need to figure out how to build a makefile for it on the Pi (so far I'm ...
by ByteArts
Mon Jan 26, 2015 4:26 pm
Forum: General programming discussion
Topic: Can't install libhid-dev
Replies: 8
Views: 2700

Re: Can't install libhid-dev

After more testing with the mphidflash and finding more problems with it, I've decided to go another route and am working on converting the Microchip "cross-platform" HID bootloader program to run on the pi. I'll post results here once I'm further along.
by ByteArts
Fri Jan 23, 2015 7:22 pm
Forum: General programming discussion
Topic: Can't install libhid-dev
Replies: 8
Views: 2700

Re: Can't install libhid-dev

I did try it on Windows and I get the same problem -- mphidflash reports a "Error: Verify Failed" when using the new firmware file (71K in size), but works fine with the old firmware file (63K in size), so I think the problem is somewhere in the program itself. I guess I'll dig into it and see if I ...
by ByteArts
Fri Jan 23, 2015 6:42 pm
Forum: General programming discussion
Topic: Can't install libhid-dev
Replies: 8
Views: 2700

Re: Can't install libhid-dev

rpdom - Wow -- thanks so much for your help -- I owe you! I followed your instructions and got it to build and run, and "almost" work. I'm still having a problem with the mphidflash program not programming the firmware correctly -- it seems to corrupt part of the memory, but I don't think that's any...
by ByteArts
Fri Jan 23, 2015 5:41 am
Forum: General programming discussion
Topic: Can't install libhid-dev
Replies: 8
Views: 2700

Can't install libhid-dev

Hi - I'm trying to install the latest version of mphidflash ( https://code.google.com/p/mphidflash/ ) -- it's a program used to load firmware on to a Microchip PIC microprocessor via USB, and one of the prerequisites it requires is libhid-dev. I've tried "sudo apt-get install libhid-dev", but it doe...
by ByteArts
Tue Sep 02, 2014 11:10 pm
Forum: Raspbian
Topic: isc-dhcp-server dying when booting
Replies: 9
Views: 5930

Re: isc-dhcp-server dying when booting

I had a similar issue -- isc-dhcp-server wasn't dying, but instead would constantly disconnect and reconnect clients. If I manually restarted the service after rebooting, it would work fine. This bit of code from huafu solved my problem -- thanks! I only started having this problem after moving my f...
by ByteArts
Sat Jan 12, 2013 6:58 pm
Forum: Other
Topic: Lazarus how-to update?
Replies: 4
Views: 944

Re: Lazarus how-to update?

Here's a useful post I found that describes how to get the latest Lazarus on the Pi:
http://www.michellcomputing.co.uk/blog/ ... pberry-pi/

(Thanks to http://www.contrapositivediary.com for making me aware of the link).
by ByteArts
Mon Oct 29, 2012 4:15 pm
Forum: Other programming languages
Topic: Lazarus didn't run proper?
Replies: 6
Views: 2364

Re: Lazarus didn't run proper?

Why would you need to recompile the IDE? (I'm a noob at Lazarus, and was just wondering). I was able to install and use Lazarus with no problems on Wheezy using "apt-get install lazarus". I just got a 512MB Pi and am anxious to try out Lazarus on that to see if the app builds go any faster -- they a...

Go to advanced search