Go to advanced search

by JoeSoap
Sun Apr 12, 2020 10:12 am
Forum: HATs and other add-ons
Topic: prototyping board w/o strips ?
Replies: 5
Views: 299

Re: prototyping board w/o strips ?

Thanks for the response ... the Winwill DIY Proto Hat Shield is the sort I dislike , with 'bars' across the back . Adafruit Perma-Proto Pi HAT .... my eyesight is not improving with age and I didnt see the ' bars' at first ... had to get the optivisor on to see them on my screen :-( So these are the...
by JoeSoap
Sat Apr 11, 2020 3:31 pm
Forum: HATs and other add-ons
Topic: prototyping board w/o strips ?
Replies: 5
Views: 299

Re: prototyping board w/o strips ?

Useful info .

I looked on the cool components website but they dont seems to have
the PiBreak (Plus) (that I could find) ,
so I'll order some today from the robotshop .

Thanks for the response .
by JoeSoap
Sat Apr 11, 2020 12:10 pm
Forum: HATs and other add-ons
Topic: prototyping board w/o strips ?
Replies: 5
Views: 299

prototyping board w/o strips ?

Talking pi 2,3,4 B , prototyping board that can be positioned on top of a pi. Several years ago I bought a couple of Pi prototyping boards from a supplier that doesnt sell them any more . All of the ones that are turned up in a search now, have plated bars connecting the via's (on the back) and you ...
by JoeSoap
Sun Jul 09, 2017 3:24 pm
Forum: OpenGLES
Topic: setting MVP for multiple meshes
Replies: 0
Views: 1766

setting MVP for multiple meshes

over 10yrs ago I used opengl a bit and then ogre but not done any such since. Been trying to get a grip of opengl on the rpi2/3 and write some classes to help but there is one aspect that I dont understand - as per the title. (have been looking at peepo's tuts) so if use the same pair of vertex and ...
by JoeSoap
Thu Mar 16, 2017 4:45 pm
Forum: Troubleshooting
Topic: Internet and VNC access but ping gives 0 packets received?
Replies: 1
Views: 347

Re: Internet and VNC access but ping gives 0 packets receive

I am assuming ipv4 ? so you have hostapdpi which is connected to the internet, and a set of clientpis which are connected thru the wifi to hostapdpi . hostapdpi can access the internet , so from that you can ping 8.8.8.8 and see replies ? the client pis can ping hostapdpi (and see replies) ? there a...
by JoeSoap
Mon Feb 13, 2017 9:03 am
Forum: C/C++
Topic: simple C++ ctor Q
Replies: 3
Views: 785

Re: simple C++ ctor Q

Just to clarify the answer (as explained in PeterO's link), it is because the c++ compiler (for the example below) Myclass fred() ; interprets it as a declaration of function fred returning a Myclass object. Not that I would ever declare function in a list of vars ... but heyho Thanks to PeterO for ...
by JoeSoap
Sun Feb 12, 2017 8:55 pm
Forum: C/C++
Topic: simple C++ ctor Q
Replies: 3
Views: 785

[answered] simple C++ ctor Q

Thats what I call google foo . Thanks . It took me several reads thru that
to understand what it was saying . As I experienced it, it will probably stay
with me for some time (maybe a couple of days )

Thanks

JoeSoap
by JoeSoap
Sun Feb 12, 2017 8:27 pm
Forum: C/C++
Topic: simple C++ ctor Q
Replies: 3
Views: 785

simple C++ ctor Q

I use pigeon C++ with g++ as the compiler .the code below illustrates my problem/question. /*************************************************************************** ctorq.cpp ***************************************************************************/ #include <stdio.h> class Bob { public : int B...
by JoeSoap
Wed Jan 18, 2017 11:52 am
Forum: Troubleshooting
Topic: Using temperature sensors
Replies: 1
Views: 326

Re: Using temperature sensors

Tom, the DS18B20 is a one wire dallas semiconductor to92 ic that can be used directly with a pi. You can buy the item itself, or more commonly , one with a cable already attached. You would need to enable the one wire system on the pi . A couple of links about the ds18b20 and the one wire system htt...
by JoeSoap
Tue Jan 17, 2017 10:21 am
Forum: Troubleshooting
Topic: fixed:openvpn with server and single client
Replies: 1
Views: 488

Re: openvpn with server and single client

ok , experimented some more and the server cfg that now works for me (TM) # /etc/openvpn/server.conf log /var/log/openvpn.log status /var/log/openvpn-status.log 20 verb 7 local 192.168.0.94 port 1194 proto tcp-server dev tun ca /etc/openvpn/easy-rsa/keys/ca.crt cert /etc/openvpn/easy-rsa/keys/soapse...
by JoeSoap
Mon Jan 16, 2017 2:59 pm
Forum: Troubleshooting
Topic: fixed:openvpn with server and single client
Replies: 1
Views: 488

fixed:openvpn with server and single client

have had openvpn working with a static key with a server and a single client connecting to it using the openvpn (static key ?) howto . That was done using a cmd line config with ifconfig 10.8.0.1 10.8.02 on my server and ifconfig 10.8.0.2 10.8.0.1 on the client and all was happy. I was able to ping ...
by JoeSoap
Tue Jan 10, 2017 2:23 pm
Forum: Troubleshooting
Topic: Symptom: no wifi icon
Replies: 5
Views: 1237

Re: Symptom: no wifi icon

I had expected that anyone using the raspberry pi would be familiar with linux (which is the operating system , roughly equivalent to microsoft windows). I can now see that was a mistaken assumption and that there are users who arent. I should have realised before, with the strange concepts of 'scra...
by JoeSoap
Mon Jan 09, 2017 4:01 pm
Forum: Troubleshooting
Topic: Motion troubleshooting
Replies: 8
Views: 2043

Re: Motion troubleshooting

The ip address of your windows pc is something that you should know but there is something being mounted. You say it is not filling up but it looks quite full to me at 83% - clearly not an immediate worry , but ... so there are no files in /mnt/camshare ? nor in the dir that you are running it in ? ...
by JoeSoap
Mon Jan 09, 2017 3:40 pm
Forum: Troubleshooting
Topic: Symptom: no wifi icon
Replies: 5
Views: 1237

Re: Symptom: no wifi icon

I am no expert on the gui side of things (nor on the wifi side), so just to indicate what info might be useful for a diagnosis by other people etc. indicators of what level your system is at uname -r presumably you are just using the inbuilt wifi (not a usb dongle) ? what else is in your system ie j...
by JoeSoap
Mon Jan 09, 2017 2:54 pm
Forum: Troubleshooting
Topic: Motion troubleshooting
Replies: 8
Views: 2043

Re: Motion troubleshooting

Glad you spotted my deliberate mistake and used du (vs df ). I have only run motion a couple of times but wrote my own version so I dont have much experience with motion itself. I would expect it to put the files in the target_dir ie /mnt/camshare or failing that in the dir you run it from. Have jus...
by JoeSoap
Mon Jan 09, 2017 9:12 am
Forum: Troubleshooting
Topic: Motion troubleshooting
Replies: 8
Views: 2043

Re: Motion troubleshooting

the normal place for the motion conf file is /etc/motion/motion.conf which should somewhere (just had a *quick* skim and couldnt find it) have the picture storage directory . The crude but effective alternative is to run : sudo df -sm /* find which is the biggest and repeat on that so on my greenpi ...
by JoeSoap
Fri Jan 06, 2017 7:57 pm
Forum: Troubleshooting
Topic: Raspberry PI 3 with OSMC slow internet connection?
Replies: 7
Views: 2160

Re: Raspberry PI 3 with OSMC slow internet connection?

The earlier posters and the responses clear up some possibilities. the sd card seem small esp with osmc on it (which implies to me recording tv and stuff like that ? ). just some thts for you - is there something else running taking cpu and or ram or io - is it swapping - is the io what you would ex...
by JoeSoap
Thu Jan 05, 2017 4:59 pm
Forum: Troubleshooting
Topic: ./wakeWordAgent -e sensory no such file or directory (same e
Replies: 2
Views: 1652

Re: ./wakeWordAgent -e sensory no such file or directory (sa

I know nothing about wakeword but the error is that wiringpi is not installed.

see

http://wiringpi.com/download-and-install/

JoeSoap
by JoeSoap
Wed Jan 04, 2017 12:12 pm
Forum: Troubleshooting
Topic: NFS permissions on ReadyNAS
Replies: 5
Views: 1376

Re: NFS permissions on ReadyNAS

clearly root_squash is not active for that situation. (fyi I have no idea what SR,CP or T are) Common practice is to never give root privileges to any program but to use a (new) group and make whoever runs the prog a member of that group , and for that group to be the one used when the directory is ...
by JoeSoap
Wed Jan 04, 2017 10:11 am
Forum: Troubleshooting
Topic: Can't connect to wifi with pi3 Model B
Replies: 10
Views: 2827

Re: Can't connect to wifi with pi3 Model B

wifi is not my strong point (nor are many other things :-) ) . thts on this ... - the fact that it worked for some time implies that your config is ok - then the fact that it has stopped working *with no change* to your config makes me think that you are suffering interference and that you should ch...
by JoeSoap
Wed Jan 04, 2017 8:01 am
Forum: Troubleshooting
Topic: NFS permissions on ReadyNAS
Replies: 5
Views: 1376

Re: NFS permissions on ReadyNAS

forgot the 'root_squash' ... by default root_squash is true which means if you access it as root then it will 'squash' you to user 'nobody' ie minimal access.

JoeSoap
by JoeSoap
Tue Jan 03, 2017 7:44 pm
Forum: Troubleshooting
Topic: NFS permissions on ReadyNAS
Replies: 5
Views: 1376

Re: NFS permissions on ReadyNAS

Just some thts on what I would look at :
- are the users and their ids (the number) the same on the client as on the server?
- is it mounted r/w AND exported r/w (bit fuzzy on this as mine just work)
- what perms are there on the underlying directory and the path

JoeSoap
by JoeSoap
Tue Jan 03, 2017 2:38 pm
Forum: Troubleshooting
Topic: DNS on wlan0
Replies: 2
Views: 2573

Re: DNS on wlan0

I dont use dhcp so no use on that aspect. however , iiuc , there should be only one route from A to B ie your pi to the router (which I assume is your internet connection) . So if you have those 2 routes , then I think you need to ifup one interface (eth0) and ifdown the other (wlan0) when using eth...
by JoeSoap
Sat Dec 31, 2016 2:44 pm
Forum: Troubleshooting
Topic: startx works only as root/sudo
Replies: 1
Views: 635

Re: startx works only as root/sudo

your pastebin files have been removed (it says). You could post directly the data or trim it a bit . may be worthwhile doing a 'type startx' to find where it is and then looking at the permissions on it . also 'id' to determine your groups . iirc I *cant* startx if root on my slackware box (not goin...
by JoeSoap
Thu Dec 29, 2016 2:43 pm
Forum: Troubleshooting
Topic: Unable to unzip file
Replies: 4
Views: 1685

Re: Unable to unzip file

oops , I meant
what error message do you get from sudo unzip doom1.wad.zip

Go to advanced search