Go to advanced search

by Wm.A.Weezl
Tue Mar 21, 2017 5:36 am
Forum: Networking and servers
Topic: Scanner server through usbip
Replies: 0
Views: 281

Scanner server through usbip

I stumbled across a way to make the Pi work as a scanner server. This worked with a Brother all-in-one device that does not have any drivers available for the Pi. It seems like it would work for any make and model of scanner that uses sane . It was much easier than setting up the Pi to serve an HP s...
by Wm.A.Weezl
Tue Jan 19, 2016 12:44 am
Forum: Troubleshooting
Topic: HP all-in-one scanner not working in Raspbian Jessie
Replies: 1
Views: 1142

HP all-in-one scanner not working in Raspbian Jessie

Sorry about this long narrative, but I’ve been trying everything I can think of or google to get my scanner going. An HP Deskjet-F4100 all-in-one is connected to my Pi Model B which runs Raspbian Jessie. Printing works fine, and scanning was working with Raspbian Wheezy, before I upgraded to Jessie....
by Wm.A.Weezl
Mon Jan 18, 2016 9:49 pm
Forum: Troubleshooting
Topic: HDD device name keeps changing
Replies: 7
Views: 1213

Solved: HDD device name keeps changing

Rotwang was right, it was the power supply. I changed from a 700-mA power supply to a 2000-mA supply and this problem went away.
by Wm.A.Weezl
Fri Dec 18, 2015 4:16 am
Forum: Troubleshooting
Topic: HDD device name keeps changing
Replies: 7
Views: 1213

Re: HDD device name keeps changing

Thanks, kiricks. It's a 3.5-inch drive. So it sounds like this drive might be placing a greater drain on the Pi's power supply than a 2.5-inch drive would. I'll check that voltage. It may be a few days before I can get to it. Can anyone describe what dmesg would show if a poor power supply were caus...
by Wm.A.Weezl
Thu Dec 17, 2015 4:33 am
Forum: Troubleshooting
Topic: HDD device name keeps changing
Replies: 7
Views: 1213

Re: HDD device name keeps changing

Thanks for the suggestions. I did try mounting the HDD by putting its UUID in fstab a while ago, but it didn't seem to change the behavior. According to my notes, fdisk -l continued to report either /dev/sda1 or /dev/sdb1 , alternately. (Does fdisk always report USB disks as /dev/sd xy, even if you ...
by Wm.A.Weezl
Wed Dec 16, 2015 3:44 am
Forum: Troubleshooting
Topic: HDD device name keeps changing
Replies: 7
Views: 1213

HDD device name keeps changing

I'm running Raspbian Wheezy on a headless Pi. An external hard disk drive with its own power supply is connected via USB. An entry in fstab mounts it to /media/WD-1TB/, like this: /dev/sda1 /media/WD-1TB ext4 defaults 0 2 The problem is, most of the time when I access the Pi through ssh, the HDD isn...
by Wm.A.Weezl
Sat Dec 13, 2014 2:12 am
Forum: Raspbian
Topic: Raspberry image scanning problem
Replies: 10
Views: 1352

Re: Raspberry image scanning problem

Re. Angelus88's comment on 2013-09-01: 08:32, it looks like micsko17's output is normal for HP all-in-one devices. I have a HP F4180, and the output from sane-find-scanner includes these 2 lines: found USB scanner (vendor=0x03f0 [HP], product=0x7e04 [Deskjet F4100 series]) at libusb:001:005 found US...
by Wm.A.Weezl
Sun Oct 20, 2013 1:19 pm
Forum: Raspbian
Topic: Pi drops ethernet connection
Replies: 27
Views: 14216

Re: Pi drops ethernet connection

In my case, the 2012-09-18 version of Raspbian continues to work well about 3 weeks after re-installing it. The Pi is always powered on and connected to ethernet. I did not experience deteriorating function with the newer versions of Raspbian - they failed to work from the very start.
by Wm.A.Weezl
Tue Oct 08, 2013 1:34 am
Forum: Raspbian
Topic: Pi drops ethernet connection
Replies: 27
Views: 14216

Re: Pi drops ethernet connection

Update 6 days later. The 2012-09-18 Raspbian is working like a sweet, sweet dream. Which leads me to wonder again, why has newer software been released that is so much worse than the old? Or does the new OS not work on my Pi because it's one of the earliest ones manufactured? Does the newer OS work ...
by Wm.A.Weezl
Thu Oct 03, 2013 2:22 am
Forum: Raspbian
Topic: Pi drops ethernet connection
Replies: 27
Views: 14216

Pi drops ethernet connection

I am running my Pi headless over ssh as a print- and file server. It was working pretty well with the 2012-09-18-wheezy-raspbian version, then in June I ran apt-get upgrade and ruined everything! After that, any operation that caused a lot of ethernet traffic caused the Pi to drop its network connec...
by Wm.A.Weezl
Tue Oct 23, 2012 1:26 am
Forum: Troubleshooting
Topic: USB redirector
Replies: 71
Views: 59483

Re: USB redirector

Hi. I am trying to get usbip working with the RasPi as server and a Debian Squeeze (one generation earlier than Wheezy) computer as client. I started out with a method found on Sourceforge[1], but that didn't work out. Then I found this page and used secretagent's method of July 12, but first instal...
by Wm.A.Weezl
Thu Oct 18, 2012 2:03 am
Forum: Beginners
Topic: How to set up the Raspberry Pi as an NFS server
Replies: 5
Views: 6664

Re: How to set up the Raspberry Pi as an NFS server

Thanks, it worked for me with Wheezy version of 2012-09-18. I can confirm that you can use the avahi name in place of the IP address when you mount the nfs share on the client. When setting up the server (the Pi) I did have to issue sudo service rpcbind start but I didn't need to do the modprobe step.

Go to advanced search