Go to advanced search

by Ark_42
Mon Jul 15, 2019 12:57 pm
Forum: Raspbian
Topic: Buster bug report thread
Replies: 163
Views: 15289

Pi zero brcmfmac problem

After nearly 24 hours running ok my zero W locked up. after reloading I find the following in /var/log/kern.log with cat kern.log | grep brcm Jul 15 07:52:29 raspberrypi kernel: [39735.259739] brcmfmac: brcmf_escan_timeout: timer expired Jul 15 11:09:54 raspberrypi kernel: [51579.996447] brcmfmac: b...
by Ark_42
Fri Mar 31, 2017 4:44 pm
Forum: Camera board
Topic: Zero w wifi stops with raspvid
Replies: 3
Views: 424

Re: Zero w wifi stops with raspvid

Should have said that they were in syslog
by Ark_42
Fri Mar 31, 2017 4:43 pm
Forum: Camera board
Topic: Zero w wifi stops with raspvid
Replies: 3
Views: 424

Re: Zero w wifi stops with raspvid

Nothing like that in dmesg, but lots of this ( every 5 mins whether doing this test or not ) .. Mar 31 13:43:51 raspberrypi wpa_supplicant[454]: wlan0: WPA: Group rekeying completed with 00:12:17:6b:31:f6 [GTK=TKIP] Mar 31 13:43:51 raspberrypi rsyslogd-2007: action 'action 17' suspended, next retry ...
by Ark_42
Fri Mar 31, 2017 12:56 pm
Forum: Camera board
Topic: Zero w wifi stops with raspvid
Replies: 3
Views: 424

Zero w wifi stops with raspvid

I have have a Zero w in one of the official cases. It works a treat and when I SSH to it I can run raspvid ( raspivid -t 0 -rot 90 ) displaying the image on an attached HDMI screen. However after about 5 minutes I can no longer access the zero w via ssh. Using a smaller picture size ( raspivid -t 0 ...
by Ark_42
Fri Feb 05, 2016 11:31 am
Forum: Official Foundation Display
Topic: Display with A+
Replies: 1
Views: 423

Re: Display with A+

Ok, I took one of my other projects apart and tried the A+ from it and the display worked ! Back to the original - no go, so I'm using the working one with the display and the non working one works perfectly in the project ( which doesn't use the DSI connector) , so there must be a fault on that A+ ...
by Ark_42
Thu Feb 04, 2016 12:22 pm
Forum: Official Foundation Display
Topic: Display with A+
Replies: 1
Views: 423

Display with A+

Hi, I just bought a new official touch screen and went through the recommended installation procedures. I'm using a Pi A+ and the latest Jessie Raspian ( updated ). Despite trying all the recommendations I could find on this forum and the web in general the screen remained blank. As a last resort I ...
by Ark_42
Wed Dec 31, 2014 12:21 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: I2C with Adafruit 128x32 I2C OLED
Replies: 30
Views: 16315

Re: I2C with Adafruit 128x32 I2C OLED

Hi,
I've just got this OLED and wondered if you connected to 3.3 volt or 5 volt for the power supply
Thanks
Ark_42
by Ark_42
Thu Feb 06, 2014 2:45 pm
Forum: Bare metal, Assembly language
Topic: Flash/SD card driver for RPi
Replies: 8
Views: 3359

Re: Flash/SD card driver for RPi

Thanks for that - I'm off to play now :D
by Ark_42
Wed Feb 05, 2014 12:28 pm
Forum: Bare metal, Assembly language
Topic: Flash/SD card driver for RPi
Replies: 8
Views: 3359

Re: Flash/SD card driver for RPi

I to am interested in this, DexOS could you post the defines that go with you code example please.
by Ark_42
Thu Sep 19, 2013 8:20 am
Forum: Bare metal, Assembly language
Topic: make for CSUD
Replies: 3
Views: 826

Re: make for CSUD

Thank you tufty, I hadn't spotted that typo.
All compiles a treat now
by Ark_42
Wed Sep 18, 2013 4:57 pm
Forum: Bare metal, Assembly language
Topic: make for CSUD
Replies: 3
Views: 826

make for CSUD

Hi all, I've just downloaded the code for CSUD from github and tried the make. ( I'm on Windows 7 and have used make to compile bare asm without problems ) It has failed instantly as below d:\Active data\Pi\csud\csud-master>make driver CONFIG=DEBUG TYPE=STANDALONE TARG ET=RPI GNU=arm-non-eabi- arm-n...
by Ark_42
Sat Jul 13, 2013 9:13 am
Forum: Bare metal, Assembly language
Topic: Set GPIO interupts in assembler
Replies: 7
Views: 2582

Re: Set GPIO interupts in assembler

I've just decided to ignore interrupt 51 ( and 52 ), I'm just using 49 for the GPEDS0 group and 50 for the GPEDS1 group - works for me.
by Ark_42
Fri Jul 12, 2013 9:17 am
Forum: Bare metal, Assembly language
Topic: Set GPIO interupts in assembler
Replies: 7
Views: 2582

Re: Set GPIO interupts in assembler

I think you misread my comment, there are 4 GPIO interrupt lines ( according to the BCM2835 ARM Peripherals manual interrupt chapter - 49,50,51,52 ) with 52 being the line shared between all, hence the question about interrupt 51. To actually get the interrupt you'll need to set the appropriate inte...
by Ark_42
Tue Jul 09, 2013 11:16 am
Forum: Bare metal, Assembly language
Topic: Set GPIO interupts in assembler
Replies: 7
Views: 2582

Re: Set GPIO interupts in assembler

Experimentation now shows that setting GPHEN0 bit 4 and GPEDS0 bit 4 ( I'm using pin 4 of the GPIO ) and then IRQ_ENABLE_2 to 0x00020000 ( for interrupt 49 ) will cause an interrupt when pin 4 going high. If interrupt 52 is enabled it also set when pin 4 goes high. The documentation says The GPIO pe...
by Ark_42
Sun Jul 07, 2013 6:25 pm
Forum: Bare metal, Assembly language
Topic: Set GPIO interupts in assembler
Replies: 7
Views: 2582

Set GPIO interupts in assembler

Hi, I've read and re-read the BCM2835 ARM Peripherals manual ( chapter 6 and 7) but whilst I can see how to decide what to detect ( going high/low etc ) for which GPIO pin ( e.g. pin 4 ) I can't see how to associate the event with one of the 4 GPIO interupts so that I can actually get an interrupt f...
by Ark_42
Wed Oct 17, 2012 4:52 pm
Forum: Bare metal, Assembly language
Topic: uart rx with interupts
Replies: 5
Views: 2318

Re: uart rx with interupts

That example had the answers - all now working.

The interupt number was wrong and one of the manual entries incorrect/incomplete.

Many thanks for the suggestion and to dwelsh67 for the code example

Richard
by Ark_42
Wed Oct 17, 2012 2:49 pm
Forum: Bare metal, Assembly language
Topic: uart rx with interupts
Replies: 5
Views: 2318

Re: uart rx with interupts

Thanks for that clue, I'll have a look at that

Richard
by Ark_42
Wed Oct 17, 2012 2:01 pm
Forum: Bare metal, Assembly language
Topic: uart rx with interupts
Replies: 5
Views: 2318

uart rx with interupts

I am doing this in assembler. I have sucessfully used the uart for recieving and transmitting without using interupts ( based on dwelsh67's bootloader5 converted to assembler ) and now want to process input using interupts rather than waiting for the input. I have sucessfully got the timer interupts...
by Ark_42
Mon Sep 10, 2012 11:39 am
Forum: Bare metal, Assembly language
Topic: Baking pi Input01
Replies: 11
Views: 2449

Re: Baking pi Input01

It's worth noting that the driver seems not to work with some keyboards.

My original one ( a TRUST one, which works with rasbian ) would only show the first character pressed - none if you pressed the shift , but on changing to a Dell keyboard it works a treat.
by Ark_42
Mon Sep 10, 2012 11:11 am
Forum: Bare metal, Assembly language
Topic: Baking pi Input01
Replies: 11
Views: 2449

Re: Baking pi Input01

Ah thanks, I was really having trouble try to work out why.
by Ark_42
Mon Sep 10, 2012 10:57 am
Forum: Bare metal, Assembly language
Topic: Baking pi Input01
Replies: 11
Views: 2449

Baking pi Input01

Hi,
I'm trying to understand lookup, and can't see why the tables are .align 3 when defined

Can someone please explain.

Thanks
by Ark_42
Fri Sep 07, 2012 12:02 pm
Forum: Bare metal, Assembly language
Topic: Baking Pi screen01
Replies: 49
Views: 10883

Re: Baking Pi screen01

I tried that, the shades image didn't appear for some time after the beep ( 4 or 5 seconds )

Ark_42
by Ark_42
Fri Sep 07, 2012 10:18 am
Forum: Bare metal, Assembly language
Topic: Baking Pi screen01
Replies: 49
Views: 10883

Re: Baking Pi screen01

I've been playing with this and discovered that if I have a 5 second delay before starting to get the framebuffer the shade pattern normally seen when loading a unix apears after about 3 of the 5 seconds. My program ( basically screen02 ) then works normally. Without the 5 second wait the first scre...
by Ark_42
Wed Sep 05, 2012 10:03 am
Forum: Bare metal, Assembly language
Topic: Baking Pi screen01
Replies: 49
Views: 10883

Re: Baking Pi screen01

Thanks for clarifing that.

Ark_42
by Ark_42
Wed Sep 05, 2012 9:30 am
Forum: Bare metal, Assembly language
Topic: Baking Pi screen01
Replies: 49
Views: 10883

Baking Pi screen01

Hi, In the 4th section of mailboxRead you have tst status,#0x40000000 .unreq status bne wait2$ with the comment This code checks that the top bit of the status field is 0, and loops back to 3. if it is not. surely one of these is wrong, should the code test 0x80000000 or are we suposed to test one b...

Go to advanced search