Go to advanced search

by sugatam
Thu May 29, 2014 3:59 am
Forum: Troubleshooting
Topic: Force HDMI mode stopped working
Replies: 21
Views: 4971

Re: Force HDMI mode stopped working

I have exactly the same problem. My setting of CEA mode 4 is being ignored on bootup, and mode 2 is being used instead. A tvservice -e "CEA 4 HDMI" fixes it, but it is annoying to have to explicitly run it after bootup.
by sugatam
Mon Mar 11, 2013 2:12 am
Forum: Media centres
Topic: Passthrough not working as unprivileged user
Replies: 0
Views: 502

Passthrough not working as unprivileged user

This is really bizzarre, so I hope some kind soul can point out what I'm doing wrong. I've had a setup with the pi directly connected to my hdmi tv, and I've been happily running omxplayer (with -o hdmi) from omxplayer-ui as user www-data. It took me a bit to ensure /dev/vchiq has the proper permiss...
by sugatam
Sat Feb 16, 2013 8:25 pm
Forum: Media centres
Topic: PlayOn and the RPi
Replies: 6
Views: 11544

Re: PlayOn and the RPi

I routinely watch Netflix on the pi via playon. I use xbmc on the pi, and its upnp support detects the playon server.
by sugatam
Mon Feb 11, 2013 4:15 am
Forum: Media centres
Topic: mpd and hdmi audio
Replies: 1
Views: 934

Re: mpd and hdmi audio

Anyone?
by sugatam
Sun Feb 03, 2013 3:51 pm
Forum: Media centres
Topic: mpd and hdmi audio
Replies: 1
Views: 934

mpd and hdmi audio

I apologize if this has been covered already, but my searches are turning up a ton of posts that talk about setting up a pi as an audio player using either the analog audio output or external usb DACs. How do I get mpd on the pi to just send the decoded PCM out over HDMI? I have a receiver capable o...
by sugatam
Fri Oct 19, 2012 12:28 am
Forum: Media centres
Topic: 1080i AVC (h264) Tv recordings no longer work - Black Screen
Replies: 46
Views: 13103

Re: 1080i AVC (h264) Tv recordings no longer work - Black Sc

Are these already properly handled in omxplayer?
by sugatam
Mon Oct 01, 2012 4:19 pm
Forum: Media centres
Topic: 1080i deinterlacing
Replies: 21
Views: 11166

Re: 1080i deinterlacing

Yes, I have tested 1080i deinterlacing with omxplayer and it works well
by sugatam
Fri Sep 28, 2012 12:14 pm
Forum: Media centres
Topic: mpeg2 clip doesn't play on omxplayer
Replies: 6
Views: 1874

Re: mpeg2 clip doesn't play on omxplayer

Thanks, will do.
by sugatam
Fri Sep 28, 2012 2:20 am
Forum: Media centres
Topic: mpeg2 clip doesn't play on omxplayer
Replies: 6
Views: 1874

Re: mpeg2 clip doesn't play on omxplayer

Here is the mediainfo: General ID : 0 (0x0) Complete name : /media/MAIN/1576_20120925204200.mpg Format : MPEG-TS File size : 120 MiB Duration : 1mn 4s Overall bit rate : 15.7 Mbps Video ID : 6271 (0x187F) Menu ID : 1 (0x1) Format : MPEG Video Format version : Version 2 Format profile : [email protected] For...
by sugatam
Thu Sep 27, 2012 11:33 pm
Forum: Media centres
Topic: mpeg2 clip doesn't play on omxplayer
Replies: 6
Views: 1874

Re: mpeg2 clip doesn't play on omxplayer

Anyone?
by sugatam
Wed Sep 26, 2012 12:22 pm
Forum: Media centres
Topic: 1080i deinterlacing
Replies: 21
Views: 11166

Re: 1080i deinterlacing

Makes sense. So the selective application of deinterlacing based on the source has to be done at the player level. Looking at the code, OMXPlayer doesn't do it currently. In reality, things are a bit more complicated - the source could be true progressive, it could have 3:2 pulldown, or true interla...
by sugatam
Wed Sep 26, 2012 1:05 am
Forum: Media centres
Topic: mpeg2 clip doesn't play on omxplayer
Replies: 6
Views: 1874

mpeg2 clip doesn't play on omxplayer

This one's a vanilla 1080i mpeg2/ac3 captured from one channel on my hdhomerun prime. Give omxplayer fits, the thing plays a couple of frames, freezes for a few seconds, then a couple more frames, and so on. All the while the audio is messed up. This is the only stream on my cable lineup to have thi...
by sugatam
Wed Sep 26, 2012 12:50 am
Forum: Media centres
Topic: 1080i deinterlacing
Replies: 21
Views: 11166

Re: 1080i deinterlacing

Just tested it - works great! Thanks a lot!! Hopefully one of days you'll have the time to code something a more sophisticated deinterlacing algorithm, but this is great in the meantime. BTW, is there any harm to calling omxplayer with -d even when the source is progressive? Hopefully the GPU does n...
by sugatam
Tue Sep 25, 2012 2:22 am
Forum: Media centres
Topic: 1080i deinterlacing
Replies: 21
Views: 11166

Re: 1080i deinterlacing

Wow, that was fast! Thanks dom!! I compile my own omxplayer, so I can remove the check easily enough myself. Do I need a new firmware?
by sugatam
Mon Sep 24, 2012 1:02 am
Forum: Media centres
Topic: 1080i deinterlacing
Replies: 21
Views: 11166

Re: 1080i deinterlacing

Here is a clip from NBC captured using my hdhomerun. It is 1080i mpeg2 with ac3 audio, and the pi plays it perfectly other than the jaggies.

https://docs.google.com/open?id=0B6kbH3 ... mZJRG8yMWc
by sugatam
Sat Sep 22, 2012 1:22 pm
Forum: Media centres
Topic: 1080i deinterlacing
Replies: 21
Views: 11166

1080i deinterlacing

Is there a possibility of adding this to the GPU? Doesn't have to be fancy, even bob would do.
by sugatam
Sat Sep 08, 2012 5:06 pm
Forum: Media centres
Topic: omxplayer strictly from SSH
Replies: 2
Views: 1755

Re: omxplayer strictly from SSH

I do this all the time. No special commands necessary. I use

omxplayer -o hdmi -p filename

but the switches are just for audio.
by sugatam
Sat Sep 01, 2012 7:58 pm
Forum: Raspbian
Topic: apt-get install problem
Replies: 2
Views: 546

Re: apt-get install problem

Thank you! That's what I was missing, all is well now.
by sugatam
Sat Sep 01, 2012 7:09 pm
Forum: Raspbian
Topic: apt-get install problem
Replies: 2
Views: 546

apt-get install problem

Looks like the package lists are out of date. My sources file is set to:

deb http://archive.raspbian.org/raspbian wheezy main contrib non-free

But when I try to install bzip2, it can't find it due to a release number diff. The repo has 1.0.6-4 while apt-cache has 1.0.6-3 from the package list.

Go to advanced search