Go to advanced search

by NKnuelle
Mon Apr 20, 2020 12:49 pm
Forum: Graphics, sound and multimedia
Topic: Problem using Gstreamer with v4l2 and v4l2h264enc
Replies: 6
Views: 359

Re: Problem using Gstreamer with v4l2 and v4l2h264enc

Thanks for your quick response. I will open up an issue. I am trying to encode 720p50 which should be no problem for the card and the Pi. Because of the issues I didn't try to encode higher resolutions. I already had issues using io-mode 4/5 using my camera which was filming a somehow static image (...
by NKnuelle
Mon Apr 20, 2020 12:07 pm
Forum: Graphics, sound and multimedia
Topic: Problem using Gstreamer with v4l2 and v4l2h264enc
Replies: 6
Views: 359

Re: Problem using Gstreamer with v4l2 and v4l2h264enc

I am still experiencing the buffer issues with io-modes 4/5. Is there any solution yet? Should I open up an issue on Github for the GStreamer Plugin or does it relate to the Raspberry Pi/Auvidea module only?
by NKnuelle
Fri Apr 17, 2020 9:57 am
Forum: Deutsch
Topic: Schalten eines 5V Relais-Boards mit GPIO und 10k Widerstand schädlich?
Replies: 6
Views: 352

Re: Schalten eines 5V Relais-Boards mit GPIO und 10k Widerstand schädlich?

Hey smartifahrer :) danke für deine Antwort. Das schaue ich mir mal an. Ja, das ist bestimmt ein Logik-Problem bei mir - ich komme da eher aus der binären Ecke, da gibt es so etwas (eigentlich) nicht :lol: GPIOs sind eben doch Elektronik, keine einfachen "Schalter". Daher bestimmt auch meine Verwirr...
by NKnuelle
Fri Apr 17, 2020 9:06 am
Forum: Deutsch
Topic: Schalten eines 5V Relais-Boards mit GPIO und 10k Widerstand schädlich?
Replies: 6
Views: 352

Re: Schalten eines 5V Relais-Boards mit GPIO und 10k Widerstand schädlich?

Moin, vielen Dank für deine ausführiche Antwort! Ich war bei dieser Schaltung generell etwas verwundert, warum denn überhaupt Strom ZUM GPIO fließen sollte. Es ist doch ein Ausgang, kein Eingang. Das heißt wenn überhaupt sollte Strom VOM GPIO zum Relais-Board fließen, nicht umgekehrt. Das lässt sich...
by NKnuelle
Thu Apr 16, 2020 3:34 pm
Forum: Deutsch
Topic: Schalten eines 5V Relais-Boards mit GPIO und 10k Widerstand schädlich?
Replies: 6
Views: 352

Re: Schalten eines 5V Relais-Boards mit GPIO und 10k Widerstand schädlich?

Hi mline, vielen Dank für deine Antwort. Mh. Seltsam. Elektrotechnisch bist du da sicherlich der Erfahrenere. Im Manual des Relais ist allerdings auch ein Beispiel, inklusive Coding für den Arduino inklusive Aufbauanleitung. Dort werden die PINs ganz klar als Outputs definiert. Nur dass die PINs des...
by NKnuelle
Thu Apr 16, 2020 1:04 pm
Forum: Deutsch
Topic: Schalten eines 5V Relais-Boards mit GPIO und 10k Widerstand schädlich?
Replies: 6
Views: 352

Schalten eines 5V Relais-Boards mit GPIO und 10k Widerstand schädlich?

Hallo zusammen, ich nutze dieses Relay-Board an einem Raspberry Pi 4: https://www.az-delivery.de/products/16-relais-modul?variant=18282757357664&gclid=CjwKCAjwhOD0BRAQEiwAK7JHmO1WMeTzd4zvu1vdoW-5yiIa5uPHg-DVp7oqgE48LsfcpEnhOfsFAxoCnpsQAvD_BwE Es ist ein 5V Relais-Board, dass bei LOW-Pegel schaltet. ...
by NKnuelle
Thu Apr 02, 2020 11:23 am
Forum: Graphics, sound and multimedia
Topic: B101 Auvidea record audio + video + stream
Replies: 19
Views: 712

Re: B101 Auvidea record audio + video + stream

I am streaming using the module via Gstreamer to my local Nginx Server with rtmp enabled via this pipeline: GST_DEBUG=2 gst-launch-1.0 flvmux streamable=true name=mux ! rtmpsink location="rtmp://localhost:1935/live/stream" v4l2src io-mode=4 ! "video/x-raw,framerate=50/1,format=UYVY" ! v4l2h264enc ou...
by NKnuelle
Thu Apr 02, 2020 10:24 am
Forum: Graphics, sound and multimedia
Topic: B101 Auvidea record audio + video + stream
Replies: 19
Views: 712

Re: B101 Auvidea record audio + video + stream

Please confirm that u followed all the steps mentioned by 6by9 in this thread (page 17): https://www.raspberrypi.org/forums/viewtopic.php?f=38&t=120702&start=400#p1339178 And please post the output of v4l2-ctl --log-status as well as your kernel and firmware: uname -a and vcgencmd version Thanks!
by NKnuelle
Thu Apr 02, 2020 8:24 am
Forum: Graphics, sound and multimedia
Topic: Problem using Gstreamer with v4l2 and v4l2h264enc
Replies: 6
Views: 359

Re: Problem using Gstreamer with v4l2 and v4l2h264enc

Hey 6by9! thank you for your response. The Kernel and Firmware versions are: [email protected]:~ $ uname -a Linux raspberrypi 4.19.97-v7l+ #1294 SMP Thu Jan 30 13:21:14 GMT 2020 armv7l GNU/Linux [email protected]:~ $ vcgencmd version Feb 12 2020 12:37:37 Copyright (c) 2012 Broadcom version c3c8dbdf147686f...
by NKnuelle
Wed Apr 01, 2020 1:19 pm
Forum: Graphics, sound and multimedia
Topic: Problem using Gstreamer with v4l2 and v4l2h264enc
Replies: 6
Views: 359

Re: Problem using Gstreamer with v4l2 and v4l2h264enc

Update: I recently tested the pipeline using io-modes 2 on Ouput AND v4l2src like this (something I missed experimenting before): GST_DEBUG=2 gst-launch-1.0 flvmux streamable=true name=mux ! rtmpsink location="rtmp://localhost:1935/live/stream live=1" v4l2src io-mode=2 ! "video/x-raw,framerate=50/1,...
by NKnuelle
Wed Apr 01, 2020 8:23 am
Forum: Graphics, sound and multimedia
Topic: Problem using Gstreamer with v4l2 and v4l2h264enc
Replies: 6
Views: 359

Problem using Gstreamer with v4l2 and v4l2h264enc

Hello everyone, I am streaming the HDMI input of my Raspberry Pi 4B (4GB) via B101 module (tc358743) with Gstreamer to my local Nginx RTMP Server using gst-launch-1.0 and this pipeline: GST_DEBUG=2 gst-launch-1.0 flvmux streamable=true name=mux ! rtmpsink location="rtmp://localhost:1935/live/stream ...
by NKnuelle
Tue Mar 31, 2020 12:52 pm
Forum: Graphics, sound and multimedia
Topic: yet another v4l2h264enc problem
Replies: 9
Views: 585

Re: yet another v4l2h264enc problem

Oh sorry,

for me this seemed to be a very similar problem.

I'm going to start a fresh new thread describing my problem over there.

Thank you
by NKnuelle
Mon Mar 30, 2020 4:54 pm
Forum: Graphics, sound and multimedia
Topic: yet another v4l2h264enc problem
Replies: 9
Views: 585

Re: yet another v4l2h264enc problem

Hi there, I found this thread and my problem seems to relate to this, too. My stream stops after some minutes and I can't get it working again without rebooting the Pi. I tried to change the values of io-modes. This didn't work, too. If I omit the io-values like this: GST_DEBUG=2 gst-launch-1.0 flvm...
by NKnuelle
Mon Mar 30, 2020 4:14 pm
Forum: Graphics, sound and multimedia
Topic: RTMP Stream using GStreamer and a B101
Replies: 7
Views: 1984

Re: RTMP Stream using GStreamer and a B101

Hi again, I have a big issue using GStreamer-1.0 with this command: The RTMP stream stops after some minutes (about 10 minutes, not always the same). I don't get any error messages using this comnmand: GST_DEBUG=2 gst-launch-1.0 flvmux streamable=true name=mux ! rtmpsink location="rtmp://0.0.0.0/liv...
by NKnuelle
Fri Mar 27, 2020 10:50 am
Forum: Graphics, sound and multimedia
Topic: HDMI to CSI-2 via TC358743 on kernel 4.1
Replies: 673
Views: 252136

Re: HDMI to CSI-2 via TC358743 on kernel 4.1

Hi all, I try to set the dv-timings via v4l2 --set-dv-timings to the detected input format. Is this possible without having to provide an EDID file? This is the output with v4l2-ctl --log-status : [ 7190.336255] unicam fe801000.csi: ================= START STATUS ================= [ 7190.337938] tc3...
by NKnuelle
Tue Mar 24, 2020 6:45 pm
Forum: Graphics, sound and multimedia
Topic: RTMP Stream using GStreamer and a B101
Replies: 7
Views: 1984

Re: RTMP Stream using GStreamer and a B101

Hey everyone, I am trying to figure out how to get audio working with RTMP, too. Currently I am using this pipeline which is very similar: gst-launch-1.0 flvmux streamable=true name=mux ! rtmpsink location="rtmp://0.0.0.0:1935/live" v4l2src io-mode=4 ! "video/x-raw,framerate=50/1,format=UYVY" ! v4l2...
by NKnuelle
Tue Mar 24, 2020 5:07 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Using Auvidea B101 Rev.4 for 1080p50 input via HDMI
Replies: 4
Views: 279

Re: Using Auvidea B101 Rev.4 for 1080p50 input via HDMI

For everyone searching for some solutions: For me I was able to stream with gstreamer in 720p/50 with a raspberry pi 4. I generate a RTMP stream with this: gst-launch-1.0 flvmux streamable=true name=mux ! rtmpsink location="rtmp://0.0.0.0:1935/live" v4l2src io-mode=4 ! "video/x-raw,framerate=50/1,fo...
by NKnuelle
Tue Mar 24, 2020 2:05 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Using Auvidea B101 Rev.4 for 1080p50 input via HDMI
Replies: 4
Views: 279

Re: Using Auvidea B101 Rev.4 for 1080p50 input via HDMI

Hi again, I managed to enable the driver, I set the EDID (1080P50EDID.txt) and checked the status: [email protected]:/usr/lib $ v4l2-ctl --log-status Status Log: [ 1680.454021] unicam fe801000.csi: ================= START STATUS ================= [ 1680.455712] tc358743 0-000f: -----Chip status----- [ ...
by NKnuelle
Tue Mar 24, 2020 11:41 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Using Auvidea B101 Rev.4 for 1080p50 input via HDMI
Replies: 4
Views: 279

Re: Using Auvidea B101 Rev.4 for 1080p50 input via HDMI

Thank you for your reply. I understand that it is getting boring to point users where they should look for. For me it was very difficult to find the right information for my project. I am able to setup my camera's output to the signal I need (720p/50p or 1080/50p) which should be possilbe to record/...
by NKnuelle
Tue Mar 24, 2020 9:53 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Using Auvidea B101 Rev.4 for 1080p50 input via HDMI
Replies: 4
Views: 279

Using Auvidea B101 Rev.4 for 1080p50 input via HDMI

Hello, I found some information regarding this topic but the information was mostly outdated, because the kernel now includes the driver for the Auvidea module. I am using Kernel 4.19 and an fresh installed Raspbian on a Raspberry Pi 4 Model B with 4 GB Ram: uname -r 4.19.97-v7l+ I am able to record...

Go to advanced search