Go to advanced search

by ubergeek72
Sun Mar 22, 2015 9:09 pm
Forum: Raspbian
Topic: Raspberry pi +: Don't mount lvm logical volumes at boot
Replies: 3
Views: 1318

Re: Raspberry pi +: Don't mount lvm logical volumes at boot

Apparently it's a bug in Debian. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=711147 . The workaround is to edit /etc/init.d/lvm2: do_start() { modprobe dm-mod 2>/dev/null || : /bin/sleep 5 2>/dev/null || : ### Add this line /sbin/vgscan --ignorelockingfailure >/dev/null || : /sbin/vgchange -al...
by ubergeek72
Fri Oct 31, 2014 3:04 am
Forum: Python
Topic: Don your testing hats, it's WiringPi2-Python
Replies: 54
Views: 17894

Re: Don your testing hats, it's WiringPi2-Python

To answer my own question, according to this, wiringpi2 can't do wiringpi2.wiringPiIsr interrupts. Drat.

Thanks. -JRS
by ubergeek72
Thu Oct 30, 2014 10:33 pm
Forum: Python
Topic: Don your testing hats, it's WiringPi2-Python
Replies: 54
Views: 17894

Re: Don your testing hats, it's WiringPi2-Python

Okay. I'm trying to figure out why wiringpi2.wiringPiISR doesn't work. To verify my hardware setup, I built isr.c with the following code, copied pretty much verbatim from the wiringpi website: #include <stdio.h> #include <string.h> #include <errno.h> #include <stdlib.h> #include <wiringPi.h> // Wha...
by ubergeek72
Sat May 11, 2013 7:39 pm
Forum: Troubleshooting
Topic: USB FIQ testing....
Replies: 181
Views: 75555

Re: USB FIQ testing....

my lsusb -v output under the 3.6 kernel: bNumEndpoints 1 bInterfaceClass 3 Human Interface Device bInterfaceSubClass 0 No Subclass bInterfaceProtocol 0 None iInterface 0 HID Device Descriptor: bLength 9 bDescriptorType 33 bcdHID 1.11 bCountryCode 0 Not supported bNumDescriptors 1 bDescriptorType 34 ...
by ubergeek72
Sat May 11, 2013 7:35 pm
Forum: Troubleshooting
Topic: USB FIQ testing....
Replies: 181
Views: 75555

Re: USB FIQ testing....

Pi on kernel 3.8.12+ #438 PREEMPT dated Wed. May 8 Keyboard in upper USB port Mouse in lower USB port. Pi powered by 12w Apple Ipad charger. Speed: 700mhz Environment: LXDE without lxpanel and with Cairo-Dock - typing in an xterm Results: keyboard hesitates, sticks. Same result for Keyboard in lower...
by ubergeek72
Sat May 11, 2013 6:29 pm
Forum: Troubleshooting
Topic: USB FIQ testing....
Replies: 181
Views: 75555

Re: USB FIQ testing....

That's interesting the FIQ shouldn't logically have any effect on networking performance since that's USB2... If you just have a keyboard plugged in do you get the same effect? What about a standard keyboard, have you got one of those handy to try? I don't have any non-apple keyboards to try. I'll ...
by ubergeek72
Sat May 11, 2013 6:16 pm
Forum: Troubleshooting
Topic: USB FIQ testing....
Replies: 181
Views: 75555

Re: USB FIQ testing....

More testing seems to be in order. While my pi was working fine with the current main kernel and USB system via a powered hub (which resolved the apple keyboard stuttering problems). Installing this update /caused/ my apple keyboard to begin stuttering, both with and without the hub. It also killed ...
by ubergeek72
Mon Nov 19, 2012 5:33 pm
Forum: Debian
Topic: Help test the next Debian image (wheezy)
Replies: 443
Views: 138782

Re: Help test the next Debian image (wheezy)

re:

Code: Select all

Openbox Message: Unable to find a valid menu file "/usr/share/lxde/openbox/menu.xml"
If you edit lxde-rc.xml, you'll find that this path to the menu.xml file is specified there. If you change it (as the comments suggest) to

Code: Select all

$HOME/.config/openbox/menu.xml
this error goes away.

-JRS
by ubergeek72
Wed Oct 10, 2012 5:33 am
Forum: Raspbian
Topic: boot messages question
Replies: 3
Views: 1219

Re: boot messages question

I'm also seeing this with 3.2.27+ #244 PREEMPT dated Sat. Oct 6, though without the DMA warnings.
by ubergeek72
Sun Oct 07, 2012 2:24 am
Forum: General discussion
Topic: Simon's accelerated X development thread
Replies: 405
Views: 141698

Re: Simon's accelerated X development thread

teh_orph wrote:With regards to my driver,
**snip**
If I get lucky with my final corruption bug I'll be sending said packagers some code this weekend!
EDIT: oh and it'll require a kernel module that I've written. Not sure how that bit's gonna work...
Awesome. Thanks for answering all my questions here. :)
by ubergeek72
Fri Oct 05, 2012 5:36 pm
Forum: General discussion
Topic: Simon's accelerated X development thread
Replies: 405
Views: 141698

Re: Simon's accelerated X development thread

I've been watching this thread with considerable interest, and from the sound of things, a great deal has gotten accomplished. Awesome work, folks. Not being an expert programmer myself, and being rather rusty at unix driver installation, I wonder if I could get a couple questions answered? 1. Is th...
by ubergeek72
Tue Aug 28, 2012 3:10 am
Forum: Troubleshooting
Topic: Raspberry Pi Won't Boot, Red Power Light Only
Replies: 197
Views: 434245

Re: Raspberry Pi Won't Boot, Red Power Light Only

I had this, with the very faint green LED being lit. Turned out I messed up when I wrote the disk image out to my sdcard. You have to talk directly to the raw device (which is in the directions, I just skimmed/ignored it). So if, as on my mac, you have /dev/disk3s1 where the sd card is, you have to ...

Go to advanced search