Go to advanced search

by bfg-e
Thu Apr 30, 2020 4:11 pm
Forum: Troubleshooting
Topic: St7735 showing gibberish
Replies: 6
Views: 285

Re: St7735 showing gibberish

hi , i got it to work , but only in 128x128 resolution. If i set 160x128 it make the image at a 45 degree angle (it just shows up the 128x128 picture and instead of breaking the line at the pixel 128 it continues up to 160)
by bfg-e
Thu Apr 30, 2020 7:24 am
Forum: Troubleshooting
Topic: St7735 showing gibberish
Replies: 6
Views: 285

Re: St7735 showing gibberish

[/quote] Please can you link to the product page of the ST7735S you purchased, there are hundreds for sale on AliExpress. [/quote] https://www.aliexpress.com/item/32906859151.html?spm=a2g0s.9042311.0.0.27424c4d3nTENH It worked well also with test codes from arduino library (using an arduino uno, if ...
by bfg-e
Thu Apr 30, 2020 6:37 am
Forum: Troubleshooting
Topic: St7735 showing gibberish
Replies: 6
Views: 285

Re: St7735 showing gibberish

What Raspberry? What OS? Where did you get the display? Does the manufacturer/vendor have some instructions for connecting it to a RPi? I use a raspberry pi zero(non w) Retropie I got it from aliexpress ,the display is an ST7735S . It worked well with python3(with aditional libraryes i maked it sho...
by bfg-e
Wed Apr 29, 2020 3:30 pm
Forum: Troubleshooting
Topic: St7735 showing gibberish
Replies: 6
Views: 285

St7735 showing gibberish

Image
Hi , today I wanted to add an st7735s display to my pi to can play games on retropie. I checked the wiring and it's good .
What should I check ? I tryed adjusting the resolution and rotation but it doesn't help
20200429_182832.jpg
20200429_182832.jpg (53.88 KiB) Viewed 285 times
by bfg-e
Wed Mar 18, 2020 10:05 am
Forum: Beginners
Topic: No hdmi output pi zero
Replies: 4
Views: 262

Re: No hdmi output pi zero

What model of HDMI-to-VGA adapter? Have you tried it with external power (some older devices need that)? Have you enabled SSH and thus be able to remotely login and run some tvservice commands? FWIW, I've used these three types with P0's: https://www.cpmspectrepi.uk/raspberry_pi/MoinMoinExport/HDMI...
by bfg-e
Wed Mar 11, 2020 1:16 pm
Forum: Beginners
Topic: No hdmi output pi zero
Replies: 4
Views: 262

Re: No hdmi output pi zero

Hi , i had a pi zero (non w) and today i wanted to hook it up to a vga monitor. I grabbed my hdmi to vga adapter (it had a sepparated usb for powering it) i puted the hdmi into minihdmi adapter and it on to pi. I had no hdmi output, so i tryed messing with the modes and stuff from the config.txt an...
by bfg-e
Wed Mar 11, 2020 12:32 pm
Forum: Beginners
Topic: No hdmi output pi zero
Replies: 4
Views: 262

No hdmi output pi zero

Hi , i had a pi zero (non w) and today i wanted to hook it up to a vga monitor. I grabbed my hdmi to vga adapter (it had a sepparated usb for powering it) i puted the hdmi into minihdmi adapter and it on to pi. I had no hdmi output, so i tryed messing with the modes and stuff from the config.txt and...
by bfg-e
Fri Feb 28, 2020 3:50 pm
Forum: Troubleshooting
Topic: Raspberry pi zero dont boot from sd card
Replies: 11
Views: 570

Re: Raspberry pi zero dont boot from sd card

I found the solution myself: adding start_x=1 on the top of config.txt file , now the pi boot just fine. Hmmm. Did you by any chance add a camera module between it working and not? i didnt added the camera on the rpi(even if that comand is to activate the camera).I was very surprised that it worked...
by bfg-e
Sun Feb 23, 2020 5:25 pm
Forum: General discussion
Topic: ST7735 not working on the pi zero
Replies: 0
Views: 93

ST7735 not working on the pi zero

Hi , i wanted to use a st7735 display for my pi to play retropie games, but after i followed this guide https://www.raspberrypi.org/forums/viewtopic.php?t=207627 i got only a white screen . All that i changed was moving dc and rst to 24 and 25 gpio(also on the software). I tryed this 2 times and it ...
by bfg-e
Sun Feb 23, 2020 3:56 pm
Forum: Troubleshooting
Topic: waveshare 1.44" tft lcd HAT (st7735s) (Solved)[obsolete]
Replies: 10
Views: 14777

Re: waveshare 1.44" tft lcd HAT (st7735s) (Solved)

I tryed this and i dont get any picture at all , i modifyed the dc and rst gpios to 24 and 25
by bfg-e
Fri Feb 21, 2020 6:20 pm
Forum: General discussion
Topic: thoughts about rpi 3a+
Replies: 17
Views: 790

Re: thoughts about rpi 3a+

Hi , i would like to buy a rpi 3a+(that all can i buy with my budget). It is good enough for a beginer like me ? And it is possibel to get wifi handshakes with it? I see two possibilities: One is that you used the computer of a friend, public library or community center to register for this forum a...
by bfg-e
Fri Feb 21, 2020 4:14 pm
Forum: General discussion
Topic: thoughts about rpi 3a+
Replies: 17
Views: 790

thoughts about rpi 3a+

Hi , i would like to buy a rpi 3a+(that all can i buy with my budget). It is good enough for a beginer like me ? And it is possibel to get wifi handshakes with it?
by bfg-e
Fri Feb 21, 2020 3:15 pm
Forum: Troubleshooting
Topic: Problems with raspberry pi zero
Replies: 17
Views: 721

Re: Problems with raspberry pi zero

I found the solution myself: adding start_x=1 on the top of config.txt file , now the pi boot just fine.
by bfg-e
Fri Feb 21, 2020 3:14 pm
Forum: Troubleshooting
Topic: Raspberry pi zero dont boot from sd card
Replies: 11
Views: 570

Re: Raspberry pi zero dont boot from sd card

I found the solution myself: adding start_x=1 on the top of config.txt file , now the pi boot just fine.
by bfg-e
Fri Feb 21, 2020 3:42 am
Forum: Troubleshooting
Topic: Raspberry pi zero dont boot from sd card
Replies: 11
Views: 570

Re: Raspberry pi zero dont boot from sd card

Is this the same RPiZero board that was extensively discussed in your thread earlier this week? https://www.raspberrypi.org/forums/viewtopic.php?p=1613622#p1613094 Yes, it is the same board, now i know the board work well(without the sd it shows as bcm2708 boot), if i remove the start file it start...
by bfg-e
Thu Feb 20, 2020 3:41 pm
Forum: Troubleshooting
Topic: Problems with raspberry pi zero
Replies: 17
Views: 721

Re: Problems with raspberry pi zero

I tryed all the thinks from boot problems sticky , i cleande the flux and triple-checked the solderings, and still had the same problem
by bfg-e
Thu Feb 20, 2020 3:05 pm
Forum: Troubleshooting
Topic: Raspberry pi zero dont boot from sd card
Replies: 11
Views: 570

Re: Raspberry pi zero dont boot from sd card

Hi , i had a raspberry pi zero and it wont boot from sd. I tryed changing the cable , usb from my pc , sd card , os for the raspberry, and the led did not blynk at all. The only think that i observe is if i remove from the boot partition the start.elf file , the led blinks 4 times , bu if i put bac...
by bfg-e
Thu Feb 20, 2020 2:35 pm
Forum: Troubleshooting
Topic: Raspberry pi zero dont boot from sd card
Replies: 11
Views: 570

Re: Raspberry pi zero dont boot from sd card

wally wrote:
Thu Feb 20, 2020 2:14 pm
Hi,
similar problems here, see
viewtopic.php?f=28&t=249108&p=1614846#p1614846

Do you get any error message ?
(I do not know the pi zero)
i dont had a display to find that out
by bfg-e
Thu Feb 20, 2020 2:08 pm
Forum: Troubleshooting
Topic: Raspberry pi zero dont boot from sd card
Replies: 11
Views: 570

Raspberry pi zero dont boot from sd card

Hi , i had a raspberry pi zero and it wont boot from sd. I tryed changing the cable , usb from my pc , sd card , os for the raspberry, and the led did not blynk at all. The only think that i observe is if i remove from the boot partition the start.elf file , the led blinks 4 times , bu if i put back...
by bfg-e
Tue Feb 18, 2020 12:08 pm
Forum: Troubleshooting
Topic: Problems with raspberry pi zero
Replies: 17
Views: 721

Re: Problems with raspberry pi zero

At this point all I can do is refer you once again to the boot problems sticky and suggest an internet search with emphasis on the four flashes of the green LED. but i got it only once. And another question , is there any combination of gpios , like on est modules to force booting from the sd? Mayb...
by bfg-e
Tue Feb 18, 2020 6:44 am
Forum: Troubleshooting
Topic: Problems with raspberry pi zero
Replies: 17
Views: 721

Re: Problems with raspberry pi zero

Zero, zeroW, or zeroWH? What changes did you make to config.txt? What changes did you make to cmdline.txt? What network connection does your zero(W(H)) have? Without one, enabling ssh won't do you any good. It'll be enabled but without a network it'll only work for local connections from the same P...
by bfg-e
Tue Feb 18, 2020 5:45 am
Forum: Troubleshooting
Topic: Problems with raspberry pi zero
Replies: 17
Views: 721

Re: Problems with raspberry pi zero

Zero, zeroW, or zeroWH? What changes did you make to config.txt? What changes did you make to cmdline.txt? What network connection does your zero(W(H)) have? Without one, enabling ssh won't do you any good. It'll be enabled but without a network it'll only work for local connections from the same P...
by bfg-e
Mon Feb 17, 2020 6:21 pm
Forum: Troubleshooting
Topic: Problems with raspberry pi zero
Replies: 17
Views: 721

Re: Problems with raspberry pi zero

i reflashed the card with a fresh version of raspbian(i modifyed the config cmdline and added the ssh file to can acces it from ssh), but it dont show on. Zero, zeroW, or zeroWH? What changes did you make to config.txt? What changes did you make to cmdline.txt? What network connection does your zer...
by bfg-e
Mon Feb 17, 2020 5:37 pm
Forum: Troubleshooting
Topic: Problems with raspberry pi zero
Replies: 17
Views: 721

Re: Problems with raspberry pi zero

drgeoff wrote:
Mon Feb 17, 2020 5:19 pm
Maybe your soldering is not as good as you think. :(
I am prety good at soldering(i can even solder 0201 resistor/capacitors) , electronics deisigning , pcb deisigning , schematic drawing and soo on. This is not the point . Probably i am missing something important and thats why i asked here
by bfg-e
Mon Feb 17, 2020 5:06 pm
Forum: Troubleshooting
Topic: Problems with raspberry pi zero
Replies: 17
Views: 721

Re: Problems with raspberry pi zero

drgeoff wrote:
Mon Feb 17, 2020 4:32 pm
Did you have it working at any time before you soldered to it?
Yea i worked with it for around 10-12 hours

Go to advanced search