Go to advanced search

by Vanfanel
Thu Apr 29, 2021 10:34 am
Forum: Advanced users
Topic: Strange message about deprecated instructions in ARMV8-a
Replies: 7
Views: 301

Re: Strange message about deprecated instructions in ARMV8-a

@jahboater: No, I am using latest version: The latest GCC version is 11.1 :) Try adding: -mrestrict-it it removes the messages on my Pi. I meant latest version available on stable Debian 10 (Raspberry Pi OS) :D Did you install 11.1 on Raspberry Pi OS manually? Also... would -mrestrict-it have any i...
by Vanfanel
Thu Apr 29, 2021 10:04 am
Forum: Advanced users
Topic: Strange message about deprecated instructions in ARMV8-a
Replies: 7
Views: 301

Re: Strange message about deprecated instructions in ARMV8-a

@jahboater: No, I am using latest version: pi@raspberrypi:~/src/SDL/test $ gcc -v Using built-in specs. COLLECT_GCC=gcc COLLECT_LTO_WRAPPER=/usr/lib/gcc/arm-linux-gnueabihf/8/lto-wrapper Target: arm-linux-gnueabihf Configured with: ../src/configure -v --with-pkgversion='Raspbian 8.3.0-6+rpi1' --with...
by Vanfanel
Thu Apr 29, 2021 9:21 am
Forum: Advanced users
Topic: Strange message about deprecated instructions in ARMV8-a
Replies: 7
Views: 301

Strange message about deprecated instructions in ARMV8-a

Hi there, I am building an small 32bit system (armhf) for Pi4. It's all going fine, but when building libGLVND, I see this strange message repeating a lot during the building: {standard input}:290682: IT blocks containing 16-bit Thumb instructions of the following class are performance deprecated in...
by Vanfanel
Sat Mar 13, 2021 3:45 pm
Forum: General discussion
Topic: Microsoft GPG key suggestion
Replies: 477
Views: 36084

Re: Microsoft GPG key suggestion

Thanks to those who explained me what has happened. Well, I am not using the compromised Raspberry Pi OS anymore, aarch64 Debian it will be from now on (and I really hope we start getting other competing SBCs soon, I don't feel like I can trust the Raspberry Pi foundation anymore, being sponsored by...
by Vanfanel
Sat Mar 13, 2021 11:27 am
Forum: General discussion
Topic: Microsoft GPG key suggestion
Replies: 477
Views: 36084

Re: Microsoft GPG key suggestion

LTolledo wrote:
Wed Mar 10, 2021 9:37 pm
seem a solution has been rolled out...

this topic has now become irrelevant?
Out of curiosity, what was the solution and when was it rolled out? I can't find anything about it.
by Vanfanel
Fri Feb 19, 2021 11:36 pm
Forum: General discussion
Topic: Microsoft GPG key suggestion
Replies: 477
Views: 36084

Re: Microsoft GPG key suggestion

Doing it the way they did it was clearly wrong. But, they really don't care. They are an empire now. (Further explanation of what I mean by that phrase available upon request). I am interested on reading what you mean. Certainly the foundation has grown into a major electronics manufacturer that's ...
by Vanfanel
Fri Feb 19, 2021 9:28 pm
Forum: General discussion
Topic: Microsoft GPG key suggestion
Replies: 477
Views: 36084

Re: Microsoft GPG key suggestion

So, from what I can see, the repository and Microsoft's GPG key will be removed from the LITE version at least? Are there any news on this? To be honest, I don't feel very confident about Raspberry Pi OS anymore, or the Raspberry Pi "project" itself anymore. Making us swallow this M$ stuff...
by Vanfanel
Fri Feb 19, 2021 4:39 pm
Forum: General discussion
Topic: Why is there a Microsoft repository on my sources list?
Replies: 3
Views: 285

Why is there a Microsoft repository on my sources list?

Hi, I have done an update and found out that a Microsoft repository has been added to my sources list. Can you please stop doing that? It's on /etc/apt/sources.list.d/vscode.list This is not a Microsoft platform and VSCodium is not open source either. It deviates a lot from the initial goals of the ...
by Vanfanel
Sat Feb 06, 2021 7:05 pm
Forum: Advanced users
Topic: Moving Linux Kernel to 5.10
Replies: 604
Views: 87430

Re: Moving Linux Kernel to 5.10

Hi there! I am on kernel 5.10.7-v8+, and I use the vc4-hdmi audio device ONLY. Of course I have this overlay in config.txt: dtoverlay=vc4-kms-v3d The problem I am seeing is that alsactl fails for both store and restore values: For STORE: pi@raspberrypi:~ $ sudo alsactl store alsactl: get_control:256...
by Vanfanel
Fri Jan 29, 2021 11:22 am
Forum: Advanced users
Topic: Different boot entries in bootloader, with different cmdline.txt files. Possible?
Replies: 0
Views: 103

Different boot entries in bootloader, with different cmdline.txt files. Possible?

Hi there, For creating new boot entries in the NOOBS boot menu, what I currently do is: -Create a new "boot" partition for the new entry -Create a custom cmdline.txt on that partition. That cmdline.txt specifies a custom init process. -Add a new entry in SETTINGS/installed_os.json The prob...
by Vanfanel
Sun Nov 15, 2020 2:09 am
Forum: Gaming
Topic: Revenge of the Titans on Raspberry Pi 4
Replies: 7
Views: 676

Re: Revenge of the Titans on Raspberry Pi 4

@rsbrowndog Since this uses lwjgl, shouldn't this game also run outside X11?
I mean, does lwjgl have GLES on KMSDRM support? Or SDL2 support?
by Vanfanel
Wed Nov 11, 2020 2:03 pm
Forum: Graphics programming
Topic: Simple 2D graphics on RPi4 - oenvg replacement on Pi4?
Replies: 2
Views: 681

Re: Simple 2D graphics on RPi4 - oenvg replacement on Pi4?

What about SDL2? You can easily build a minimal SDL2 with KMS/DRM support by doing: Get latest SDL2 sources from it's HG repo: hg clone --depth 1 http://hg.libsdl.org/SDL Install deps: sudo apt-get install libudev-dev libasound2-dev libvorbis-dev libflac-dev libmodplug-dev libpng-dev libjpeg-dev lib...
by Vanfanel
Wed Nov 11, 2020 1:54 pm
Forum: Graphics programming
Topic: [SOLVED] VULKAN outside X on the Raspberry Pi 4
Replies: 9
Views: 1774

Re: VULKAN outside X on the Raspberry Pi 4

This is now possible because the VK_KHR_Display extension is available. Instructions on the first post.
by Vanfanel
Wed Nov 11, 2020 1:53 pm
Forum: Graphics programming
Topic: Comnpile Mesa for 64bit raspberry pi OS
Replies: 2
Views: 736

Re: Comnpile Mesa for 64bit raspberry pi OS

Yep, working here on OS 64bit. First, install those deps: sudo apt-get install libvulkan-dev libvulkan1 vulkan-tools --no-install-recommends Now, configure MESA like this: CFLAGS="-O2 -march=armv8-a+crc+simd -mtune=cortex-a72" CXXFLAGS="-O2 -march=armv8-a+crc+simd -mtune=cortex-a72&qu...
by Vanfanel
Fri Nov 06, 2020 6:32 pm
Forum: Advanced users
Topic: [SOLVED] How to install armhf libc on 64bit Raspberry Pi OS?
Replies: 0
Views: 449

[SOLVED] How to install armhf libc on 64bit Raspberry Pi OS?

SOLUTION: sudo apt-get install libstdc++6:armhf Hi, I have some programs built for 32bir armhf, with no sources to rebuild. So I am in a quest to get them running on my light 64bit Raspberry Pi OS (Debian). What exactly are the packages I have to install via APT to get armhf elf executables running...
by Vanfanel
Wed Nov 04, 2020 2:36 pm
Forum: Other
Topic: [SOLVED] Current NOOBS LITE fails to boot installed OSes
Replies: 9
Views: 585

Re: Current NOOBS LITE fails to boot installed OSes

It seems to be working again with current versions of the OSes involved: installing them from NOOBS LITE works again. Closing this.
by Vanfanel
Mon Nov 02, 2020 7:52 pm
Forum: Other
Topic: [SOLVED] Current NOOBS LITE fails to boot installed OSes
Replies: 9
Views: 585

Re: Current NOOBS LITE fails to boot installed OSes

Just to be clear - is it NOOBS-lite that is failing to load, staying on the rainbow screen? Or have you managed to use NOOBS to install Risc but booting into Risc is sticking on the rainbow screen? NOOBS Lite loads fine. Installng any OSES works fine. BUT booting again into NOOBS menu and booting a...
by Vanfanel
Mon Nov 02, 2020 3:47 pm
Forum: Other
Topic: [SOLVED] Current NOOBS LITE fails to boot installed OSes
Replies: 9
Views: 585

Re: Current NOOBS LITE fails to boot installed OSes

Which model of Pi? What size SD card? What do the red and green LEDs do whilst the rainbow screen is showing? What colour is the top left hand colour of your rainbow screen - red or magenta ? If you have a Pi4 and it is magenta, try plugging your HDMI lead into the other socket. The top left hand c...
by Vanfanel
Mon Nov 02, 2020 3:05 pm
Forum: Other
Topic: [SOLVED] Current NOOBS LITE fails to boot installed OSes
Replies: 9
Views: 585

Re: Current NOOBS LITE fails to boot installed OSes

thatchunkylad198966 wrote:
Mon Nov 02, 2020 2:17 pm
Do you have another sdcard you can try?
Yes, I have tried many. It's not the SD card.
by Vanfanel
Mon Nov 02, 2020 1:41 pm
Forum: Other
Topic: [SOLVED] Current NOOBS LITE fails to boot installed OSes
Replies: 9
Views: 585

[SOLVED] Current NOOBS LITE fails to boot installed OSes

Hi there,

I just setup a NOOBs LITE SD today, downloading the latest version as of nov/02/2020.
It has always worked for me (FAT32 partition, decompress NOOBS LITE, boot, install: so simple).

It stays on the rainbow screen.
Is NOOBS broken as of today?
by Vanfanel
Sun Oct 18, 2020 10:16 pm
Forum: RISCOS
Topic: FORCING an incompatible system to install from NOOBS
Replies: 4
Views: 1162

Re: FORCING an incompatible system to install from NOOBS

just use rpi-imager & grab the image for risc. you'll get a better install. select use custom, then the image. That's not a solution for me: I CAN install Risc OS manually via dd-ing the .img, but NOOBS gives me a multiboot menu. Installing from rpi-imager only allows me to install and boot one...
by Vanfanel
Sun Oct 18, 2020 9:45 pm
Forum: RISCOS
Topic: FORCING an incompatible system to install from NOOBS
Replies: 4
Views: 1162

FORCING an incompatible system to install from NOOBS

Hi there, Since Risc OS DOES work fine on the Pi4 but is NOT available to install on NOOBS if a Pi4 is detected, is it possible to force it's installation even if it does not appear as installable on the NOOBS first boot menu? In SETTINGS/installed_os.json, I can see how systems are marked to be com...
by Vanfanel
Sun Oct 18, 2020 2:28 pm
Forum: Advanced users
Topic: Moving Linux Kernel to 5.10
Replies: 604
Views: 87430

Re: Moving Linux Kernel to 5.9

@6by9: Thanks, I won't ask in both places again. Really sorry.
I have closed the github issue since it should in raspberrypi/kernel and not in raspberrypi/software anyway.
by Vanfanel
Sun Oct 18, 2020 2:06 pm
Forum: Advanced users
Topic: Moving Linux Kernel to 5.10
Replies: 604
Views: 87430

Re: Moving Linux Kernel to 5.9

Running latest NEXT branch kernel here: I am using the vc4-hdmi audio device, so I have commented dtparam=audio=on in config.txt, and I am using the modified vc4-hdmi.conf with the contents described here: https://www.raspberrypi.org/forums/viewtopic.php?f=29&t=269769&p=1636828#p1636828 So, ...
by Vanfanel
Sun Oct 18, 2020 10:22 am
Forum: Graphics programming
Topic: [SOLVED] GLES2 programs segfault on vc4-kms-v3d on Pi4
Replies: 13
Views: 1620

Re: [SOLVED] GLES2 programs segfault on vc4-kms-v3d on Pi4

@Vanfanel Glad you got it sorted out. My RPiOS installs have always been with the default user pi. The RPi4 Vulkan driver currently does not work in DRM. According to Iago Toral that will be added at a later time. The only way the RPi4 Vulkan driver works is through X11. I hope they make VULKAN wor...

Go to advanced search