Go to advanced search

by iandk
Thu Mar 04, 2021 11:05 pm
Forum: General discussion
Topic: Pi NAS long term experiences?
Replies: 3
Views: 178

Pi NAS long term experiences?

Hey there, I‘m currently using a Synology DS220+ as my primary NAS. But I‘m thinking about selling the Synology and using one of my Pi 4‘s as a NAS with one or two HDDs attached. I‘d either go with JBOD or something like Snapraid. Does anyone have long term experiences with using a Pi (4) as a NAS? ...
by iandk
Tue Mar 02, 2021 12:53 pm
Forum: General discussion
Topic: USB power supply to power 4x Pi 4B cluster
Replies: 19
Views: 8346

Re: USB power supply to power 4x Pi 4B cluster

I'm using this one:

https://www.amazon.de/gp/product/B01JFO ... UTF8&psc=1


Works like a charm so far
by iandk
Mon Mar 01, 2021 3:45 pm
Forum: Advanced users
Topic: Samba speed halved
Replies: 2
Views: 159

Re: Samba speed halved

Maybe you have the same problem?

https://github.com/raspberrypi/linux/issues/4133
by iandk
Wed Feb 24, 2021 11:33 pm
Forum: Beginners
Topic: Slow smb transfer speeds
Replies: 10
Views: 293

Re: Slow smb transfer speeds

XFS gives the best performance with samba.

However there is currently some sort of bug in the newest kernel which reduces the performance
https://github.com/raspberrypi/linux/issues/4133
by iandk
Wed Feb 10, 2021 7:03 pm
Forum: Advanced users
Topic: Moving Linux Kernel to 5.10
Replies: 549
Views: 60007

Re: Moving Linux Kernel to 5.10

I just tested it again. Flashed the newest Raspberry Pi OS 32bit version (still running the old 5.4.83-v7l+ Kernel ), configured a basic samba share and ran a few tests with around 10-20GB of data. No issues at all, the transfer speed was at 110MB/s all the time. After that I updated to the kernel v...
by iandk
Wed Feb 10, 2021 6:36 pm
Forum: Advanced users
Topic: Moving Linux Kernel to 5.10
Replies: 549
Views: 60007

Re: Moving Linux Kernel to 5.10

Same issue in my case, RPi2. Updated four days ago, the Samba transfer speed dropped to an unacceptable level. And I got some failures when booting my RPi and USB disks are connected, blk_update_request I/O error, dev_sda . But the drives are fine, I've double checked them, and after the revert to ...
by iandk
Wed Feb 10, 2021 11:54 am
Forum: Advanced users
Topic: Moving Linux Kernel to 5.10
Replies: 549
Views: 60007

Re: Moving Linux Kernel to 5.10

If you have GitHub, would you mind commenting, that you are experiencing the same issue? I don't think metoo posts to the already opened issue will help the developers diagnose this any faster. That was not my intention. But this kind of issues often seem to be related to a specific configuration. ...
by iandk
Tue Feb 09, 2021 9:23 pm
Forum: Advanced users
Topic: Moving Linux Kernel to 5.10
Replies: 549
Views: 60007

Re: Moving Linux Kernel to 5.10



I‘ve been using a Pi 4 as a NAS for quite some time now and it‘s been running great. 
 But there was quite a read/write performance regression with some recent update. 

 I guess it‘s related to the Kernel upgrade. 
I tested this by installing an older version of the 64Bit Raspberry Pi OS which i...
by iandk
Mon Feb 08, 2021 2:03 pm
Forum: General discussion
Topic: STICKY: Raspberry Pi OS (64 bit) beta test version feedback
Replies: 680
Views: 147886

Re: STICKY: Raspberry Pi OS (64 bit) beta test version feedback

Thank you, I'll create an issue.

I'm sure it's related to one of the recent updates, not sure if it's kernel related or maybe some other firmware.
by iandk
Mon Feb 08, 2021 1:10 pm
Forum: General discussion
Topic: STICKY: Raspberry Pi OS (64 bit) beta test version feedback
Replies: 680
Views: 147886

Re: STICKY: Raspberry Pi OS (64 bit) beta test version feedback

Network performance issues I noticed a read/write performance regression with some recent update I guess it‘s related to the Kernel upgrade. 
I tested this by installing an older version of the 64Bit Raspberry Pi OS which is still running 5.4.51-v8+. 

 With this kernel version there were no issues...
by iandk
Mon Feb 08, 2021 11:06 am
Forum: General discussion
Topic: Pi 4 NAS performance issues
Replies: 7
Views: 366

Re: Pi 4 NAS performance issues

So I did a bit more testing, it definitely seems to be related to the newer kernel. When using the older 64bit image with the old kernel version 5.4.51-v8+ I don’t have any issues with the network transfer speed. But when using the latest 32bit version or upgrade the 64bit version to the latest kern...
by iandk
Sun Feb 07, 2021 10:32 pm
Forum: Advanced users
Topic: Moving Linux Kernel to 5.10
Replies: 549
Views: 60007

Re: Moving Linux Kernel to 5.10



I‘ve been using a Pi 4 as a NAS for quite some time now and it‘s been running great. 
 But there was quite a read/write performance regression with some recent update. 

 I guess it‘s related to the Kernel upgrade. 
I tested this by installing an older version of the 64Bit Raspberry Pi OS which is...
by iandk
Sun Feb 07, 2021 12:05 pm
Forum: General discussion
Topic: STICKY: Raspberry Pi OS (64 bit) beta test version feedback
Replies: 680
Views: 147886

Re: STICKY: Raspberry Pi OS (64 bit) beta test version feedback

Feedback on the slow speed of sftp of Raspberry Pi 4B Raspberry Pi 4B 4G version 1.2 OS: Raspberr Pi OS 64Bit The speed is very slow when sftp transfers files. The CPU usage of sshd reaches 100%. If I use FTP, the speed can read the peek speed of gigabit network card. May I know how to make sftp sp...
by iandk
Sun Feb 07, 2021 12:03 pm
Forum: General discussion
Topic: Pi 4 NAS performance issues
Replies: 7
Views: 366

Re: Pi 4 NAS performance issues

There was a recent bump from the 5.4 to the 5.10 kernel, which you would have picked up in the last few days if you keep your system up to date. That might have affected your speeds. Oh, that might be the issue... I just installed the 64bit Raspberry Pi OS Beta and installed only SAMBA and didn't u...
by iandk
Sun Feb 07, 2021 11:48 am
Forum: Beginners
Topic: 8gb Pi4 or 4gb for a Personal NAS?
Replies: 4
Views: 306

Re: 8gb Pi4 or 4gb for a Personal NAS?

A basic NAS doesn't need much RAM, 2GB should be enough.

I wouldn't recommend using WIFI however, it's quite unstable and you're sharing the bandwidth with all the other devices connected.
by iandk
Sun Feb 07, 2021 11:29 am
Forum: General discussion
Topic: Pi 4 NAS performance issues
Replies: 7
Views: 366

Re: Pi 4 NAS performance issues

I just gave EXT4 a try, pretty much the same issue.

I have no idea why it was working all the time and suddenly there's such a performance regression.


I'm quite sure there must have been some other changes in a recent update.

Do you know anything about that? @jamesh @gsh
by iandk
Sun Feb 07, 2021 12:09 am
Forum: General discussion
Topic: STICKY: Raspberry Pi OS (64 bit) beta test version feedback
Replies: 680
Views: 147886

Re: STICKY: Raspberry Pi OS (64 bit) beta test version feedback

I know it’s ready once it’s ready, but is there some sort of ETA? Like this summer/ winter?
by iandk
Sat Feb 06, 2021 11:12 pm
Forum: General discussion
Topic: Pi 4 NAS performance issues
Replies: 7
Views: 366

Re: Pi 4 NAS performance issues

Thank you for the hint, iirc I couldn’t find anything XFS in the syslog, but I‘ll keep an eye on it.
Do you know which log XFS uses? Or maybe have some tips for debugging?


I might give EXT4 a try tomorrow, but it seemed like XFS was faster
by iandk
Sat Feb 06, 2021 10:04 pm
Forum: General discussion
Topic: Pi 4 NAS performance issues
Replies: 7
Views: 366

Pi 4 NAS performance issues

Hey there! So I've been using a Pi 4 2GB as a small NAS with Samba for a few months now. It has been running quite well so far, but for a few days, the read/write performance is much lower than before. I was able to write with a constant 112MB/s and read with 100-110MB/s. But somehow it's now sittin...
by iandk
Sat Jan 30, 2021 2:24 pm
Forum: Beginners
Topic: Any Twin Power Supply Recommendations?
Replies: 6
Views: 218

Re: Any Twin Power Supply Recommendations?

Is there a better way to power several Pi 4's at once?
by iandk
Mon Jan 25, 2021 3:26 am
Forum: Beginners
Topic: Pi 4 and external USB drive
Replies: 5
Views: 272

Re: Pi 4 and external USB drive

Depends on what kind of drive you‘re using.

A 3,5“ HDD has it‘s own power supply, therefore that’s not an issue.
2,5“ SSDs work just fine and 2,5“ HDDs are likely to work as well.
by iandk
Wed Jan 06, 2021 9:26 pm
Forum: General discussion
Topic: First boot script/ cloud-init integration
Replies: 1
Views: 73

First boot script/ cloud-init integration

Hi,

I'd love to see support for some sort of first boot script or a cloud-init integration.
That would allow one to place a script into the /boot partition to e.g. set the hostname/IP, install packages, set SSH key ....


Any input on this?
Thanks!
by iandk
Wed Jan 06, 2021 7:18 pm
Forum: Troubleshooting
Topic: SMB Share not using full gigabit
Replies: 17
Views: 576

Re: SMB Share not using full gigabit

Oh sorry, missed that.

I'd still give XFS a try
by iandk
Wed Jan 06, 2021 7:09 pm
Forum: Troubleshooting
Topic: SMB Share not using full gigabit
Replies: 17
Views: 576

Re: SMB Share not using full gigabit

What kind of HDD have you attached?
Make sure its not a SMR drive.

Also try using XFS instead of EXT4 as the filesystem for the drive.
I'm able to write with a constant 112MB/s to my Pi4 with a MX500
by iandk
Fri Dec 11, 2020 7:52 pm
Forum: Troubleshooting
Topic: Network -> SSD performance issues
Replies: 2
Views: 175

Re: Network -> SSD performance issues

I'll give it a try without overclock later.
I already tried 3 different clients, two Macs and one windows workstation.

Go to advanced search