Go to advanced search

by johnnywho
Sun Mar 29, 2020 1:32 pm
Forum: Troubleshooting
Topic: [Solved] Raspberry Pi 4 Ethernet Problem
Replies: 20
Views: 14209

Re: Raspberry Pi 4 Ethernet Problem

Good news, one of the recent software updates apparently fixed the problem. I kept using my raspberry pi 3b+ having rpi 4 back in the box waiting for a router upgrade. I tried to swap the sd card from time to time and check if something has changed, especially after the rpi-eeprom upgrades. This tim...
by johnnywho
Wed Aug 28, 2019 9:14 pm
Forum: Troubleshooting
Topic: Raspberry Pi 4 Ethernet Port Issue
Replies: 8
Views: 2748

Re: Raspberry Pi 4 Ethernet Port Issue

I'm also facing issues on my Raspberry Pi 4B when plugged over gigabit to a EPC3940 Modem/Router. It does connect, but it's basically unusable. Unfortunately, I haven't found any solutions yet (https://www.raspberrypi.org/forums/viewtopic.php?t=249112) I really wonder how many switches don't work wi...
by johnnywho
Fri Aug 23, 2019 2:22 pm
Forum: Troubleshooting
Topic: [Solved] Raspberry Pi 4 Ethernet Problem
Replies: 20
Views: 14209

Re: Raspberry Pi 4 Ethernet Problem

The problem turned out to be compatibility issue between rpi4 and my ISP branded Cisco router. I connected my rpi4 to another network with a gigabit switch and immediately noticed an improvement during connecting and typing commands over ssh. No ping packet losses and decent internet speeds when usi...
by johnnywho
Sat Aug 17, 2019 7:20 pm
Forum: Troubleshooting
Topic: [Solved] Raspberry Pi 4 Ethernet Problem
Replies: 20
Views: 14209

Re: Raspberry Pi 4 Ethernet Problem

You were right, it loses packets when pinging the router. [email protected]:~ $ ping 192.168.0.1 -c 8 PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data. 64 bytes from 192.168.0.1: icmp_seq=1 ttl=64 time=1.27 ms 64 bytes from 192.168.0.1: icmp_seq=6 ttl=64 time=1.42 ms 64 bytes from 192.168.0.1: icmp_...
by johnnywho
Sat Aug 17, 2019 6:12 pm
Forum: Troubleshooting
Topic: [Solved] Raspberry Pi 4 Ethernet Problem
Replies: 20
Views: 14209

Re: Raspberry Pi 4 Ethernet Problem

It's a rather unknown docsis 3.0 modem/router Technicolor EPC3940 from my cable provider. I tested static ip config, with manually entered `static domain_name_servers=` in `/etc/dhcpcd.conf`. Pings seem low, but I had to wait 20 seconds to see the first ping result: [email protected]:~ $ ping google.co...
by johnnywho
Sat Aug 17, 2019 5:44 pm
Forum: Troubleshooting
Topic: [Solved] Raspberry Pi 4 Ethernet Problem
Replies: 20
Views: 14209

Re: Raspberry Pi 4 Ethernet Problem

neilgl wrote:
Sat Aug 17, 2019 5:34 pm
What happens if you temporarily unplug the Ethernet cable from the 3b+ and put it into the pi4?

Hot-swapping the cables doesn't fix it. SSH still laggy, server names still not found.

What's worth noting is that I also tried static ip configurations which didn't help much as well.
by johnnywho
Sat Aug 17, 2019 5:14 pm
Forum: Troubleshooting
Topic: [Solved] Raspberry Pi 4 Ethernet Problem
Replies: 20
Views: 14209

[Solved] Raspberry Pi 4 Ethernet Problem

I'm having an ethernet connectivity problem on a freshly installed Raspbian Buster Lite (2019-07-10) I'm able to find the rpi4 on the network, but ssh is slow to connect and feels very laggy when typing. DNS doesn't work out of the box. After specifying it manually, rpi4 finds the servers, but the s...

Go to advanced search