Go to advanced search

by stu54
Thu Aug 29, 2019 5:30 pm
Forum: Graphics, sound and multimedia
Topic: Can't get 3D to work with omxplayer
Replies: 9
Views: 1477

Re: Can't get 3D to work with omxplayer

I noticed something that was happening when I tried the latest kernel for the PI. I said in a previous post that the glasses looked like they were being put into anaglyph mode. In fact, it is the projector going into anaglyph mode instead of alternating left and right frames. If I was going to guess...
by stu54
Thu Jul 25, 2019 10:36 pm
Forum: HATs and other add-ons
Topic: lcdproc and PI4
Replies: 3
Views: 648

Re: lcdproc and PI4

I have a fix. I posted something about getting GPIO working on the PI 4 in another forum and someone said to change the base address to 0xFE000000 from 0x3F000000 so I tried that (in hd44780-rpi.h) and now it works. I had cloned the lcdproc master branch and that's what I compiled to test it.
by stu54
Thu Jul 25, 2019 10:29 pm
Forum: C/C++
Topic: PI4 and GPIO not working
Replies: 2
Views: 509

Re: PI4 and GPIO not working

Thanks! That fixed it. This all came about because I posted something in another forum here about lcdproc not working on the PI 4. I made the same change in my copy of the lcdproc source and now it works, too.
by stu54
Thu Jul 25, 2019 5:17 pm
Forum: C/C++
Topic: PI4 and GPIO not working
Replies: 2
Views: 509

PI4 and GPIO not working

I am using the example C++ programming for GPIO from https://elinux.org/RPi_GPIO_Code_Samples I read for the PI4 the BCM2708_PERI_BASE value is 0x3F000000 and for the PI2 it is 0x20000000. I tried the same example on a PI2 and PI4 (adjusting the BCM2708_PERI_BASE for each version) and it works on th...
by stu54
Wed Jul 24, 2019 4:47 am
Forum: HATs and other add-ons
Topic: lcdproc and PI4
Replies: 3
Views: 648

lcdproc and PI4

I have a HD44780 display wired to my PI 4 GPIO pins. I can get it to work fine using the Python rplcd-tests so I know it's wired correctly. I have compiled the master branch of lcdproc and I can see the driver loaded with no errors when I run LCDd with my LCDd.conf file. But the display does not sho...
by stu54
Wed Jul 10, 2019 5:11 pm
Forum: Graphics, sound and multimedia
Topic: Can't get 3D to work with omxplayer
Replies: 9
Views: 1477

Re: Can't get 3D to work with omxplayer

I tried that but the projector is not in 3D mode after running tvservice. It goes into 1080p 24Hz mode.
by stu54
Wed Jul 10, 2019 4:15 pm
Forum: Graphics, sound and multimedia
Topic: Can't get 3D to work with omxplayer
Replies: 9
Views: 1477

Re: Can't get 3D to work with omxplayer

So you think it's a video driver issue? I just wanted to make sure it wasn't something I did wrong when I ripped the blu-ray or in the demo file I found on a website. Thanks for your help. I can test code for you if you tell me how to update my driver when you have a release.
by stu54
Wed Jul 10, 2019 3:17 pm
Forum: Graphics, sound and multimedia
Topic: Can't get 3D to work with omxplayer
Replies: 9
Views: 1477

Re: Can't get 3D to work with omxplayer

Thanks for your response. I run: omxplayer -3 FP -M -r --passthrough /plex/kodi/d6_3D_MVC.mkv Output mode 32: [email protected] :20 ntsc_freq:1 3DFP Video codec omx-mvc width 1920 height 1080 profile 100 fps 23.976025 Audio codec ac3 passthrough channels 6 samplerate 48000 bitspersample 16 Subtitle count...
by stu54
Tue Jul 09, 2019 10:31 pm
Forum: Graphics, sound and multimedia
Topic: Can't get 3D to work with omxplayer
Replies: 9
Views: 1477

Can't get 3D to work with omxplayer

I have a projector that does alternate frame 3D and uses shutter-type LCD glasses. I have a 3D demo file MKV and I have another MKV which is a 3D blu-ray rip. I have a PI 4 with 1GB running raspbian buster. I am trying to play the MKV files with omxplayer. My projector OSD says the input it's gettin...

Go to advanced search