Go to advanced search

by anszom
Wed Jul 10, 2019 9:41 am
Forum: Advanced users
Topic: Anyone cross compiled QT for the Pi 4 yet.
Replies: 23
Views: 1244

Re: Anyone cross compiled QT for the Pi 4 yet.

I have now done some testing as per anszom's guidance and can report as follows.... 1. With fake KMS enabled, launching qmlscene comes up with the following error... * failed to add service - already in use? This message comes out from broadcom OpenGL libraries. For some reason you seem to still be...
by anszom
Tue Jul 09, 2019 8:56 am
Forum: Advanced users
Topic: Anyone cross compiled QT for the Pi 4 yet.
Replies: 23
Views: 1244

Re: Anyone cross compiled QT for the Pi 4 yet.

I've managed to get it to work yesterday. I've used qt 5.9 for various historical reasons, but this should apply to later versions as well. Building: 1. Install these dependencies into your raspberry pi sysroot: libegl1-mesa-dev libgbm-dev libgles2-mesa-dev mesa-common-dev . Not all of these may be ...
by anszom
Wed Jun 26, 2019 3:52 pm
Forum: Graphics programming
Topic: dispmanx: disable framebuffer layer
Replies: 2
Views: 1786

Re: dispmanx: disable framebuffer layer

The OP has probably moved on, but I've been looking for an answer to the same question. It seems that "blanking" the framebuffer by writing 1 to /sys/class/graphics/fb0/blank disables the dispmanx layer. This can be verified with "vcgencmd dispmanx_list"

Go to advanced search