Go to advanced search

by b3lt3r
Mon Jun 22, 2020 4:18 pm
Forum: Advanced users
Topic: Upgrade MariaDB
Replies: 6
Views: 291

Re: Upgrade MariaDB

As mentioned, I see 10.3 in the repository now, my assumption is that it has appeared since I did the original new image install. The real question is how I update maria safely, rather than the Pi itself. I've seen several posts in these forums saying "full upgrade" isn't a thing to be done unless t...
by b3lt3r
Mon Jun 22, 2020 2:26 pm
Forum: Advanced users
Topic: Upgrade MariaDB
Replies: 6
Views: 291

Re: Upgrade MariaDB

I've been on Buster for a long time - pretty much since first released - I've always done wipe and install from scratch so this install of 10.0 would have been from the Raspian Buster repo as shipped at the time. I do regular apt update/upgrade but have never been prompted that the newer version is ...
by b3lt3r
Mon Jun 22, 2020 1:12 pm
Forum: Advanced users
Topic: Upgrade MariaDB
Replies: 6
Views: 291

Upgrade MariaDB

I'm currently running 32 bit Raspian which has MariaDB 10.0 installed and working fine. I tried to upgrade an app and that failed, which after searching appears to be because the max index size limit changed (larger) in 10.2. I've had a look in add/remove and see 10.0 marked as installed but also se...
by b3lt3r
Sat Jun 06, 2020 9:01 pm
Forum: Advanced users
Topic: VNC on Buster 64-bit
Replies: 5
Views: 789

Re: VNC on Buster 64-bit

Seen lots of posts about issues with vncserver. I installed tightvnc on mine and it worked exactly the same as on my 32 bit versions - no issues at all. Tightvnc is part of my "standard" stack so didn't even try the shipped version.
by b3lt3r
Sat Jun 06, 2020 4:23 pm
Forum: Ubuntu
Topic: Ubuntu 20.04 on Rpi 3 - Boot from NFS root [ANSWERED]
Replies: 2
Views: 299

Re: Ubuntu 20.04 on Rpi 3 - Boot from NFS root [ANSWERED]

Well.... Ubuntu may not support network boot, but based on another thread about SSD booting here (simple method) I re-tried NFS boot and blow me down it worked a treat.... So - currently have two Pi 3s (one Pi OS 64 bit and one Ubuntu 20.04) booted from NFS mounted root file systems. Both are served...
by b3lt3r
Thu May 28, 2020 7:21 am
Forum: Ubuntu
Topic: Ubuntu 20.04 on Rpi 3 - Boot from NFS root [ANSWERED]
Replies: 2
Views: 299

Re: Ubuntu 20.04 on Rpi 3 - Boot from NFS root

Lol! Based on what I just read on the 64 bit User land Beta for Raspberry OS, it appears my need for Ubuntu *may* diminish although some apps are either only available or more up to date in the UB repos.... Would still be grateful for a clue on the NFS boot question as I'd expect 64 bit RPOS to take...
by b3lt3r
Wed May 27, 2020 4:52 pm
Forum: Ubuntu
Topic: Ubuntu 20.04 on Rpi 3 - Boot from NFS root [ANSWERED]
Replies: 2
Views: 299

Ubuntu 20.04 on Rpi 3 - Boot from NFS root [ANSWERED]

Good afternoon After losing yet another (Raspbian) system to a corrupted SD card I've had enough. I have a system running happily off SSD and that is very straight forward, however, I have decided that for my usage profiles the logical path to take is to boot via NFS mounted root volumes. This seems...
by b3lt3r
Sun May 17, 2020 10:54 am
Forum: Ubuntu
Topic: Ubuntu 20.04 Install Fail
Replies: 33
Views: 8357

Re: Ubuntu 20.04 Install Fail

Just my experiences to date... I have installed and am currently running 19.10 and 20.04 on a couple of Pi3s. Overall so far they seem reliable and as soon as Docker add the focal repository I'll probably switch off 19.10. I added xfce4 as a desktop to 20.04 yesterday - that took hours and hours. Th...
by b3lt3r
Sun May 17, 2020 10:15 am
Forum: Ubuntu
Topic: Transfer system from Pi3 to Pi4
Replies: 2
Views: 153

Re: Transfer system from Pi3 to Pi4

OK thanks.

The trigger for the suspicion was that the Ubuntu site downloads have distinct links for 3 & 4 which I dangerously assumed meant that *something* differs in the images. Having looked at the URL behind the links they seem identical so maybe it's not an issue.

Mike
by b3lt3r
Sun May 17, 2020 9:32 am
Forum: Ubuntu
Topic: Transfer system from Pi3 to Pi4
Replies: 2
Views: 153

Transfer system from Pi3 to Pi4

Simple question (no question ever turns out so, but I live in hope) If I build a system on a Pi3 B on Ubuntu 20.04 including all applications, docker etc - can I simply take the SD card out of the Pi3, pop it in a Pi4 and expect it to boot up and run correctly? I have a niggling suspicion that the b...
by b3lt3r
Thu Feb 27, 2020 4:53 pm
Forum: Troubleshooting
Topic: Desktop files recovery SD card corrupt
Replies: 3
Views: 199

Re: Desktop files recovery SD card corrupt

Hi Caveat you - I'm not an expert - found this on Google, but it did work.. I had a similar issue on an external USB device and followed these steps on another non-pi Debian machine which did repair the superblock. Ymmv and suggest an rsync or image of the card before doing it :-) Sorry for bad form...
by b3lt3r
Wed Jan 01, 2020 3:14 pm
Forum: Troubleshooting
Topic: Desktop doesn't respond on Raspbian Buster
Replies: 15
Views: 1755

Re: Desktop doesn't respond on Raspbian Buster

Just a random thought as your symptom is very similar to something I experienced on a NUC with Mint Mate - constant looping of the graphical login prompt despite putting in the correct password. Desktop behaviour was inconsistent before I logged out (which I did to try and reset the desktop with a r...
by b3lt3r
Mon Dec 23, 2019 9:22 am
Forum: Advanced users
Topic: Pi4 rootfs on SSD
Replies: 2
Views: 471

Pi4 rootfs on SSD

Hi

I believe that it's still necessary to perform the initial boot from SD and mount the SSD as root (I don't want to get into TFTP etc). Can someone please confirm/deny, and if correct, point me at the latest how-to guide for Pi4?

TIA

Mike
by b3lt3r
Fri Sep 20, 2019 9:05 am
Forum: Troubleshooting
Topic: USB behaviour when adding devices
Replies: 0
Views: 154

USB behaviour when adding devices

I noticed that when I plugged in a new device (stick or external hub) to my Pi 4 - the light on my already attached and mounted drive went out momentarily and the hdmi display also flickered. This happens when I literally just touch the empty port while I'm trying to line the plug up to the hole. On...
by b3lt3r
Sat Sep 14, 2019 1:38 pm
Forum: Advanced users
Topic: Moving /var/log to USB SSD
Replies: 1
Views: 516

Moving /var/log to USB SSD

I would like to move just /var/log off the SD card to reduce writes on the SD. I know how to do it, however what I can't find is an answer to whether it's safe to do it. My uncertainty is whether the system needs to write to /var/log before USB drives are mounted. I feel it's very likely in which ca...
by b3lt3r
Wed Sep 04, 2019 9:02 am
Forum: Troubleshooting
Topic: Pi 4 on latest Buster - quick questions
Replies: 2
Views: 165

Re: Pi 4 on latest Buster - quick questions

Thank you!
by b3lt3r
Wed Sep 04, 2019 8:54 am
Forum: Troubleshooting
Topic: Pi 4 on latest Buster - quick questions
Replies: 2
Views: 165

Pi 4 on latest Buster - quick questions

1. Which frequency I should be seeing? I had expected to see a constant 1500mhz while CPU temp was below 60c. What I actually see is mostly 600mhz with short periods at 1500mhz. 2. During boot I saw nothing on the console between the rainbow splash and the desktop appearing - I'm used to seeing the ...
by b3lt3r
Tue Sep 03, 2019 11:48 am
Forum: Troubleshooting
Topic: Rpi 3 not connecting to wifi with AP security
Replies: 5
Views: 310

Re: Rpi 3 not connecting to wifi with AP security

It may be worth looking at the security settings on the AP where you have issues. I had a case where one of my adapters would not connect to a TP-Link powerline Wifi extender when many other devices would. I changed "something" and the issue went away. I'm afraid I cannot remember which item but cer...
by b3lt3r
Fri Jul 12, 2019 4:10 pm
Forum: Troubleshooting
Topic: USB reset errors - assistance appreciated
Replies: 0
Views: 224

USB reset errors - assistance appreciated

[*]In my message logs I see repeated lines of: [3381758.194531] usb 1-1.4.5.5: reset high-speed USB device number 11 using dwc_otg The system is working but given the frequency of this message it appears something is not happy and I'd like to narrow the issue down. I have a USB 2.0 powered hub attac...
by b3lt3r
Wed Jul 10, 2019 1:38 pm
Forum: General discussion
Topic: Reasoning behind dual Micro HDMI, and potential future alternatives?
Replies: 125
Views: 13318

Re: Reasoning behind dual Micro HDMI, and potential future alternatives?

I guess I must be insane then @jamesh :-) I (and I suspect 80+%) of users will plug 1 monitor into their Pis for the vast majority of use cases. That would have saved buying a new cable because I had boxes of the full size one in my hoarding cavern. For my (insane) tastes - the nicest solution would...
by b3lt3r
Sat Jul 06, 2019 11:43 am
Forum: General discussion
Topic: Video Chat on the Raspberry 4
Replies: 27
Views: 7676

Re: Video Chat on the Raspberry 4

On Pi3 I can do video chat using a nextcloud with nextcloud-talk solution. Works surprisingly well including screenshare and my assumption is that running on a Pi4 will make it even better. With the addition of coturn I can chat from my mobile on the mobile network to any other users registered to m...
by b3lt3r
Fri Jul 05, 2019 3:58 pm
Forum: Troubleshooting
Topic: Problem with two ssd connected on the two USB 3 ports of RPi 4
Replies: 5
Views: 495

Re: Problem with two ssd connected on the two USB 3 ports of RPi 4

I could have sworn I saw a comment in the original release materials that one of the benefits of upgrading the power supply to USB-C/3a from micro/2.5 was that USB devices *may* not require external power. Personally, I would not trust disks without the best power supply possible having just been th...
by b3lt3r
Sat Jun 29, 2019 3:16 pm
Forum: General discussion
Topic: problems with raspberry pi 4b
Replies: 18
Views: 2662

Re: problems with raspberry pi 4b

You may want to check that your display is plugged into HDMI port 0 - closest to the USB-C. The alternate port does not seem to output video once updates have been done following the initial configuration. Fixed mine and several other peoples apparently "not booting" Pis
by b3lt3r
Wed Jun 26, 2019 5:17 pm
Forum: Troubleshooting
Topic: Pi 4 Installation Issues (Solved)
Replies: 22
Views: 10157

Re: Pi 4 Installation Issues (Solved)

Oh. This is an actual hardware issue? Has the Pi shop confirmed what the issue is? Personally it's not a deal breaker for me as the unit I have now will run 99.99% headless and 1 screen if ever, but it would be good to know what to look out for when (yes when) I buy other units which I'd probably wa...
by b3lt3r
Wed Jun 26, 2019 8:17 am
Forum: Troubleshooting
Topic: No video after 'resized filesystem message'
Replies: 2
Views: 241

Re: No video after 'resized filesystem message'

Had the same - must ensure you use the HDMI port closest to the power port - that will work correctly

Go to advanced search