Go to advanced search

by kikusin
Sat Jul 20, 2019 7:43 am
Forum: Networking and servers
Topic: 4G Hat
Replies: 105
Views: 85614

Re: 4G Hat

I think it is not passing username and password.

Try to input all the parameter within " " , as only one unique string.
Like in --wds-start-network= "apn=orange,username=orange,password=orange,ip-type=4"
by kikusin
Thu Jul 18, 2019 9:15 am
Forum: Networking and servers
Topic: 4G Hat
Replies: 105
Views: 85614

Re: 4G Hat

Hi @witenite1!

Have you tried to follow previos Gamuras tip?

launch

Code: Select all

sudo qmi-network /dev/cdc-wdm0 start
Before requesting IP.

This is not gonna get you rid of the bug, but is a faster thing to try.

Good luck!
by kikusin
Tue Jul 02, 2019 1:53 am
Forum: Networking and servers
Topic: 4G Hat
Replies: 105
Views: 85614

Re: 4G Hat

It worked! Thank you so much Gamura! [By the way, probably related to ISP, but in my case I need to wait up to three minutes since starting network till I request IP if I want it to succeed.] Anyway, just in case, I think is great to have here the whole list of commands you use. I am pretty sure som...
by kikusin
Thu Jun 27, 2019 3:09 pm
Forum: Networking and servers
Topic: 4G Hat
Replies: 105
Views: 85614

Re: 4G Hat

I am afraid we both need help from someone who knows better about QMI. I am still blocked with the IP lease :S The only thing I can suggest is: by console, do you get to open the network by [ AT+NETOPEN ] ? And can you get IP [ AT+IPPADDR ]? Surely you know, but just in case, the IP you mention [ ww...
by kikusin
Wed Jun 26, 2019 4:15 pm
Forum: Networking and servers
Topic: 4G Hat
Replies: 105
Views: 85614

Re: 4G Hat

Be sure you followed step 2) of main post: 2. This one is important - when you reboot the pi, the SIM7600 module's cellular radio is OFF and needs to be turned ON before you can see the mobile network. One way is to use a script which pulls the GPIO pin 4 LOW for a second or two (as per this post: h...
by kikusin
Fri Jun 21, 2019 12:36 pm
Forum: Networking and servers
Topic: 4G Hat
Replies: 105
Views: 85614

Re: 4G Hat

Hi everyone! New here and fighting with SIM7600 as well. Thanks for all the info in the thread. It was very useful but I got stuck in the very very last step. I get everything ok and start the network: pi@raspberrypi:~ $ sudo qmicli -p -d /dev/cdc-wdm0 --device-open-"net=net-raw-ip|net-no-qos-h...

Go to advanced search