Go to advanced search

by Minestrone
Tue Jun 25, 2019 8:10 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: 1-Wire Ds18B20 temperature sensor disappearing when over 60°C
Replies: 7
Views: 1194

Re: 1-Wire Ds18B20 temperature sensor disappearing when over 60°C

Thanks a lot for all the input. I will try to rewire the network the next few days, and then come back with results. It could be that the special spot is actually 64°, the last time it failed, the last correctly logged temperature was actually 63.5°. As it only logs every 5 minutes it could therefor...
by Minestrone
Mon Jun 24, 2019 9:25 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: 1-Wire Ds18B20 temperature sensor disappearing when over 60°C
Replies: 7
Views: 1194

Re: 1-Wire Ds18B20 temperature sensor disappearing when over 60°C

My system is wired in star topology, so each sensor has its own line. I thought from an electronic standpoint, star and daisy chained is the same? (or does the different cable length make such a big difference?) I will try to rewire the network in the next few days. Do you think a arduino would mayb...
by Minestrone
Thu Jun 20, 2019 3:03 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: 1-Wire Ds18B20 temperature sensor disappearing when over 60°C
Replies: 7
Views: 1194

Re: 1-Wire Ds18B20 temperature sensor disappearing when over 60°C

Hey, thanks for your reply, I am using the original raspberry PSU and have never had any problems with power outages, the sensors itself are from a german online shop and should be of enough quality, the are connected via 3m cables. The high temperature only occurs when the solar panels are providin...
by Minestrone
Thu Jun 20, 2019 2:16 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: 1-Wire Ds18B20 temperature sensor disappearing when over 60°C
Replies: 7
Views: 1194

1-Wire Ds18B20 temperature sensor disappearing when over 60°C

Hey Guys, so I build a small pool automation, with 4 relays and 3 temperature sensors. I connected the sensors via a pcb board using the 3v3 from the raspberry and a 4k7 resistor as pullup. Everything works exactly as intended until one (and it normally does not matter which one of the three it is) ...

Go to advanced search