Go to advanced search

by teknomanzer
Thu May 30, 2019 12:37 am
Forum: Device Tree
Topic: Buildroot Pi Zero Ethernet Gadget issues
Replies: 11
Views: 2865

Re: Buildroot Pi Zero Ethernet Gadget issues

thagrol, thanks for the link. I'd like to keep it simple. I'd like to understand why this works on a Stretch lite and not on a Buildroot. What's missing and how to set it up. I think it's close, the driver is loaded and the computer recognizes the gadget and creates the RNDIS connection. Here is a d...
by teknomanzer
Wed May 29, 2019 9:59 am
Forum: Device Tree
Topic: Buildroot Pi Zero Ethernet Gadget issues
Replies: 11
Views: 2865

Re: Buildroot Pi Zero Ethernet Gadget issues

Here is my entire config.txt for completion: ######################################################## ### MAXDASH CONFIG ######################################################## ### General disable_splash=1 boot_delay=0 ### Kernel kernel=zImage ### Memory gpu_mem_256=128 gpu_mem_512=196 gpu_mem_1024...
by teknomanzer
Wed May 29, 2019 9:57 am
Forum: Device Tree
Topic: Buildroot Pi Zero Ethernet Gadget issues
Replies: 11
Views: 2865

Re: Buildroot Pi Zero Ethernet Gadget issues

So I removed modules-load=g_ether from the cmdline.txt Added back my S02ethernet_gadget init script which does a modprobe g_ether Added dtoverlay=dwc2,dr_mode=peripheral to the config.txt Unfortunately I get the same result. RNDIS connection pops up on Mac just fine, I can connect to it, I can ping ...
by teknomanzer
Wed May 29, 2019 9:54 am
Forum: Device Tree
Topic: Buildroot Pi Zero Ethernet Gadget issues
Replies: 11
Views: 2865

Re: Buildroot Pi Zero Ethernet Gadget issues

Imodules-load is not a real command line option supported by the kernel. It is interpreted by systemd instead. So if you selected a different init system in buildroot, that option will indeed not load your g_ether. Thank you! I didn't know. I am indeed not using systems but busybox init. That would...
by teknomanzer
Tue May 28, 2019 10:01 pm
Forum: Device Tree
Topic: Buildroot Pi Zero Ethernet Gadget issues
Replies: 11
Views: 2865

Re: Buildroot Pi Zero Ethernet Gadget issues

PhilE, Do you know why with Raspbian Stretch or Stretch lite, the settings I provided just work? Whats different? I suppose the Stretch is also using the "bcmrpi" configuration which defaults to "Dual Role Mode". Is the stretch setting the peripheral model somewhere else in the boot sequence? Thanks...
by teknomanzer
Tue May 28, 2019 8:20 pm
Forum: Device Tree
Topic: Buildroot Pi Zero Ethernet Gadget issues
Replies: 11
Views: 2865

Re: Buildroot Pi Zero Ethernet Gadget issues

Thanks Phil. I'll give it a try tonight!
by teknomanzer
Tue May 28, 2019 9:02 am
Forum: Device Tree
Topic: Buildroot Pi Zero Ethernet Gadget issues
Replies: 11
Views: 2865

Buildroot Pi Zero Ethernet Gadget issues

Hi, I'm setting up a pi zero w as an ethernet gadget with a custom Buildroot distribution and I'm having some weird issues. My config.txt: dtoverlay=dwc2 My cmdline.txt: vt.global_cursor_default=0 root=/dev/mmcblk0p2 rootfstype=ext4 console=tty1 fsck.repair=yes rootwait modules-load=dwc2,g_ether My ...

Go to advanced search