Go to advanced search

by antoinebore
Fri May 17, 2019 8:37 am
Forum: Compute Module
Topic: SDIO1 CM3+ WILC1000
Replies: 31
Views: 760

Re: SDIO1 CM3+ WILC1000

Good news... and bad news. It works once for me ! After that, I disconnected the wire and the kernel crashed. Now that I have rebooted the raspi, the mmc1 isn't working anymore... any idea ? [email protected]:~$ sudo cat /sys/kernel/debug/mmc1/ios clock: 0Hz vdd: 0 (invalid) bus mode: 2 (push-pull) chi...
by antoinebore
Fri May 17, 2019 8:33 am
Forum: Compute Module
Topic: SDIO1 CM3+ WILC1000
Replies: 31
Views: 760

Re: SDIO1 CM3+ WILC1000

Thank you. I don't have the same version as of ATWILC1000-SD as you. I guess that the pin above the 9 SDIO pins are chip_en, irq and reset, right ?
by antoinebore
Fri May 17, 2019 8:05 am
Forum: Compute Module
Topic: SDIO1 CM3+ WILC1000
Replies: 31
Views: 760

Re: SDIO1 CM3+ WILC1000

You can compile with: $ dtc [email protected] -I dts -O dtb -o sdio-overlay-final.dtbo sdio-overlay-final.dts However, I would make the name something more meaningful like wilc_sdio.dtbo. Whatever name you choose, copy the .dtbo to /boot/overlays and add "dtoverlay=your_name.dtbo" to config.txt. Ok thank you. # /...
by antoinebore
Fri May 17, 2019 7:32 am
Forum: Compute Module
Topic: SDIO1 CM3+ WILC1000
Replies: 31
Views: 760

Re: SDIO1 CM3+ WILC1000

By the way, did you use the WILC1000 last version that you can download on the wilc1000 git or did you use the one available in raspberrypi/linux git ?
by antoinebore
Fri May 17, 2019 6:48 am
Forum: Compute Module
Topic: SDIO1 CM3+ WILC1000
Replies: 31
Views: 760

Re: SDIO1 CM3+ WILC1000

Thank you for the feedback, I will try. Could you share a picture of your set up ?

Do you use your device tree like an overlay with dtoverlay=sdio-overlay-final in /boot/config.txt ?

Cheers,
by antoinebore
Fri May 17, 2019 2:17 am
Forum: Compute Module
Topic: SDIO1 CM3+ WILC1000
Replies: 31
Views: 760

Re: SDIO1 CM3+ WILC1000

I also almost succeed few times but this solution isn't consistent enough for me. Not yet, for the moment, I'm trying with the Cypress solutions as the CYW43438 is used in the Raspi 3B+. I have tried the ISM43362-L36 as I only need WiFi but it doesn't work (thread here: https://www.raspberrypi.org/f...
by antoinebore
Fri May 17, 2019 1:32 am
Forum: Compute Module
Topic: SDIO1 CM3+ WILC1000
Replies: 31
Views: 760

Re: SDIO1 CM3+ WILC1000

Hi,

I gave up with this module and I don't have any answer for you. Maybe you can ask on their github :https://github.com/linux4wilc/driver/issues
by antoinebore
Thu May 16, 2019 3:33 am
Forum: Compute Module
Topic: ISM43362
Replies: 6
Views: 137

Re: ISM43362

I have made some progress by adding some capacitor. Now the ISM43362 is able to send his signature but it still doesn't work : [ 2080.051294] mmc1: new high speed SDIO card at address 0001 [ 2080.052654] brcmfmac: F1 signature read @0x18000000=0x1591a962 [ 2080.053641] brcmfmac: brcmf_chip_cores_che...
by antoinebore
Wed May 15, 2019 10:56 am
Forum: Compute Module
Topic: ISM43362
Replies: 6
Views: 137

Re: ISM43362

Hi,

Thank you, I will try but I was wrong, the CYW43362 and ISM43362 support SDIO High-speed.

EDIT: Lower the clock didn't work.
by antoinebore
Wed May 15, 2019 9:44 am
Forum: Compute Module
Topic: ISM43362
Replies: 6
Views: 137

Re: ISM43362

The problem seems to be the clock. The ISM43362 only support 25MHz max and the Raspi provide 47 MHz. Does somebody know how I can limit the mmc1 frequency ?

Cheers,
Antoine
by antoinebore
Wed May 15, 2019 8:58 am
Forum: Compute Module
Topic: ISM43362
Replies: 6
Views: 137

Re: ISM43362

How are you connecting the device to the SDIO bus? The documentation doesn't mention any support of SDIO, only SPI and UART interfaces Hi, Are you sure that you read the right documentation ? I have bought this one : https://www.inventeksys.com/wifi/wifi-modules/ism43362-l36/ On the documentation :...
by antoinebore
Wed May 15, 2019 3:22 am
Forum: Compute Module
Topic: ISM43362
Replies: 6
Views: 137

ISM43362

Hi, I'm still trying to add a softAP WiFi module to my Raspi CM3+. (I'm starting to think I will never succeed.) I am trying to do it with the ISM43362. This module uses a similar chip that the one used on the Raspi 3B+. Unfortunately, when I connect the module to my SDIO GPIO, I have this message :...
by antoinebore
Tue May 07, 2019 1:37 am
Forum: Compute Module
Topic: CM IO Board USB GPIO
Replies: 2
Views: 151

Re: CM IO Board USB GPIO

USB is a dedicated peripheral which is not part of the GPIO. So, no you can't wire it to GPIO but you can use a USB-A type cable and solder it to it's leads. than connect it to CMIO J14. Be shure to only use D+/D- from J14 (!!!) as this module need 3.3V power supply. For power supply and control si...
by antoinebore
Mon May 06, 2019 10:24 am
Forum: Compute Module
Topic: CM IO Board USB GPIO
Replies: 2
Views: 151

CM IO Board USB GPIO

Hi,

Can we connect a USB Dongle like this one: https://www.acmesystems.it/WIFI-2 by wiring USB data + and USB data - on 2 GPIO of the CM IO Board ?

Thank you,
Antoine
by antoinebore
Mon May 06, 2019 1:23 am
Forum: Compute Module
Topic: SDIO1 CM3+ WILC1000
Replies: 31
Views: 760

Re: SDIO1 CM3+ WILC1000

Hi, Thanks mate. Appreciate your help. Yes we can work together till we get this solved. I think I have gone one step further. I was seeing high frequency oscillation on DAT3 and CMD. I thought may be this is due to long wires I used to connect the dev kit to CMIO. So I shorted them to about 3 cm. ...
by antoinebore
Fri May 03, 2019 4:48 am
Forum: Compute Module
Topic: SDIO1 CM3+ WILC1000
Replies: 31
Views: 760

Re: SDIO1 CM3+ WILC1000

Hi, Many thanks for your reply. The pin out diagram you mentioned has the pin 1 and 2 description not matching the signal name. Could you please clarify? I have already checked the pin out of the wilc1000-sd Dev kit with the Dev kit schematic and it seems correct. What I have connected is as follow...
by antoinebore
Thu May 02, 2019 9:36 am
Forum: Compute Module
Topic: SDIO1 CM3+ WILC1000
Replies: 31
Views: 760

Re: SDIO1 CM3+ WILC1000

You need to wire the SDIO pin according this image : http://3.bp.blogspot.com/_8JZhVVmpICU/T ... pinout.jpg
by antoinebore
Thu May 02, 2019 9:30 am
Forum: Compute Module
Topic: SDIO1 CM3+ WILC1000
Replies: 31
Views: 760

Re: SDIO1 CM3+ WILC1000

Hi, I am trying the same and seeing the same results as yours. Did you manage to find a solution? Cheers, Kay Can you send your log ? I had some problem because of the wiring order of my pin. The wilc1000 schematic can fool you, be careful. Concerning the driver, I'm not able to make it work despit...
by antoinebore
Thu Apr 25, 2019 9:04 am
Forum: Compute Module
Topic: SDIO1 CM3+ WILC1000
Replies: 31
Views: 760

Re: SDIO1 CM3+ WILC1000

That comment is just saying that the standard Compute Module DTB doesn't enable the other MMC interface - the one used for WiFi on the 3B etc. This isn't a problem for you because you are using the "sdio" overlay - that's what it was designed for. Now that your wiring is better, what do the followi...
by antoinebore
Thu Apr 25, 2019 4:09 am
Forum: Compute Module
Topic: SDIO1 CM3+ WILC1000
Replies: 31
Views: 760

Re: SDIO1 CM3+ WILC1000

I have manage to have a nice wiring and, now, the signal are clean. Although, the PI still doesn't recognize the module. Here is my wiring and the signal D7 (the signal top signal) is the SD1_CLK ; D3 is SD1_DAT3 ; D2 is SD1_CMD http://zupimages.net/viewer.php?id=19/17/bo82.jpg http://zupimages.net/...
by antoinebore
Wed Apr 24, 2019 11:09 am
Forum: Compute Module
Topic: SDIO1 CM3+ WILC1000
Replies: 31
Views: 760

Re: SDIO1 CM3+ WILC1000

So if I understood, I can't use it to plug my external WiFi module ? Do you know if there is an easy way to do that ? There is no easy way - you would need to break the tracks and reconnect them to other GPIOs, which is harder than what you are doing now. OK thank you. I will try to remake my wiring.
by antoinebore
Wed Apr 24, 2019 10:30 am
Forum: Compute Module
Topic: SDIO1 CM3+ WILC1000
Replies: 31
Views: 760

Re: SDIO1 CM3+ WILC1000

The SD card adaptor on the CMIO board is only for the CM Lite variant - it isn't connected to the right GPIOs to be useful as a secondary device. So if I understood, I can't use it to plug my external WiFi module ? Do you know if there is an easy way to do that ? Anyway, thank you for your response...
by antoinebore
Wed Apr 24, 2019 10:16 am
Forum: Compute Module
Topic: SDIO1 CM3+ WILC1000
Replies: 31
Views: 760

Re: SDIO1 CM3+ WILC1000

[email protected]:~ $ dmesg | grep sdio [ 0.804391] mmc-bcm2835 3f300000.sdio: could not get clk, deferring probe [ 1.872941] mmc-bcm2835 3f300000.sdio: mmc_debug:0 mmc_debug2:0 [ 1.881101] mmc-bcm2835 3f300000.sdio: DMA channel allocated This isn't an error - it's just an artifact of the way Linux ma...
by antoinebore
Wed Apr 24, 2019 9:49 am
Forum: Compute Module
Topic: SDIO1 CM3+ WILC1000
Replies: 31
Views: 760

SDIO1 CM3+ WILC1000

Hello everyone, I'm trying to connect the WILC1000-SD card to my Raspberry Pi Compute Module IO Board (with a CM3+). I want to use SDIO1. I have added "dtoverlay=sdio,poll_once=off" on /boot/config.txt I connected the WILC1000-SD to the GPIO22-27 which are setup in ALT3 mode. Although, the Pi and th...
by antoinebore
Thu Apr 18, 2019 7:30 am
Forum: Compute Module
Topic: WiFi chip for Compute Module 3
Replies: 18
Views: 16918

Re: WiFi chip for Compute Module 3

I can tell you one to avoid (at least for now). I've been trying to get an ATWILC1000 module working, but the driver support isn't there yet. There's a wilc1000 driver in drivers/staging but I wasn't able to get it to work (though it's being actively updated in the staging-next git repo). There's a...

Go to advanced search