Go to advanced search

by ddwwcc
Thu May 09, 2019 9:29 pm
Forum: Raspbian
Topic: Bug?: Setting gpio active_low via sys/class
Replies: 2
Views: 217

Re: Bug?: Setting gpio active_low via sys/class

Well, while researching the sysfs replacement, I found that one of the disadvantages of sysfs is it doesn't support pull up resistor setting. So, it's not a bug, it just never worked.

Thanks
by ddwwcc
Thu May 09, 2019 7:08 pm
Forum: Raspbian
Topic: Bug?: Setting gpio active_low via sys/class
Replies: 2
Views: 217

Bug?: Setting gpio active_low via sys/class

Hi I think I've found a bug, and as far as I can tell, this is the right place to report it. I'm trying to set active_low via sys/class for a GPIO input.but cannot get the pull up resistor to pull up. . For reference this is on a RPi 3 B+, with Debian Stretch fully updated. I have a switch attached ...
by ddwwcc
Thu May 09, 2019 6:51 pm
Forum: Troubleshooting
Topic: Setting the GPIO pull up resistor
Replies: 6
Views: 291

Re: Setting the GPIO pull up resistor

Looks like a bug, then. I'll put in a bug report.
by ddwwcc
Wed May 08, 2019 3:13 pm
Forum: Troubleshooting
Topic: Setting the GPIO pull up resistor
Replies: 6
Views: 291

Re: Setting the GPIO pull up resistor

Because I can't get it to work.
by ddwwcc
Wed May 08, 2019 1:13 pm
Forum: Troubleshooting
Topic: Setting the GPIO pull up resistor
Replies: 6
Views: 291

Re: Setting the GPIO pull up resistor

I general google around says I can, although I agree this is not definitive.

This doc, for instance says I can:

http://raspberrypi.znix.com/hipidocs/topic_gpiodev.htm

As I said, It's a cut down version, so has very little installed, hence the swapping cards to check hardware.
by ddwwcc
Wed May 08, 2019 11:24 am
Forum: Troubleshooting
Topic: Setting the GPIO pull up resistor
Replies: 6
Views: 291

Setting the GPIO pull up resistor

Hi I'm trying to get a simple button input to GPIO working, with a particular program I'm using, which uses a cut down version of Debian Stretch. For reference the program is QLC+ 4.12.1 on a RPi 3 B+, but cannot get the pull up resistor to pull up. I have a switch attached to pin 12, GPIO 18, via a...
by ddwwcc
Wed Jan 02, 2019 4:22 pm
Forum: Graphics, sound and multimedia
Topic: Sox not behaving
Replies: 0
Views: 184

Sox not behaving

Hi I've got an odd fault with Sox: I can't get it to accept special filenames, so -n -d and -p are not accepted. I can record and play, as long as they don't involve a special file name, for instance, with a USB mic attached, these work: $ rec song001.ogg $ rec -n $ play song001.ogg but this: sox −n...

Go to advanced search