Go to advanced search

by Lasse808
Tue Jan 29, 2019 2:14 pm
Forum: Camera board
Topic: Raspiraw images over or under exposed
Replies: 19
Views: 1517

Re: Raspiraw images over or under exposed

That is odd. I am using Stretch as well. What happens if you : 1. Run the raspiraw comand line from the 640x480 tool script on its own under chrt : sudo chrt -rr 99 raspiraw -md 7 -t 1000 -ts tstamps.csv -hd0 hd0.32k --height 128 --top 0 --vinc 17 --fps 180 -sr 1 -o /dev/shm/out.%04d.raw 2>/dev/null...
by Lasse808
Tue Jan 29, 2019 1:02 am
Forum: Camera board
Topic: Raspiraw images over or under exposed
Replies: 19
Views: 1517

Re: Raspiraw images over or under exposed

It is always a bit fiddly to run a sudo command within a shell script, so just run it on the full shell script :

Code: Select all

sudo chrt -rr 99 ./640x480 60000 180
You can check with top -H that the process within the shell script runs at RT level.
by Lasse808
Mon Jan 28, 2019 8:04 pm
Forum: Camera board
Topic: Raspiraw images over or under exposed
Replies: 19
Views: 1517

Re: Raspiraw images over or under exposed

Normally a process starts with priority 20, which is the lowest priority. So if anything else is happening on the Pi3B+ there is a high chance your process will be delayed. When worrying about micro seconds it is not ideal to have these interruptions in execution. If you are running headless and not...
by Lasse808
Sun Jan 27, 2019 9:35 pm
Forum: Camera board
Topic: Raspiraw images over or under exposed
Replies: 19
Views: 1517

Re: Raspiraw images over or under exposed

Hi Hermann, I am capturing in 640x480. I solved the frame loss and irregular callback issues by going to RT scheduler priority. Now I have below 0.1% frame loss with less than 10 lost frames pr minute at 180 fps. Good to know there are options to increase fps with decrease in vertical lines. I have ...
by Lasse808
Sun Jan 27, 2019 2:33 am
Forum: Camera board
Topic: Raspiraw images over or under exposed
Replies: 19
Views: 1517

Re: Raspiraw images over or under exposed

Many thanks Ethanol100! Very helpful! I am processing the frames looking for motion at 180 fps. I extract every 10th frame and process through opencv white balance and bespoke gamma correction (based upon PyImage's gamma correction) for a preview window. As you mention, I also found staying in 10 bi...
by Lasse808
Wed Jan 23, 2019 10:11 pm
Forum: Camera board
Topic: Raspiraw images over or under exposed
Replies: 19
Views: 1517

Re: Raspiraw images over or under exposed

Yes, slow and fast frame rates. The frames end up almost completely dark or completely white.
The data is in the raw frames, but just needs appropriate scaling.
by Lasse808
Wed Jan 23, 2019 9:13 pm
Forum: Camera board
Topic: Raspiraw images over or under exposed
Replies: 19
Views: 1517

Re: Raspiraw images over or under exposed

Thank you guys! I did experiment with Exposure time and Gain, and the picture I attached was the best I could get. I tracked down the issue to White Balance. If I manually de-mosaic and scale the 3 color channels, then I can get a reasonably nice looking picture. When using dcraw the white balance i...
by Lasse808
Tue Jan 22, 2019 8:33 pm
Forum: Camera board
Topic: Raspiraw images over or under exposed
Replies: 19
Views: 1517

Raspiraw images over or under exposed

Hi, Thanks to the great work posted here on this board, I have been able to get Raspiraw and the raw2ogg2anim tools going on Raspbian Stretch, RPI 3B+ and Ver 2 camera. When I use Raspivid I get great looking h264 video. But when using Raspiraw the frames are over exposed it seems, as everything is ...
by Lasse808
Mon Dec 31, 2018 7:53 pm
Forum: Camera board
Topic: High framerate raspivid (initially 640x480 at 180fps)
Replies: 25
Views: 9773

Re: High framerate raspivid (initially 640x480 at 180fps)

Hi Hermann, Thank you for the detailed share! I have build your code in the userland repository, but get an error when I run : raspivid -md 7 -fps 180 -pts 180.pts -w 640 -h 480 -o tt.h264 -t 4000 -ex off mmal: mmal_component_create_core: could not find component 'vc.camera_info' mmal: mmal_componen...
by Lasse808
Mon Dec 31, 2018 7:44 pm
Forum: Camera board
Topic: High framerate raspivid (initially 640x480 at 180fps)
Replies: 25
Views: 9773

Re: High framerate raspivid (initially 640x480 at 180fps)

Hello, When I build the code on a RSPI 3 with camera version 2 everything seems to be OK. But when I use : raspivid -md 7 -fps 180 -pts 180.pts -w 640 -h 480 -o tt.h264 -t 4000 -ex off I get : mmal: mmal_component_create_core: could not find component 'vc.camera_info' mmal: mmal_component_create_cor...

Go to advanced search