Go to advanced search

by puccaso
Wed Oct 07, 2020 11:18 am
Forum: Camera board
Topic: HQ UVC gadget and raspistll -fw
Replies: 2
Views: 305

Re: HQ UVC gadget and raspistll -fw

that would be awesome.
i have had issues getting the uvc cam to work with the rpi4 so I bought a zero wh but still no luck.

how are you getting yours to work as USB webcam?
by puccaso
Wed Oct 07, 2020 9:08 am
Forum: Advanced users
Topic: Pi Zero OTG webcam with Picam
Replies: 3
Views: 1158

Re: Pi Zero OTG webcam with Picam

i am having so much trouble with this :/
i have an rpi4, but couldn't get it to work
so i bought a new zero wh, and still no luck
by puccaso
Tue Oct 06, 2020 10:39 pm
Forum: Advanced users
Topic: Turn RPi Camera module into USB webcam for use in Windows
Replies: 14
Views: 2223

Re: Turn RPi Camera module into USB webcam for use in Windows

hey guys -

so i could not get the g_webcam gadget to work with the rpi4, so i bought a zero wh..
i've tried all of the uvc-gadget repos on this thread
but i can't get it working.

what am i doing wrong:(
by puccaso
Mon Aug 24, 2020 1:05 pm
Forum: Troubleshooting
Topic: System crashing when changing resolution [headless rpi4b 4gb]
Replies: 2
Views: 338

System crashing when changing resolution [headless rpi4b 4gb]

Hey folks, So I've had no issues with this device hitherto this problem when changing resolutions. Ultimately, I need to change/set resolution so I can get realvnc working correctly, and although I could do this manually in config.txt this is a production machine and I don't like loose ends. So I co...
by puccaso
Sat Aug 01, 2020 3:43 pm
Forum: Graphics, sound and multimedia
Topic: Full KMS in Buster Lite?
Replies: 11
Views: 3317

Re: Full KMS in Buster Lite?

any update on this? now considering that vulkan is almost working?
by puccaso
Sat Jul 25, 2020 10:17 pm
Forum: Camera board
Topic: Spare Parts list?
Replies: 3
Views: 263

Re: Spare Parts list?

Hey rpdom, What sort of parts do you mean? Lenses and adaptors perhaps, or components like the sensor? the HQ camera has 2 silver standoff type pins that connect the camera module to the pcb board.. they are a bit iffy - fyi - and they kept coming loose. I have unfortunately lost one now, and need t...
by puccaso
Fri Jul 24, 2020 7:35 pm
Forum: Camera board
Topic: Spare Parts list?
Replies: 3
Views: 263

Spare Parts list?

hey guys
does anyone know where we can find a spare parts list for the HQ camera board?

Thanks
puc
by puccaso
Tue Jul 21, 2020 6:09 pm
Forum: Camera board
Topic: Raspberry Pi High Quality Camera Module pins
Replies: 0
Views: 141

Raspberry Pi High Quality Camera Module pins

hey gang
i have the Raspberry Pi High Quality Camera Module, and on the board there are 2 pins that screw the sensor onto the pcb.
those screws come out quite easily, and i've lost one!

where can i get a replacement for those pins?


Thank you.

Kindly,
Puc.
by puccaso
Sun Jun 28, 2020 11:41 pm
Forum: Automation, sensing and robotics
Topic: Boot rapberry on ram
Replies: 15
Views: 17525

Re: Boot rapberry on ram

Now that we have an 8gB modal.. Could we get some official support for this? How can we do this guys? i use log2ram, can't we implement some of that, even if there was an initial copying of the system to ram, once we're up - we're good. just that I guess writing any huge changes back to the ssd/sd w...
by puccaso
Mon Jun 22, 2020 4:23 pm
Forum: Camera board
Topic: (32bit) Preview works fine, but all videos and images corrupt.
Replies: 7
Views: 413

Re: (32bit) Preview works fine, but all videos and images corrupt.

im such a doofus..
i had the 64bit arm flag in config.txt

working now.

slow mo videos here we go!

Thanks for everyone's time and attention. <3
by puccaso
Mon Jun 22, 2020 3:39 pm
Forum: Camera board
Topic: (32bit) Preview works fine, but all videos and images corrupt.
Replies: 7
Views: 413

Re: (32bit) Preview works fine, but all videos and images corrupt.

Ok so fresh install I haven't even upated, just used the fresh install rpi-imager So i guess something is crashing.? ==> syslog <== Jun 22 16:38:00 cam kernel: [ 131.832075] ------------[ cut here ]------------ Jun 22 16:38:00 cam kernel: [ 131.832124] WARNING: CPU: 1 PID: 1184 at drivers/staging/vc...
by puccaso
Mon Jun 22, 2020 2:58 pm
Forum: Camera board
Topic: (32bit) Preview works fine, but all videos and images corrupt.
Replies: 7
Views: 413

Re: (32bit) Preview works fine, but all videos and images corrupt.

I would suspect zram. Preview does all the heavy lifting on the GPU, so there is no interaction with the ARM. As soon as you take a capture, the JPEG file has to be copied back into ARM memory via DMA, and it looks like that is going wrong. Most likely the system is giving the DMA copy a compressed...
by puccaso
Mon Jun 22, 2020 12:08 pm
Forum: Camera board
Topic: (32bit) Preview works fine, but all videos and images corrupt.
Replies: 7
Views: 413

Re: (32bit) Preview works fine, but all videos and images corrupt.

ok nope. gone again. it was working i installed zram-tools then installed log2ram, set the config to enable zram and booted and we're gone again removed log2ram and then zram in that order and we're still gone.. Could someone help me locate what is causing this? like there must be a file that's bein...
by puccaso
Mon Jun 22, 2020 10:58 am
Forum: Camera board
Topic: (32bit) Preview works fine, but all videos and images corrupt.
Replies: 7
Views: 413

Re: (32bit) Preview works fine, but all videos and images corrupt.

ok update:
so I believe this was due to some software corruption
reimaged the sd card, and all is well.
by puccaso
Mon Jun 22, 2020 9:59 am
Forum: Camera board
Topic: HQ Camera not supported by 64bit or broken cam? :oops: :?: :(
Replies: 13
Views: 862

Re: HQ Camera not supported by 64bit or broken cam? :oops: :?: :(

MMAL is not currently supported in 64bit userland. We had the code written, but there's an odd failure case that we haven't got to the bottom of as yet. (Patches are in the userland repo but reverted if you want to go and investigate) Codecs and camera are available via v4l2 under both 32 and 64 bi...
by puccaso
Mon Jun 22, 2020 9:59 am
Forum: Camera board
Topic: HQ Camera not supported by 64bit or broken cam? :oops: :?: :(
Replies: 13
Views: 862

Re: HQ Camera not supported by 64bit or broken cam? :oops: :?: :(

For me using raspistill, raspivid etc does not work for 64bit, showing preview works fine, but if the images are going to be saved, it fails. There are only limited cases where 64bit is really useful, for camera functions, I currently will stick to 32bit. this is the exact issue im having now using...
by puccaso
Sun Jun 21, 2020 9:47 pm
Forum: Camera board
Topic: (32bit) Preview works fine, but all videos and images corrupt.
Replies: 7
Views: 413

(32bit) Preview works fine, but all videos and images corrupt.

Hello gang, I have purchased the HQ cam, with the telephoto lens. However, even though i can see previews fine - whenever i save a jpeg, it is either corrupted, so looks jagged and no real detail can be made out, or - i see an error stating the jpeg is corrupt and 0x0d 0x0d found where it shouldn't ...
by puccaso
Wed Jun 17, 2020 8:41 am
Forum: Camera board
Topic: HQ Camera not supported by 64bit or broken cam? :oops: :?: :(
Replies: 13
Views: 862

HQ Camera not supported by 64bit or broken cam? :oops: :?: :(

Hey fam, I just received my HQ cam and telephoto lens, but i wonder if there is something wrong with them, or with my pi setup. i've got the 8gb, running with the 64bit raspberry pi os. I know the 64bit OS is buggy - but i just want to know if anyone else has had issues taking pics or videos with th...
by puccaso
Wed Feb 19, 2020 6:33 pm
Forum: Advanced users
Topic: Overclock to 2.29 Ghz. But How?
Replies: 3
Views: 472

Re: Overclock to 2.29 Ghz. But How?

Ok. False alarm. root@deskpi:/home/pi# gcc -o cpuburn-a53 cpuburn-a53.S root@deskpi:/home/pi# while true; do vcgencmd measure_clock arm; vcgencmd measure_temp; sleep 10; done& stress -c 4 -t 900s [1] 29960 stress: info: [29961] dispatching hogs: 4 cpu, 0 io, 0 vm, 0 hdd frequency(48)=2100515584 temp...
by puccaso
Wed Feb 19, 2020 6:05 pm
Forum: Advanced users
Topic: Overclock to 2.29 Ghz. But How?
Replies: 3
Views: 472

Overclock to 2.29 Ghz. But How?

Hello everyone, I have overclocked to 2.29 Ghz....? What. Can someone help me confirm how i've actually done this, because I never actually wrote numbers that high, just 2100 - :shock: :o :mrgreen: here's output from the device... and a screeny screenshot .png System: Host: deskpi Kernel: 4.19.102-v...
by puccaso
Sun Dec 08, 2019 12:33 pm
Forum: Graphics, sound and multimedia
Topic: dsi OK but hdmi (closest to usbC) gives rainbow (rpi4/4gb)
Replies: 1
Views: 400

dsi OK but hdmi (closest to usbC) gives rainbow (rpi4/4gb)

Hello RPI gang! I've had like no issues with this baby since I got it, until recently. I dont quite know whats happened but as the subject says, my DSI 7" Raspberry Official LCD works fine, but the hdmi output now is a rainbow. i've tried both rasbian, and puppylinux and debian from berryboot - same...
by puccaso
Mon Nov 18, 2019 12:47 am
Forum: Other
Topic: New Pi4 64bit OS
Replies: 4
Views: 6894

Re: New Pi4 64bit OS

version 2 is out
its actually good
but no matter what i do, i just cannot remove the mandarin/chinese references -
ive tried to change locales etc but no avail.
fast system tho!
by puccaso
Thu Oct 17, 2019 5:42 pm
Forum: General discussion
Topic: Dmesg questions
Replies: 2
Views: 372

Re: Dmesg questions

jdb wrote:
Wed Oct 16, 2019 8:07 pm
It's mostly-meaningless spam from the dwc_otg USB driver as it loads. The driver is built-in to the kernel so it is always loaded, and likes to announce its presence with multiple log lines. It serves no purpose on Pi4 as the USB ports are serviced via a PCI-express controller chip.
Thank you!

Go to advanced search