Go to advanced search

by pertm84
Thu Mar 07, 2019 7:35 am
Forum: Camera board
Topic: Memory leak? System "hangs" after some time. (webcamserver)
Replies: 11
Views: 585

Re: Memory leak? System "hangs" after some time. (webcamserver)

RaTTuS wrote:
Wed Mar 06, 2019 4:25 pm
look at a watchdog timer to reboot your RPI if it goes meh
Thanks for the tip! I am about to give up the Pi though, I think I'll just buy an IP-camera and save a whole-lot-of-work. I'll bring home the Pi and do some research on why it is so unstable, maybe I can find another use for it..
by pertm84
Wed Mar 06, 2019 4:14 pm
Forum: Camera board
Topic: Memory leak? System "hangs" after some time. (webcamserver)
Replies: 11
Views: 585

Re: Memory leak? System "hangs" after some time. (webcamserver)

Ok, so everything worked for 9 days, now I get "Network is unreachable" when I try to SSH into it.
This is driving me nuts, because the raspberry is 515 km away from me. :twisted:

I know the router is working, because I have a wifi smartplug on the same network, which is working.
by pertm84
Tue Mar 05, 2019 1:45 pm
Forum: Beginners
Topic: MOTION on stretch... errors
Replies: 6
Views: 2669

Re: MOTION on stretch... errors

I am using Motion 4.0.1 because that is what is available through apt-get. How long til they post the recent update there? There won't be any newer versions of Motion in Raspbian Stretch, other than any security patches that may be required. A later version will be in Raspbian Buster, whenever that...
by pertm84
Tue Mar 05, 2019 12:26 pm
Forum: Camera board
Topic: Memory leak? System "hangs" after some time. (webcamserver)
Replies: 11
Views: 585

Re: Memory leak? System "hangs" after some time. (webcamserver)

Ok, thanks Dougie. At least I can remove that as a probable cause for the hangups ;)
by pertm84
Tue Mar 05, 2019 11:44 am
Forum: Camera board
Topic: Memory leak? System "hangs" after some time. (webcamserver)
Replies: 11
Views: 585

Re: Memory leak? System "hangs" after some time. (webcamserver)

Ok, so I tried looking further into the issue with my hangups, and noticed this using htop:

Image
url to image in case of img fails https://ibb.co/ctV7s3y

So it looks like I have two instances of Motion running? Or am I interpreting the htop wrong?
by pertm84
Tue Mar 05, 2019 11:19 am
Forum: Beginners
Topic: MOTION on stretch... errors
Replies: 6
Views: 2669

Re: MOTION on stretch... errors

I am using Motion 4.0.1 because that is what is available through apt-get. How long til they post the recent update there? Just curious, because I get an error message when Motion starts: Mar 05 12:00:03 raspberrypi systemd[1]: Starting LSB: Start Motion detection... Mar 05 12:00:04 raspberrypi moti...
by pertm84
Mon Mar 04, 2019 1:53 pm
Forum: Camera board
Topic: Memory leak? System "hangs" after some time. (webcamserver)
Replies: 11
Views: 585

Re: Memory leak? System "hangs" after some time. (webcamserver)

Thanks, I've checked the etc/default/locale: # File generated by update-locale LANG=en_US.UTF-8 # LANGUAGE=en_US.UTF-8 I've also tried all the tips on the internet: export LC_ALL=en_US.UTF-8 bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8) In the syslog, I couldn't see anything p...
by pertm84
Mon Mar 04, 2019 12:17 pm
Forum: Camera board
Topic: Memory leak? System "hangs" after some time. (webcamserver)
Replies: 11
Views: 585

Re: Memory leak? System "hangs" after some time. (webcamserver)

OK, it seems there is a problem with my locales. I am not able to install the US utf8. I get: sudo dpkg-reconfigure locales perl: warning: Setting locale failed. perl: warning: Please check that your locale settings: LANGUAGE = "en_US.UTF-8", LC_ALL = "en_US.UTF-8", LC_CTYPE = "UTF-8", LANG = (unset...
by pertm84
Mon Mar 04, 2019 11:37 am
Forum: Camera board
Topic: Memory leak? System "hangs" after some time. (webcamserver)
Replies: 11
Views: 585

Re: Memory leak? System "hangs" after some time. (webcamserver)

Thanks for the quick answer! I'm not quite sure what to look for in dmesg, and everytime I had to do a hard-reset, it looks like the log-files has restarted.What should I look for in dmesg? Also when I tried to type dmesg, I get: -bash: dmesg: command not found I know it must be installed, because w...
by pertm84
Mon Mar 04, 2019 11:11 am
Forum: Camera board
Topic: Memory leak? System "hangs" after some time. (webcamserver)
Replies: 11
Views: 585

Memory leak? System "hangs" after some time. (webcamserver)

Hi I am quite new to this, but I have managed to set up a raspberry pi using stretch as a webserver for uploading stills to my wunderground account through ftp. UFW, fail2ban, apache etc is all set up and working. Also, I set the camera to livestream whenever I want. Everything is working, but somet...
by pertm84
Mon Mar 04, 2019 8:39 am
Forum: General discussion
Topic: UFW Block in=br0 spams logfile
Replies: 7
Views: 342

Re: UFW Block in=br0 spams logfile

Thanks for the Reply, Dougie. I want to keep the actually hack logging on, but all the unnecessary, non-source messages should be filtered out.
I have tried to set the ufw logging to low for now.
by pertm84
Fri Mar 01, 2019 6:32 pm
Forum: General discussion
Topic: UFW Block in=br0 spams logfile
Replies: 7
Views: 342

Re: UFW Block in=br0 spams logfile

I see. I hoped there was some way to filter out those messages from the log files, because they really fill them up. About 1000 lines per day..
by pertm84
Fri Mar 01, 2019 1:15 pm
Forum: General discussion
Topic: UFW Block in=br0 spams logfile
Replies: 7
Views: 342

Re: UFW Block in=br0 spams logfile

Thanks for the reply! Actually, I changed that IP in the post above because I am not too experienced with these security measures and did not want hackers to know my ip. I thought maybe it was my routers IP. The actual data is 224.0.0.1 I find it hard to know what I can safely share from my logfiles...
by pertm84
Fri Mar 01, 2019 12:36 pm
Forum: General discussion
Topic: UFW Block in=br0 spams logfile
Replies: 7
Views: 342

UFW Block in=br0 spams logfile

I have a rpi3 setup as a webcam to monitor my boat using Motion, installed ssh keys, fail2ban, ufw and all that. The pi can run for days and weeks, then it suddenly "hangs". I have tried to use cron to reboot it every 24 hours, but it doesn't seem to work. The pi is run in bridge mode, with eth0 con...
by pertm84
Sun Nov 25, 2018 10:50 am
Forum: Beginners
Topic: Crontab Issue - AKA not working?
Replies: 3
Views: 450

Re: Crontab Issue - AKA not working?

Added python as you suggested, and thank you, that seemed to do the trick! :)
by pertm84
Sat Nov 24, 2018 3:24 pm
Forum: Beginners
Topic: Crontab Issue - AKA not working?
Replies: 3
Views: 450

Crontab Issue - AKA not working?

Hi So I am new to this world of working with cmdline interfaces, and I do not understand it well enough to know what to do (improvise), but I am good at googling the subject and copy/paste the code where it should be. However, I seem to have confused myself with the crontab usage. I am running Raspb...
by pertm84
Sun Oct 28, 2018 9:42 pm
Forum: Camera board
Topic: Motion web stream security
Replies: 12
Views: 28925

Re: Motion web stream security

I'd like to have access only on the config part. I don't mind if people see my stream, but I'd like to secure my settings.

Any knowledge on this?
by pertm84
Fri Oct 26, 2018 10:43 am
Forum: Camera board
Topic: Raspicam+Motion/ffmpeg - Start/Stop stream on website and FTP
Replies: 3
Views: 1279

Re: Raspicam+Motion/ffmpeg - Start/Stop stream on website and FTP

Actually I found the information I needed here: viewtopic.php?t=184577
And with some Googling, I figured out how to create a bash script and make it executable.

Hopefully, someone else will find some help in this in the future.
by pertm84
Wed Oct 24, 2018 12:50 pm
Forum: Camera board
Topic: Streaming the RPi-camera feed
Replies: 2
Views: 1381

Re: Streaming the RPi-camera feed

I have had success with streaming using Motion. It can be embedded on your website using an img tag. The guide I followed https://www.bouvet.no/bouvet-deler/utbrudd/building-a-motion-activated-security-camera-with-the-raspberry-pi-zero Just turn of Motion detection if you dont need it.. EDIT - Remem...
by pertm84
Wed Oct 24, 2018 11:03 am
Forum: Camera board
Topic: Raspicam+Motion/ffmpeg - Start/Stop stream on website and FTP
Replies: 3
Views: 1279

Re: Raspicam+Motion/ffmpeg - Start/Stop stream on website and FTP

see cron */30 * * * * /usr/bin/raspistill -o /tmp/cam.jpg && /usr/bin/scp /tmp/cam.jpg [email protected].ip: Thank you for the reply. Is this all the information I need to transfer the image? I want to upload the image to weather underground: This is their ftp info: Server: webcam.wunderground.com Userna...
by pertm84
Wed Oct 24, 2018 8:41 am
Forum: Camera board
Topic: Raspicam+Motion/ffmpeg - Start/Stop stream on website and FTP
Replies: 3
Views: 1279

Raspicam+Motion/ffmpeg - Start/Stop stream on website and FTP

Hi! I have just installed Raspbian Stretch on Pi 2B, with raspicam and Motion, and it works like a charm! The plan is to use this on a boathouse with a 4G Mobile Router as internet, to keep an eye on our boat during the winterstorms in Norway. However, after running the stream for 5 hours, I noticed...
by pertm84
Tue Oct 23, 2018 5:04 pm
Forum: Camera board
Topic: memory leak?
Replies: 0
Views: 666

memory leak?

Thanks 6by9 and jbeale I changed the script to delete everything in the ram disk (not just jpg's) and put a new sd card into the B+. Hopefully that solves the problem ... Hi! I am new to this, and I am trying to set up my raspberry pi with raspicam (Stretch) to upload images to wunderground. Would ...
by pertm84
Mon Oct 22, 2018 4:48 pm
Forum: Troubleshooting
Topic: [SOLVED] Bridge wlan0 and eth0 - help needed
Replies: 57
Views: 32028

Re: [SOLVED] Bridge wlan0 and eth0 - help needed

What about the computer you are attempting to connect with? It doesn't show up as a dhcp lease? How does it get its IP? Edit: Is your computer connected by ethernet or wifi? I am not sure if I understand what you are asking, but my setup is as follows: iMac (192.168.1.101) is connected through WiFi...
by pertm84
Mon Oct 22, 2018 2:07 pm
Forum: Troubleshooting
Topic: [SOLVED] Bridge wlan0 and eth0 - help needed
Replies: 57
Views: 32028

Re: [SOLVED] Bridge wlan0 and eth0 - help needed

What about the computer you are attempting to connect with? It doesn't show up as a dhcp lease? How does it get its IP? Edit: Is your computer connected by ethernet or wifi? I am not sure if I understand what you are asking, but my setup is as follows: iMac (192.168.1.101) is connected through WiFi...
by pertm84
Mon Oct 22, 2018 1:07 pm
Forum: Troubleshooting
Topic: [SOLVED] Bridge wlan0 and eth0 - help needed
Replies: 57
Views: 32028

Re: [SOLVED] Bridge wlan0 and eth0 - help needed

Is the RPi getting network settings from a dhcp server? Normally, a "connection refused" message indicates there is no ssh daemon running on the destination device, or the firewall is preventing a connection. Are you certain there is no other device using that IP? I just double-checked my wireless ...

Go to advanced search