Go to advanced search

by brandoncheah
Thu Nov 05, 2020 1:42 am
Forum: Networking and servers
Topic: RaspAP WiFi Client AP Mode number of Clients connected
Replies: 7
Views: 372

Re: RaspAP WiFi Client AP Mode number of Clients connected

Yeah.. But I saw the comments of other people mentioning that they can at least have a few devices connected at the same time, (3 devices connected to the AP is sufficient for me). But I can only connect one...which is very weird, So I would hoping if there is any tweaks can be done to achieve at le...
by brandoncheah
Wed Nov 04, 2020 9:38 am
Forum: Networking and servers
Topic: RaspAP WiFi Client AP Mode number of Clients connected
Replies: 7
Views: 372

RaspAP WiFi Client AP Mode number of Clients connected

I am working on Raspberry Pi 4B (1 GB RAM), installed RaspAP to configure WiFi AP Client. Successfully configured WiFi AP client mode, SSID is also broadcasted, tried to connect with my laptop/phone able to establish connection with internet. However, when i try to connect a second device to the hot...
by brandoncheah
Wed Nov 04, 2020 4:50 am
Forum: Networking and servers
Topic: RaspAP WiFi Client AP Mode only 1 device can be connected
Replies: 0
Views: 59

RaspAP WiFi Client AP Mode only 1 device can be connected

Currently using Raspberry Pi Model 4B (1 GB RAM) and trying to configure it to be a hotspot and allow other raspberry pi connect to it. I install RaspAP from this command: curl -sL https://install.raspap.com | bash Also followed this guide to setup WiFi Client AP Mode (http://matnet.my/blog/2020/01/...
by brandoncheah
Tue Nov 03, 2020 3:01 am
Forum: Advanced users
Topic: OpenSC Library Smartcard Reader: Transmit Failed
Replies: 0
Views: 112

OpenSC Library Smartcard Reader: Transmit Failed

I am trying to read data from our Malaysia Identification card (MyKAD) a type of smart card. Using OpenSC library i manage to retrieve the data from the smartcard using APDU: https://github.com/OpenSC/OpenSC/wiki/Malaysian-MyKAD I installed using sudo apt-get install -y opensc , although opensc show...
by brandoncheah
Mon Oct 05, 2020 9:08 am
Forum: Beginners
Topic: Connecting Servo Motor and LEDs to Raspberry Pi
Replies: 6
Views: 197

Re: Connecting Servo Motor and LEDs to Raspberry Pi

Well there might be your problem, the LED needs a limiting resistor, it hasn't got one so is drawing too much current, luckily the power supply is probably dropping its voltage before the LED turns into a firework. You need a resistor of about 6 ohms in series with the LED, it can be higher but not...
by brandoncheah
Mon Oct 05, 2020 3:07 am
Forum: Beginners
Topic: Connecting Servo Motor and LEDs to Raspberry Pi
Replies: 6
Views: 197

Re: Connecting Servo Motor and LEDs to Raspberry Pi

LED specs: Voltage: 3.2-3.4V Current: 350MA Wavelength: 100-110LM Switching the negative rail is not as good idea when you are passing signals, the servo expects its -ve to be at the same voltage as the -ve on the Pi but you have a mosfet in between - admittedly the voltage drop across the mosfet sh...
by brandoncheah
Mon Oct 05, 2020 2:26 am
Forum: Beginners
Topic: Connecting Servo Motor and LEDs to Raspberry Pi
Replies: 6
Views: 197

Re: Connecting Servo Motor and LEDs to Raspberry Pi

yes I added MOSFET acting as a switch to turn on/off the servo and LED.

Please see the image for my setup here: https://ibb.co/F5Rxf8d

Even 5A is sufficient, but I don't know why it is not able to power my servo when the LED is used together in the circuit.
by brandoncheah
Sat Oct 03, 2020 3:08 am
Forum: Beginners
Topic: Connecting Servo Motor and LEDs to Raspberry Pi
Replies: 6
Views: 197

Connecting Servo Motor and LEDs to Raspberry Pi

Hi guys, I am connecting a Servo MG995 and 1W White LED to my Raspberry Pi with an external Switching Power Supply Unit 5V/5A. Also having a MOSFET as a switch controlled by the GPIO. I want to have the LED and Servo working at the same time but its not working well I think is because insufficient v...
by brandoncheah
Fri Aug 23, 2019 4:36 am
Forum: Advanced users
Topic: Speech Recognition with i2S microphone
Replies: 3
Views: 1640

Re: Speech Recognition with i2S microphone

*Update* I think i found out what is going wrong, it might be Pyaudio microphone selection. I've tried to record using PyAudio library, where I've specified the index number, when chosing index number 3 4 5, the sound recorded is very soft and hard to listen, that is why the voice recognition couldn...
by brandoncheah
Thu Aug 22, 2019 3:36 am
Forum: Advanced users
Topic: Speech Recognition with i2S microphone
Replies: 3
Views: 1640

Speech Recognition with i2S microphone

Currently working on RPi 3B+, Raspbian Buster. Installed speech recognition library: https://pypi.org/project/SpeechRecognition/ Hardware setup for audio and microphone: Audio Amp: MAX98357 (i2S) Microphone: SPH0645LM4H (i2S) Followed the guide on : https://www.hackster.io/maremoto/snips-assistant-f...
by brandoncheah
Mon Jul 29, 2019 8:54 am
Forum: Networking and servers
Topic: Expose FLASK web server API to the internet
Replies: 3
Views: 807

Expose FLASK web server API to the internet

I've created RESTful API using Flask and I can access the API in local network. In order for any network to access this API, I understand I need to expose this Flask web server to the internet. I would not like to configure port forwarding on my router, so this method is put aside. I tried using NGR...
by brandoncheah
Tue Jul 02, 2019 3:32 am
Forum: Troubleshooting
Topic: I2S mems microphone (SPH0645LM4H) installation issue : __sanitizer_cov_trace_pc
Replies: 2
Views: 1031

Re: I2S mems microphone (SPH0645LM4H) installation issue : __sanitizer_cov_trace_pc

Hi, I have also the same issue during (make -C /lib/modules/$(uname -r )/build M=$(pwd) modules) step:
WARNING "__sanitizer_cov_trace_pc" [/home/pi/rpi-i2s-audio/my_loader.ko] undefined!

Anybody know what's going on?
by brandoncheah
Thu May 02, 2019 10:09 am
Forum: Advanced users
Topic: MQ Gas sensor wire connection
Replies: 3
Views: 897

MQ Gas sensor wire connection

I've connected my circuit as shown in the diagram I have one issue which I am concern about the Analog Output from the Gas sensor is 0-5V, is it fine to connect to the MCP3008 ADC A0 pin? I've read online, some guides says it's Ok to straight connect, some says need to regulate the voltage to 3.3V A...
by brandoncheah
Fri Apr 26, 2019 5:58 am
Forum: Advanced users
Topic: LM386 Audio Amp Module Producing buzzing/cracking noise
Replies: 6
Views: 1682

LM386 Audio Amp Module Producing buzzing/cracking noise

I've connected my circuit as you can see in the image below: LM386 module: https://www.lelong.com.my/lm386-chip-20-gain-audio-amplifier-module-sgrobot-196954225-2020-09-Sale-P.htm It produces white noise, cracking/buzzing when its connected to the 5V and GND GPIO pins on the RPi I've tried to use an...
by brandoncheah
Sat Mar 02, 2019 2:27 am
Forum: Advanced users
Topic: Linphone console application Segmentation fault
Replies: 4
Views: 1257

Re: Linphone console application Segmentation fault

I couldn't confirm that whether this is expected/normal, because sometimes this error pops out and sometimes it doesn't.
Besides, even though previously this errors appears, I am still able to dial outgoing calls without any problem, therefore I always ignore these errors
by brandoncheah
Fri Mar 01, 2019 9:12 am
Forum: Advanced users
Topic: Linphone console application Segmentation fault
Replies: 4
Views: 1257

Linphone console application Segmentation fault

I've been using linphone console application (linphonec) in the RPi 3 B+ and it works fine until yesterday, when an outgoing call is being dialed for about 2seconds, it shows segmentation fault and exits the console application. tried to debug using gdb and I get the following messages: gdb ./linpho...
by brandoncheah
Fri Mar 01, 2019 6:35 am
Forum: Advanced users
Topic: LiPo Battery for Raspberry Pi Zero W
Replies: 6
Views: 5262

Re: LiPo Battery for Raspberry Pi Zero W

Thanks for the advice, I have another quick question. Is there any alternatives to this module from Adafruit, Powerboost 1000C: https://learn.adafruit.com/adafruit-powerboost-1000c-load-share-usb-charge-boost/overview It looks like this module can solve most of my problem which are: 1. Charging and ...
by brandoncheah
Thu Feb 28, 2019 1:58 am
Forum: Advanced users
Topic: LiPo Battery for Raspberry Pi Zero W
Replies: 6
Views: 5262

Re: LiPo Battery for Raspberry Pi Zero W

I've connected the circuit (image in the attachments), isit normal for the charger module protection to heat up when I am charging the battery? Because when I charge the battery the charger module protection became so hot and I am afraid it would blow up or something. I am using normal copper wires ...
by brandoncheah
Tue Feb 26, 2019 3:59 am
Forum: Advanced users
Topic: problem with linphone
Replies: 6
Views: 1949

Re: problem with linphone

Go to your /home/pi folder and show hidden files, then copy "linphone.db" file and paste into /home/pi/.local/share/linphone
by brandoncheah
Mon Feb 18, 2019 5:04 am
Forum: Advanced users
Topic: LiPo Battery for Raspberry Pi Zero W
Replies: 6
Views: 5262

LiPo Battery for Raspberry Pi Zero W

I want to power my RPi Zero W with a battery pack (1300mAh, 3.7V). Can somebody tell me whether this setup is correct as I don't want to damage my Raspberry Pi. I will be using a Protection & charging board TP4056 and a MT3608 Step-Up Boost converter. The battery pack will connect to TP4056, TP4056 ...
by brandoncheah
Thu Dec 13, 2018 8:01 am
Forum: Advanced users
Topic: Huawei E173 3G Dongle GSM calls
Replies: 1
Views: 974

Huawei E173 3G Dongle GSM calls

I have a Huawei E173 3G dongle up and working fine and is able to connect 3G internet via sakis3G and UMTSKeeper, able to send and receive SMS. However, the AT command (ATD) for dialing another phone number keeps giving me ERROR, I've tried ATD****, ATD*****; ATDT****, where all gives me the same ER...
by brandoncheah
Thu Nov 29, 2018 6:51 am
Forum: Advanced users
Topic: Prioritizing Wi-Fi (wlan0) over 3G USB Dongle (ppp0) internet connectivity
Replies: 2
Views: 3405

Re: Prioritizing Wi-Fi (wlan0) over 3G USB Dongle (ppp0) internet connectivity

I think this is what you need. ip route show ip route del default ip route add default via 192.168.1.1 dev wlan0 Just change device to wlan0 / eth0 or which ever interface you want to use and set the IP address to be the gateway of that network interface. FYI It's not permanent, meaning you'd have ...
by brandoncheah
Wed Nov 28, 2018 9:31 am
Forum: Advanced users
Topic: Prioritizing Wi-Fi (wlan0) over 3G USB Dongle (ppp0) internet connectivity
Replies: 2
Views: 3405

Prioritizing Wi-Fi (wlan0) over 3G USB Dongle (ppp0) internet connectivity

I just bought a 3G USB Dongle (Huawei E173) and successfully configured it to have 3G internet connection using sakis3G and also UMTSkeeper to keep my 3G connection alive whenever any 3G disconnection happens. I have both 3G and Wi-Fi connected at the same time. I want to only use 3G connection only...
by brandoncheah
Thu Oct 25, 2018 1:29 am
Forum: Advanced users
Topic: Automate Google Hangouts in Raspberry Pi?
Replies: 3
Views: 3041

Re: Automate Google Hangouts in Raspberry Pi?

Yes, I've tested it out on the chromium browser at "hangouts.google.com" and it works It is very laggy and delay about 5~10seconds I was wondering if there is any method to use google hangouts without using the chromium browser version? I mean like a google hangout console application for python/RPi...
by brandoncheah
Wed Oct 24, 2018 4:00 am
Forum: Advanced users
Topic: Automate Google Hangouts in Raspberry Pi?
Replies: 3
Views: 3041

Automate Google Hangouts in Raspberry Pi?

I am thinking of initiating a video call to a user using Google Hangouts when a button is pressed.

Is there any way to automate Google Hangouts video calling in RPi 3?

Go to advanced search