Go to advanced search

by andalus
Tue Dec 18, 2018 8:33 pm
Forum: Python
Topic: ADC of different bit resolution than 10
Replies: 2
Views: 272

Re: ADC of different bit resolution than 10

These are different chips by different manufacturers with different interfaces. I would not expect MCP3XXX code to be relevant to an ADC0832. Why not either write your own code or google for Python code for the ADC0832? Thanks for your reply Joan. Actually I have my own code for ADC0832. I translat...
by andalus
Tue Dec 18, 2018 7:55 pm
Forum: Python
Topic: ADC of different bit resolution than 10
Replies: 2
Views: 272

ADC of different bit resolution than 10

Hello everyone. I have an ADC (ADC0832) which I am trying to use with my RPi. This is 8-bits ADC. I am trying to use the gpiozero library to use this device. If I use the normal MCP300x class it gives wrong values (simply because the class waits for 10 bits while my ADC converts 8 bits only). I am l...
by andalus
Tue Dec 18, 2018 1:57 pm
Forum: Beginners
Topic: Ultrasonic Sensor (DistanceSensor) not working
Replies: 8
Views: 543

Re: Ultrasonic Sensor (DistanceSensor) not working

The breadboard gotcha? https://www.raspberrypi.org/forums/viewtopic.php?f=91&t=83372&p=589714#p635787 Thank you my friend. You know what, although I tested the VCC and GND with my multimeter during the experiment (from sensor side, and both were fine), but I I suspect this has something to do with ...
by andalus
Tue Dec 18, 2018 1:51 pm
Forum: Beginners
Topic: Ultrasonic Sensor (DistanceSensor) not working
Replies: 8
Views: 543

Re: Ultrasonic Sensor (DistanceSensor) not working

Just to make you aware all distances outside the sensor limits have to be ignored 2cm - 4m. When the object isn't square to the sensor the sonic beam gets reflected on a huge journey. Also raspberry pi may switch you job out in the critical section i.e. timing the echo Thank you for your comment. Y...
by andalus
Wed Dec 05, 2018 11:07 am
Forum: General discussion
Topic: Pinout command is not detecting RPi 3B+ board
Replies: 2
Views: 402

Re: Pinout command is not detecting RPi 3B+ board

DirkS wrote:
Wed Dec 05, 2018 6:19 am
It has been changed, but the new version has not yet been released.
See https://github.com/RPi-Distro/python-gp ... issues/663
Thank you. Its good to know at least that there is nothing wrong with my board :)
I can wait for the next version of pinout.
by andalus
Wed Dec 05, 2018 1:47 am
Forum: General discussion
Topic: My Pi didn’t connect to my WiFi repeater
Replies: 3
Views: 346

Re: My Pi didn’t connect to my WiFi repeater

Hi, are you repeating the same SSID like the original AP? or different one? Make sure your config on the repeater exactly matches the original AP (including security config). For example, if security in original AP says WPA+WPA2, then use the same thing on the range extender. If you chose anything d...
by andalus
Wed Dec 05, 2018 12:06 am
Forum: General discussion
Topic: Pinout command is not detecting RPi 3B+ board
Replies: 2
Views: 402

Pinout command is not detecting RPi 3B+ board

Hello, I bought RPi 3B+ very recently. Pinout command doesn't recognize the board. (see attachments) For example, board model is not mentioned. WiFi and Bluetooth mentioned as "False" although Wi-Fi is working fine (I didn't test BT but I think it is also fine). I tried to update gpiozero (now its o...
by andalus
Mon Dec 03, 2018 11:48 am
Forum: Beginners
Topic: Ultrasonic Sensor (DistanceSensor) not working
Replies: 8
Views: 543

Re: Ultrasonic Sensor (DistanceSensor) not working

Thank you gentlemen. I am fully aware about what you are taking about. but It didn't work either for me UNTIL I removed the sensor module from the breadboard! I was using the module installed on the breadboard directly. That didn't work! I removed it and used it connected with wires, it worked much ...
by andalus
Mon Dec 03, 2018 1:02 am
Forum: Beginners
Topic: Ultrasonic Sensor (DistanceSensor) not working
Replies: 8
Views: 543

Ultrasonic Sensor (DistanceSensor) not working

Hello guys, My first time trying HC-SR04. I used the tutorial here for gpiozero: https://projects.raspberrypi.org/en/projects/physical-computing/14 I ended up with the following message: /usr/lib/python3/dist-packages/gpiozero/input_devices.py:779: DistanceSensorNoEcho: no echo received warnings.war...
by andalus
Sun Dec 02, 2018 11:36 pm
Forum: Python
Topic: analog value detection in RPi.GPIO vs gpiozero
Replies: 2
Views: 431

Re: analog value detection in RPi.GPIO vs gpiozero

Ok I have just looked at his blog and he writes his own software spi fuctions. The RPi has it's own hardware spi and the RPi already has a python library to use them. This is a good place to read first to start to understand it all https://learn.sparkfun.com/tutorials/python-programming-tutorial-ge...
by andalus
Sun Dec 02, 2018 3:36 pm
Forum: Python
Topic: analog value detection in RPi.GPIO vs gpiozero
Replies: 2
Views: 431

analog value detection in RPi.GPIO vs gpiozero

Hello everybody. I was translating the code of using an ADC chip from RPi.GPIO to gpiozero where I found this piece of code that I don't exactly understand if the translation reflects the same meaning: the original piece of code is here (if there is a signal on the input pin, then apply bitwise OR w...
by andalus
Sun Dec 02, 2018 2:36 pm
Forum: Python
Topic: ADC08322 with gpiozero
Replies: 2
Views: 511

Re: ADC0832 with gpiozero

Here is an article on controlling the MCP3008 using python on the RPi: https://learn.adafruit.com/raspberry-pi-analog-to-digital-converters/mcp3008 . I hope this is what you are looking for. Thank you very much. The one you gave me is not bad. but it is specific for MCP3008 which I found from my re...
by andalus
Sat Dec 01, 2018 8:40 pm
Forum: Python
Topic: ADC08322 with gpiozero
Replies: 2
Views: 511

ADC08322 with gpiozero

Hello gentlemen. summary of the post: I want to know the steps that ADC chip follows to translate from analog to digital. That will help me writing the code in python to get it to work with gpiozero. I want to use ADC0832 (top-view image and datasheet link are below) with Raspberry Pi, and more spec...
by andalus
Wed Nov 07, 2018 12:18 am
Forum: Troubleshooting
Topic: gpiozero button issue with error "Failed to add edge detection"
Replies: 1
Views: 183

gpiozero button issue with error "Failed to add edge detection"

Hi all, I had started (finally) to getting deeper to gpiozero library so I started to test different scenarios and do things in different ways when I encountered a problem with instances of "Button" object! the first time I assign a pin to a button it works. second time (sometimes maybe third time, ...
by andalus
Tue Nov 06, 2018 1:39 pm
Forum: Off topic discussion
Topic: Package on Package memory animation
Replies: 3
Views: 2540

Re: Package on Package memory animation

Hello my friend. I was looking for a PoP animation when I came across your thread. :) But the link you provided seems broken :( I understand its a long time since you posted this, but if you can update the link that would be grateful because I tried to look for an animation online but I couldn't fin...
by andalus
Tue Nov 06, 2018 1:12 pm
Forum: General discussion
Topic: Where is BroadCom chip on RPi Zero W?
Replies: 4
Views: 435

Re: Where is BroadCom chip on RPi Zero W?

Well understood. Thank you gentlemen. time to explore further about PoP technology :)
by andalus
Mon Nov 05, 2018 10:42 pm
Forum: General discussion
Topic: Where is BroadCom chip on RPi Zero W?
Replies: 4
Views: 435

Where is BroadCom chip on RPi Zero W?

Hello. Forgive my ignorance, but I was explaining the hardware on the RPi to some new-to-tech people where I was stuck showing them the broadcom chip on the Raspberry Pi Zero W :) I could show them the BCM chip on RPi 3B. but when I tried it for RPi Zero W it wasn't visible (or maybe, wasn't obvious...
by andalus
Sun Oct 21, 2018 2:31 pm
Forum: Python
Topic: Stop PiCamera preview
Replies: 7
Views: 17972

Re: Stop PiCamera preview

I've frequently had problems with this, compounded by random clicking meaning IDLE no longer has focus. Luckily if you are on the latest version of Raspbian, there's a simple solution. Hold down ctrl+alt+t which will open up a terminal that has focus, although hidden behind the preview. Then blindl...
by andalus
Wed Oct 03, 2018 6:28 pm
Forum: RISCOS
Topic: Ethernet on RISCOS not detectable
Replies: 10
Views: 6011

Re: Ethernet on RISCOS not detectable

It is working now. on RISCOS forums they said that USB-to-Ethernet adapter that i see on my settings is the Ethernet. but because they Ethernet on the RPi 3 is USB based then that's why it appears this way. Another point of confusion that happened with me is, after the RISCOS fails to get an IP addr...
by andalus
Sun Sep 30, 2018 8:56 pm
Forum: RISCOS
Topic: Ethernet on RISCOS not detectable
Replies: 10
Views: 6011

Re: Ethernet on RISCOS not detectable

Hi, I am running RISCOS for my first time. I tempered a bit with the OS and its windows, but it doesn't detect my Ethernet adapter. It has only a USB-to-Ethernet adapter mentioned in its networking. Anybody knows how may I let the RISC OS detect the ethernet adapter? I am using Raspberry Pi 3. Best...
by andalus
Sun Sep 30, 2018 8:56 pm
Forum: RISCOS
Topic: Ethernet on RISCOS not detectable
Replies: 10
Views: 6011

Re: Ethernet on RISCOS not detectable

bulldozer wrote:
Thu Sep 27, 2018 2:10 pm
Also an interresting piece at http://www.riscos.org/networking/riscos.html
Also perhaps of interrest : https://www.riscosopen.org/wiki/documen ... Networking
Thanks. I've looked into those posts but they assume I have the ethernet card icon. I don't.
by andalus
Sun Sep 30, 2018 7:41 pm
Forum: RISCOS
Topic: Ethernet on RISCOS not detectable
Replies: 10
Views: 6011

Re: Ethernet on RISCOS not detectable

Hi what RISCOS are you using and which Pi you are using. I have an out of the box Pi 3B and a SD card from ROOL and it works quite nicely. I am using RPi 3B. I installed the OS from the website and put it on the SD card. The OS opens with no problem. but it seems it can't detect or see the ethernet...
by andalus
Wed Sep 26, 2018 6:24 pm
Forum: RISCOS
Topic: Ethernet on RISCOS not detectable
Replies: 10
Views: 6011

Re: Ethernet on RISCOS not detectable

would anybody jump to help? :(
by andalus
Fri Sep 14, 2018 11:28 pm
Forum: RISCOS
Topic: Ethernet on RISCOS not detectable
Replies: 10
Views: 6011

Ethernet on RISCOS not detectable

Hi, I am running RISCOS for my first time. I tempered a bit with the OS and its windows, but it doesn't detect my Ethernet adapter. It has only a USB-to-Ethernet adapter mentioned in its networking. Anybody knows how may I let the RISC OS detect the ethernet adapter? I am using Raspberry Pi 3. Best,...

Go to advanced search