Go to advanced search

by felipe.o.gutierrez
Wed Oct 24, 2018 7:34 am
Forum: Advanced users
Topic: Update RPi and the kernel modules
Replies: 2
Views: 867

Re: Update RPi and the kernel modules

I solved by reverting back to the previous kernel (https://www.raspberrypi.org/documentati ... pdating.md)
by felipe.o.gutierrez
Tue Oct 23, 2018 11:20 am
Forum: Advanced users
Topic: Update RPi and the kernel modules
Replies: 2
Views: 867

Update RPi and the kernel modules

Hi, I am using i2ctools to simulate sensors on Raspberry Pi. After enable i2c protocol on the RPi I use the commands below to get information from the kernel and install a module. sudo make -C /lib/modules/$(uname -r)/build M=$(pwd) clean sudo make -C /lib/modules/$(uname -r)/build M=$(pwd) modules ...
by felipe.o.gutierrez
Fri Sep 07, 2018 7:00 am
Forum: Beginners
Topic: C program for HC-SR04 ultrasonic sensor is not showing the correct distance
Replies: 1
Views: 1785

C program for HC-SR04 ultrasonic sensor is not showing the correct distance

I have a raspberry Pi Zero with the AlphaBot2 which has the HC-SR04 ultrasonic sensor. The implementation using Python works well. I want to implement in C because I need to bind it with another program also in C and for optimization reasons. The first thing that I noticed is the Python code uses th...
by felipe.o.gutierrez
Tue Aug 21, 2018 10:53 am
Forum: Advanced users
Topic: Waveshare AlphaBot2
Replies: 9
Views: 3271

Re: Waveshare AlphaBot2

Hi @tomcat53. I am not getting the AlphaBot2 to work even manually. Do you know how to troubleshoot the python software?
If you could help with this thread (https://www.raspberrypi.org/forums/view ... 7&t=220922) I appreciate very much.

Thanks,
Felipe
by felipe.o.gutierrez
Tue Aug 21, 2018 7:47 am
Forum: Automation, sensing and robotics
Topic: AlphBot2 with Raspberry Pi Zero is not working.
Replies: 0
Views: 446

AlphBot2 with Raspberry Pi Zero is not working.

Hi all, I bought the AlphaBot2 Pi Zero and I am following the wiki https://www.waveshare.com/wiki/AlphaBot2-PiZero to put it to work. I installed all the libraries pointed here (https://www.waveshare.com/wiki/Libraries_Installation_for_RPi) and I ensure that the command "gpio readall" is working pro...
by felipe.o.gutierrez
Tue Aug 07, 2018 8:39 am
Forum: Troubleshooting
Topic: GPSD - NEO-6M - Jessie
Replies: 25
Views: 4932

Re: GPSD - NEO-6M - Jessie

I could probably write one but there is not much to it. It goes a little like this Install Jessie... Boot check it all working. sudo raspi-config, Do as detailed above Off to console, on to serial. Shutdown Fit UART Neo6 find to gnd to GND, +ve to 5V, TX to RX and vise versa. (Physical pin 4,6,8,10...

Go to advanced search