Go to advanced search

by RealistikDash
Wed Jul 11, 2018 6:31 pm
Forum: Troubleshooting
Topic: Git clone and apt not working.
Replies: 15
Views: 1134

Re: Git clone and apt not working.

The behaviour of your Pi seems good. The protocol http works fine inside your LAN but it fails when you try to access to the internet. The default route looks good. The gateway (your router, 192.168.0.1) is apparently dropping your http connections to the Internet. I believe that the problem is due...
by RealistikDash
Mon Jul 09, 2018 4:30 pm
Forum: Troubleshooting
Topic: Git clone and apt not working.
Replies: 15
Views: 1134

Re: Git clone and apt not working.

ping -c25 google.com wget http://downloads.raspberrypi.org/raspbian_lite_latest -O /dev/null wget https://downloads.raspberrypi.org/raspbian_lite_latest -O /dev/null Hi, it still timeouts. Hmmm. Including ping?. I believe that the problem could be related to your router in such a way that it is fil...
by RealistikDash
Sat Jul 07, 2018 5:14 pm
Forum: Troubleshooting
Topic: Git clone and apt not working.
Replies: 15
Views: 1134

Re: Git clone and apt not working.

lmarmisa wrote:
Sun Jul 01, 2018 6:22 am
The ICMP protocol (ping) works but https does not. What about http?:

Code: Select all

ping -c25 google.com
wget http://downloads.raspberrypi.org/raspbian_lite_latest -O /dev/null
wget https://downloads.raspberrypi.org/raspbian_lite_latest -O /dev/null
Hi, it still timeouts.
by RealistikDash
Sat Jun 30, 2018 5:56 pm
Forum: Troubleshooting
Topic: Git clone and apt not working.
Replies: 15
Views: 1134

Re: Git clone and apt not working.

Your network seems to work fine at this time. But according to your comments, two completely independent commands are not completed due to network problems: sudo apt-get update git clone xxxx Is your RPi connected to the network via wifi?. Check if this command is completed correctly: wget https://...
by RealistikDash
Sat Jun 30, 2018 2:13 pm
Forum: Troubleshooting
Topic: Git clone and apt not working.
Replies: 15
Views: 1134

Re: Git clone and apt not working.

Try these commands and post the outputs: ip route cat /etc/resolv.conf ping -c4 8.8.8.8 ping -c4 google.com The output I get is this: [email protected]:/home/pi# ip route default via 192.168.0.1 dev wlan0 src 192.168.0.111 metric 303 192.168.0.0/24 dev wlan0 proto kernel scope link src 192.168.0.111...
by RealistikDash
Sat Jun 30, 2018 2:10 pm
Forum: Troubleshooting
Topic: Git clone and apt not working.
Replies: 15
Views: 1134

Re: Git clone and apt not working.

Have you been playing with your dns settings? It seems that incoming connections are fine, whilst outgoing are failing. What's the output of cat /etc/resolv.conf? The only thing I've really done is set a static local IP which shouldn't affect those. The output I get is # Generated by resolvconf nam...
by RealistikDash
Fri Jun 29, 2018 11:02 pm
Forum: Troubleshooting
Topic: Git clone and apt not working.
Replies: 15
Views: 1134

Git clone and apt not working.

Hi there, I have recently been having issues with my Pi. I can't seem to do anything download related on my pi. When trying to do apt update, I get this: Err:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease Cannot initiate the connection to raspbian.raspberrypi.org:80 (2a00:1098:0:80:100...
by RealistikDash
Wed Jun 06, 2018 9:23 pm
Forum: Beginners
Topic: Best 64GB SD card for use with Raspberry Pi 3 Model B
Replies: 16
Views: 25247

Re: Best 64GB SD card for use with Raspberry Pi 3 Model B

I personally have had bad experience with the SanDisk Ultras. One of them just smoked off and died. It is unreadable. I heard the Samsung Evos are good.

Go to advanced search