Go to advanced search

by dewille
Sun Mar 01, 2020 12:49 pm
Forum: Troubleshooting
Topic: First (and all subsequent) boot fails
Replies: 4
Views: 291

Re: First (and all subsequent) boot fails

I just upgraded one package (plexmediaserver) and after reboot have the same kernel panic error - not syncing...... 07f00 I tried to run single mode and uninstall plex but I can't because of this kernel panic. There is nothing more to do/fix except flash raspbian again and set up whole environment I...
by dewille
Wed Jun 13, 2018 12:14 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: RPI Zero, Microphone, PCM1808 ADC
Replies: 1
Views: 1797

RPI Zero, Microphone, PCM1808 ADC

I've been given all devices (mike,adc with resistors pulled out and pi0) and asked to configure RPi Zero with microphone via GPIO. ADC module is "CJMCU-1808" purchased on Ali https://goo.gl/yBrr2G and it's based on PCM1808. https://i.imgur.com/trHVfhk.jpg https://i.imgur.com/Un1AfAj.jpg https://i.im...
by dewille
Tue May 15, 2018 1:45 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: RTC module and I2C-0 problem
Replies: 23
Views: 7366

Re: RTC module and I2C-0 problem

I did't mention cuz I didn't think it was relevant. OK, it's clear now. Thanks for your help!
by dewille
Tue May 15, 2018 1:13 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: RTC module and I2C-0 problem
Replies: 23
Views: 7366

Re: RTC module and I2C-0 problem

OK another problem just pop up.... I'm not going to create new topic because this issue is related to current one. RTC module is working perfect on I2C-0 till I run raspivid process.... pi@raspberrypi:~ $ dmesg | grep rtc [ 30.338679] rtc-ds1307 0-0068: registered as rtc0 pi@raspberrypi:~ $ i2cdetec...
by dewille
Mon May 14, 2018 1:21 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: RTC module and I2C-0 problem
Replies: 23
Views: 7366

Re: RTC module and I2C-0 problem

Thanks a lot!!! It works now! pi@raspberrypi:~ $ sudo hwclock -r 2018-05-14 15:19:27.916061+0200 however on I2C-0 I also get 'UU' instead of '68' but RTC module is working great anyway pi@raspberrypi:~ $ i2cdetect -y 0 0 1 2 3 4 5 6 7 8 9 a b c d e f 00: -- -- -- -- -- -- -- -- -- -- -- -- -- 10: --...
by dewille
Mon May 14, 2018 10:58 am
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: RTC module and I2C-0 problem
Replies: 23
Views: 7366

Re: RTC module and I2C-0 problem

yes I already pulled them out. They're 2.4 kOhm 3.3V

Image
by dewille
Fri May 11, 2018 6:01 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: RTC module and I2C-0 problem
Replies: 23
Views: 7366

Re: RTC module and I2C-0 problem

yes I put this line already into /boot/config.txt RTC module is working on i2c-1. i2c-0 is enabled as ALT0 and it even detects that some device is connected into but it doesn't communicate with it I guess This GPIO (27 & 28) are described as These pins are generally reserved for i2c communication wi...
by dewille
Fri May 11, 2018 2:50 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: RTC module and I2C-0 problem
Replies: 23
Views: 7366

RTC module and I2C-0 problem

I got DS3231 RTC module and Pi Zero which I need to connect to I2C-0. It works well connected to IC2-1 pi@pi:~ $ sudo hwclock 2018-05-11 15:54:00.210619+0200 it register well pi@pi:~ $ dmesg | grep rtc [ 21.213237] rtc-ds1307 1-0068: registered as rtc0 shows up in devices pi@pi:~ $ ls -la /dev/rtc* ...

Go to advanced search