Go to advanced search

by g3vbv
Mon Aug 29, 2016 8:18 pm
Forum: Raspbian
Topic: Touch on 7 inch Waveshare not working with Pi 2
Replies: 0
Views: 859

Touch on 7 inch Waveshare not working with Pi 2

I had no problem with Ubuntu. xinput_calibrator --list only sees the keyboard lsusb always showed the D-WAV Scientific Co., Ltd device but there seemed to be no driver in the released kernel so i rebuilt and installed the 4.4.19-v7+ kernel from git sources - local build. [email protected]:/usr/src/li...
by g3vbv
Thu Mar 19, 2015 2:45 am
Forum: Troubleshooting
Topic: /lib/modules/3.18.9+ disappeared
Replies: 5
Views: 974

Re: /lib/modules/3.18.9+ disappeared

Thanks, that got them back. *** Downloading specific firmware revision (this will take a few minutes) % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 168 0 168 0 0 282 0 --:--:-- --:--:-- --:--:-- 372 100 43.5M 100 43.5M 0 0 708k 0 0:01:02 0:01...
by g3vbv
Wed Mar 18, 2015 8:15 pm
Forum: Troubleshooting
Topic: /lib/modules/3.18.9+ disappeared
Replies: 5
Views: 974

/lib/modules/3.18.9+ disappeared

The Pi B booted without modules. It had been fine before. I ran "rpi-update" which updated the kernel and firmware. The next reboot was OK and /lib/modules/3.18.9+ existed. Next time I powered on it had disappeared. [email protected]:~# ls /lib/modules/ 3.12.33+ 3.18.7+ 3.18.7-v7+ 3.18.8+ 3.18.8-v7+ ...
by g3vbv
Fri Feb 27, 2015 9:19 pm
Forum: Raspbian
Topic: eGalax Touch does not work after update of Raspberry Pi B
Replies: 6
Views: 2135

Re: eGalax Touch does not work after update of Raspberry Pi

Thanks, I missed that earlier.
rpi-update fixed it.
by g3vbv
Fri Feb 27, 2015 10:47 am
Forum: Raspbian
Topic: eGalax Touch does not work after update of Raspberry Pi B
Replies: 6
Views: 2135

eGalax Touch does not work after update of Raspberry Pi B

Previous kernel 3.12.33+ used to work. kernel 3.18.7+ display is OK, but touch does not work. [email protected]:/lib/modules# uname -r 3.18.7+ [email protected]:/lib/modules/3.18.7-v7+# zgrep CONFIG_INPUT_TOUCHSCREEN /proc/config.gz CONFIG_INPUT_TOUCHSCREEN=y [email protected]:~# zgrep EGALAX /proc/con...
by g3vbv
Tue Aug 28, 2012 2:05 am
Forum: Raspbian
Topic: building qt5 on the board itself
Replies: 5
Views: 8040

Re: building qt5 on the board itself

I downloaded qt50-snapshot from the repo but it only contains one file. I also tried to build on Ubuntu x86_64 but it failed part of the way through and I haven't had time to get back to it. I wonder if someone who has been able to successfully build qt5 for raspbian can supply built packages or an ...
by g3vbv
Tue Aug 14, 2012 8:29 pm
Forum: Raspbian
Topic: No sound from on-board card
Replies: 10
Views: 7842

Re: No sound from on-board card

paplay /usr/share/sounds/alsa/Front_Center now plays the full " Front Center" while aplay only plays "<buzz> Center".
by g3vbv
Tue Aug 14, 2012 8:14 pm
Forum: Raspbian
Topic: No sound from on-board card
Replies: 10
Views: 7842

Re: No sound from on-board card

I had some debian wheezy repos commented out in /etc/apt/sources.list. After restoring them I was able to reinstall pulseaudio and friends.
I'd still like qt5 qmake as my application needs qt5 so it can be built to use the GPU for the math intensive bits. Qt4 has issues with sound.
by g3vbv
Mon Aug 13, 2012 8:10 pm
Forum: Raspbian
Topic: No sound from on-board card
Replies: 10
Views: 7842

Re: No sound from on-board card

[email protected]:~# apt-cache search qmmp
[email protected]:~#
I also removed pulseaudio and friends but find my application needs pulseaudio which is no longer available from the repo.
by g3vbv
Fri Aug 10, 2012 3:59 pm
Forum: Raspbian
Topic: No sound from on-board card
Replies: 10
Views: 7842

Re: No sound from on-board card

There is just a buzz where Front should sound so only Center, Left or Right in each case is played.
by g3vbv
Fri Aug 10, 2012 3:40 pm
Forum: Raspbian
Topic: No sound from on-board card
Replies: 10
Views: 7842

Re: No sound from on-board card

I edited /etc/asound.conf replacing the spaces with tabs. "aplay /jet.wav" still gives write errors. [email protected]:~# amixer cset numid=3 0 numid=3,iface=MIXER,name='PCM Playback Route' ; type=INTEGER,access=rw------,values=1,min=0,max=3,step=0 : values=0 [email protected]:~# aplay /usr/share/soun...
by g3vbv
Thu Aug 09, 2012 7:50 pm
Forum: Raspbian
Topic: No sound from on-board card
Replies: 10
Views: 7842

No sound from on-board card

I have one application that plays sound only in short bursts from the HMDI but I have not been able to get sound from the 3.5 mm socket. Details of what I have tried below. Help appreciated. [email protected]:~# lsmod|grep snd snd_bcm2835 15388 1 snd_pcm 49240 1 snd_bcm2835 snd_seq 35080 0 snd_timer ...
by g3vbv
Wed Aug 01, 2012 1:23 am
Forum: Raspbian
Topic: raspbian sound and gcc/g++ problems
Replies: 1
Views: 1552

Re: raspbian sound and gcc/g++ problems

I forgot to mention another problem - when a USB Ethernet is plugged into the on-board USB or an external USB hub, the RasPi hangs with errors on eth0 (Unable to read registers) until it's unplugged. ifconfig returns nothing until after the unplug then it returns information for both eth0 and eth1. ...
by g3vbv
Wed Aug 01, 2012 12:48 am
Forum: Raspbian
Topic: raspbian sound and gcc/g++ problems
Replies: 1
Views: 1552

raspbian sound and gcc/g++ problems

I cannot get sound out of the on-board sound card using aplay or paplay on a .wav file. [email protected]i:/usr/src/MASTER/ghpsdr3-alex# cat /proc/asound/cards 0 [ALSA ]: BRCM bcm2835 ALSbcm2835 ALSA - bcm2835 ALSA bcm2835 ALSA [email protected]:/usr/src/MASTER/ghpsdr3-alex# fuser -v /dev/snd/* USER PI...

Go to advanced search