Go to advanced search

by Pi_DD
Tue Mar 17, 2020 9:44 am
Forum: Troubleshooting
Topic: Response to "sudo" appallingly slow - cannot force reboot
Replies: 0
Views: 298

Response to "sudo" appallingly slow - cannot force reboot

Context - I'm managing a remote Pi (90km away) that I cannot readily access and so cannot power off/on. At some point yesterday I suspect I did something to provoke the current situation (more on that in a moment). As a result _ any non sudo command executes instantaneously any sudo command (either ...
by Pi_DD
Sun Feb 09, 2020 5:53 pm
Forum: Camera board
Topic: Pi Zero case for outdoor
Replies: 5
Views: 423

Re: Pi Zero case for outdoor

For what it’s worth, this is the junction box I used.... because it has a rubber seal around the rim which is kind to the camera cable. The power cable enters via a hole pierced in one of the soft rubber grommets , then surrounded generously with BlueTak for extra waterproofing! https://www.amazon.c...
by Pi_DD
Sun Feb 09, 2020 2:27 pm
Forum: Camera board
Topic: Pi Zero case for outdoor
Replies: 5
Views: 423

Re: Pi Zero case for outdoor

For the Zero itself, no real idea I’m afraid. I think your best hope is to protect it with a waterproof junction box, about £5 on Amazon and mount the camera outside it. Take advantage of the ribbon cable which will go through a joint with a rubber seal without damage. (I’ve done this to get one int...
by Pi_DD
Wed Oct 16, 2019 11:48 am
Forum: Beginners
Topic: Question about FSTAB
Replies: 2
Views: 223

Question about FSTAB

I posted a question a while back asking why external USB SD cards showed up as "mounted" on desktop in some cases and not others. See https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=248136&p=1514953#p1514953 No replies, so I looked a bit further to try to understand and have now discovered t...
by Pi_DD
Wed Sep 04, 2019 8:56 am
Forum: Other projects
Topic: Pimoroni Pan-tilt HAT with Neopixel light strip + diffuser
Replies: 0
Views: 177

Pimoroni Pan-tilt HAT with Neopixel light strip + diffuser

This is a great bit of kit and is described very adequately on the Pimoroni web site, easy to implement with rudimentary Python skills. https://shop.pimoroni.com/products/pan-tilt-hat?variant=22408353287 so no repetition here, but just a hint about the light strip … I found that when on "all white" ...
by Pi_DD
Sun Aug 25, 2019 12:06 pm
Forum: Camera board
Topic: Purple "Noise"
Replies: 4
Views: 1310

Re: Purple "Noise"

The purple noise problem is because of a change some weeks ago to how the AWB algorithm works on “auto”. See this lengthy thread https://www.raspberrypi.org/forums/viewtopic.php?f=43&t=241633 That includes a workaround. As already said, if you update to Stretch 4.19.66+ #1253 available a few days ba...
by Pi_DD
Mon Aug 19, 2019 5:47 pm
Forum: Camera board
Topic: New AWB algorithm in test firmware
Replies: 24
Views: 6080

Re: New AWB algorithm in test firmware

Request for a clarification...... RESOLVED , the answer is AWB mode 0 still works if needed on latest Stretch and Buster I have a camera that uses both visible light LEDs and I.R LEDs and is managed using Motion/Motioneye. Had the “purple haze problem” and fixed it with the AWB=0 workaround. I note ...
by Pi_DD
Wed Aug 14, 2019 12:54 pm
Forum: Troubleshooting
Topic: VNC server not working after upgrade on RPi3 and RPi4B
Replies: 14
Views: 1993

Re: VNC server not working after upgrade on RPi3 and RPi4B

I had something like this as a problem. Then during an update of another Pi I noticed a set of messages during the update indicating the need to stop and restart the services for VNC and to enable the virtual server. Once I ran these commands everything worked just fine. As best as I can retrieve th...
by Pi_DD
Wed Aug 14, 2019 12:48 pm
Forum: Troubleshooting
Topic: VNC Server no longer working after update
Replies: 17
Views: 2471

Re: VNC Server no longer working after update

I had something like this as a problem. Then during an update of another Pi I noticed a set of messages during the update indicating the need to stop and restart the services for VNC and to enable the virtual server. Once I ran these commands everything worked just fine. As best as I can retrieve th...
by Pi_DD
Wed Aug 07, 2019 3:09 pm
Forum: Troubleshooting
Topic: external USB Micro SD mount problem
Replies: 0
Views: 139

external USB Micro SD mount problem

In doing backups of my various Pis I noticed something odd and hope somebody can help me clarify it. (I've always found the Linux mount/unmount thing less than clear - sorry about that Linux fans, but I do my best!) This table summarises.......... Pi 1 3b Stretch - backup disk visible on desktop, sh...
by Pi_DD
Sun Aug 04, 2019 10:15 am
Forum: Troubleshooting
Topic: VM is only supported on ARMv7+ VFP
Replies: 0
Views: 729

VM is only supported on ARMv7+ VFP

I am trying to upgrade a Buster installation and keep getting the above message at the end of a flood of other messages (see below). I found another problem that seemed to link this to Wolfram, but I had de-installed that anyhow. The 7 packages the messages refer to at the end were not installed, so...
by Pi_DD
Tue Jul 02, 2019 5:09 pm
Forum: Camera board
Topic: Problem with NOIR camera and BUSTER
Replies: 4
Views: 1985

Problem with NOIR camera and BUSTER

I am using a genuine Pi Noir Camera. Set it up using Stretch to use Motioneye on one of my Pi's (3b). Works just fine, everything as it should be. White balance works perfectly to give gray scale images from IR LED (it's inside a nesting box). Installed Buster on new Pi Zero. Install fine, clean, no...
by Pi_DD
Wed Jun 12, 2019 10:31 am
Forum: Troubleshooting
Topic: Pi Noir Camera not working on Pi3b
Replies: 2
Views: 292

Re: Pi Noir Camera not working on Pi3b

Thanks for the link. In the intervening period I had worked out that I have the RPi-Cam-Web-interface running in the both the machines I tried out. (Had forgotten I had installed and used it on the homepi5 machine!) I can get an image via that from the homepi5 machine I originally thought had a prob...
by Pi_DD
Wed Jun 12, 2019 9:49 am
Forum: Troubleshooting
Topic: Pi Noir Camera not working on Pi3b
Replies: 2
Views: 292

Pi Noir Camera not working on Pi3b

Camera is v2.1 8mp noir I have enabled camera via config, I have checked the cable, I have run apt-get update and upgrade Upgrade produces the following ... [email protected]:~ $ sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgr...
by Pi_DD
Wed Mar 06, 2019 5:53 pm
Forum: Troubleshooting
Topic: WLAN0 stopped working after recent update/upgrade
Replies: 7
Views: 2004

Re: WLAN0 stopped working after recent update/upgrade

I have just run apt-get upgrade and notice that it now contains updates to wireless-regdb and wpasupplicant. That looks suspiciously like a change in the relevant area. Applying the updates triggers this warning................ wpasupplicant (2:2.6-19) unstable; urgency=medium With this release, wpa...
by Pi_DD
Wed Mar 06, 2019 4:16 pm
Forum: Troubleshooting
Topic: Help with Nginx reverse proxy
Replies: 0
Views: 462

Help with Nginx reverse proxy

I'm sure somebody out there more skilled than me can help me with this? I'm trying to set up Nginx as a reverse proxy so that, in the end, I can use HTTPS for all access. But, one step at a time, I'm trying to get the reverse proxy working. I want Nginx to act as a proxy for MotioneEYE, running in t...
by Pi_DD
Sat Mar 02, 2019 8:00 am
Forum: Troubleshooting
Topic: WLAN0 stopped working after recent update/upgrade
Replies: 7
Views: 2004

Re: WLAN0 stopped working after recent update/upgrade

Solved this by “brute force”! Taking a hint from the first post above it dawned on me I ought to be able to boot the “failing” pi 3b using a cloned SD card from another that was already running on a 3B. So I tried that and, voila! It worked. I’m afraid I don’t have the skills necessary to probe this...
by Pi_DD
Fri Mar 01, 2019 9:05 pm
Forum: Troubleshooting
Topic: WLAN0 stopped working after recent update/upgrade
Replies: 7
Views: 2004

Re: WLAN0 stopped working after recent update/upgrade

I’ve just taken a look at the logs in my WiFi and can see that it is responding very differently to the Pi that will not connect. This is the list of responses when the pi tries to connect and fails..... 01.03.2019 20:33:07 IF[2.4G]:STA(b8:27:eb:de:9e:da) Pairwise Key Handshaking timeout 01.03.2019 ...
by Pi_DD
Fri Mar 01, 2019 6:08 pm
Forum: Troubleshooting
Topic: WLAN0 stopped working after recent update/upgrade
Replies: 7
Views: 2004

Re: WLAN0 stopped working after recent update/upgrade

I am having the same problem, but in a slightly different form. I have - 2 x pi 3B ethernet connected, working fine, recently updated. Will also connect via WiFi. - 2 x pi zero w wifi connected (on totally different networks) - both working fine, both set up some time back, recently updated - 1 x pi...
by Pi_DD
Sat Apr 21, 2018 6:01 pm
Forum: Networking and servers
Topic: Openvpn via pivpn
Replies: 1
Views: 526

Openvpn via pivpn

I have installed OpenVPn using Pivpn http://www.pivpn.io/ When first installed Pi was connected via wifi. Openvpn worked just find, could access server and via that other devices on my network and thence to internet. I have changed connection of the Pi to ethernet, same fixed IP address. Now I can a...
by Pi_DD
Sat Mar 03, 2018 11:01 am
Forum: Raspberry Pi OS
Topic: Remote desktop (xrdp) on stretch: Some menu items do not work
Replies: 52
Views: 31833

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

As you can tell, well out of my depth here, but learning slowly! Spending a lot of time reading manuals to understand the advice. Somehow the change fbe suggested has vanished without apparent action by me! But all still works from VNC. For that, and because VNC provides much better virtual keyboard...
by Pi_DD
Fri Mar 02, 2018 8:45 pm
Forum: Raspberry Pi OS
Topic: Remote desktop (xrdp) on stretch: Some menu items do not work
Replies: 52
Views: 31833

Re: Remote desktop (xrdp) on stretch: Some menu items do not work

I had the parallel problem with SD Card Copier as well as Raspi Config (running Stretch) In a separate thread I was given the following suggestion as a change to the menu item via Main Menu Editor ... env SUDO_ASKPASS=/usr/bin/pwdpic.sh sudo -AE dbus-launch piclone The change is adding the “E”. I di...
by Pi_DD
Thu Mar 01, 2018 9:27 am
Forum: Troubleshooting
Topic: SD Card Copier - how to make this work?
Replies: 3
Views: 3774

Re: SD Card Copier - how to make this work?

@fbe - thanks so much for that! Copy now made successfully. Thanks also for the link to the other thread which echoes other “glitches” I had encountered, but largely blundered my way around as I learn! Reading up on that thread has added a to my wider knowledge. So much to learn! I have settled to R...
by Pi_DD
Wed Feb 28, 2018 3:52 pm
Forum: Troubleshooting
Topic: SD Card Copier - how to make this work?
Replies: 3
Views: 3774

SD Card Copier - how to make this work?

I'm trying to backup my SD card and see lot of references to this accessory, but I can't seem to make it work. (Yes, I know there are other ways of backing up the SD card!) The micro SD is happily identified by the file manager. I have NOT mounted it as there is nothing in any instruction to suggest...
by Pi_DD
Mon Feb 19, 2018 5:55 pm
Forum: Troubleshooting
Topic: Cannot reach external web sites, can no longer VPN in via my Pi and Teamviewer does not see it.
Replies: 8
Views: 966

Re: Cannot reach external web sites, can no longer VPN in via my Pi and Teamviewer does not see it.

Thanks for that!

Sounds like something to tinker with when time allows! I will try the "ugly hack" and see how I get on. For now I have things working and where I have the Pi at the moment the wifi connection is fast and reliable, so I can manage.

Again, thanks for all your help!

Go to advanced search