Go to advanced search

by mamor
Tue Aug 27, 2019 12:25 am
Forum: Camera board
Topic: using raspistill to only display red pixels in Real Time
Replies: 22
Views: 2732

Re: using raspistill to only display red pixels in Real Time

The only concern is that there is too much latency (delay) in the image itself. Is that expected or does the 'redfilter' need more tuning? Thank you so much to have brought this up. I created redfilter sofar on the YUV input requirement from original poster. But as we have seen doing redfilter for ...
by mamor
Tue Aug 20, 2019 12:22 am
Forum: Camera board
Topic: using raspistill to only display red pixels in Real Time
Replies: 22
Views: 2732

Re: using raspistill to only display red pixels in Real Time

Hi HermannSW:
I work with 'SanDiegoPiGuy' and we were able to implement the red filter feature in OpenCV.
OpenCV is very powerful with color detection and processing.
Thanks again for all your help.
by mamor
Mon Aug 19, 2019 9:19 pm
Forum: Camera board
Topic: using raspistill to only display red pixels in Real Time
Replies: 22
Views: 2732

Re: using raspistill to only display red pixels in Real Time

Then enable redfilter for rgba video format as well, and compare performance of both gstreamer pipelines end to end. No need for that, just learned (again) that raspivid encoding is I420 as well. With raspivid use of h264parse and (hardware accelerated) omxh264dec are needed, besides that redfilter...
by mamor
Thu Apr 18, 2019 8:24 pm
Forum: Compute Module
Topic: I2C-0: CM3L connected to Sony IMX219 Camera
Replies: 9
Views: 818

Re: I2C-0: CM3L connected to Sony IMX219 Camera

So, besides amending dt-blob.bin, do I need to watch out for anything in the /boot/config.txt file in order to move the camera to i2c-1 besides keeping the 'vc_i2c=on'?
by mamor
Thu Apr 18, 2019 2:00 am
Forum: Compute Module
Topic: I2C-0: CM3L connected to Sony IMX219 Camera
Replies: 9
Views: 818

Re: I2C-0: CM3L connected to Sony IMX219 Camera

Hello: I have a Compute Module 3 (CM3L) that use i2c-0 to connect to the Sony IMX219. Here are some questions: 1. Is it possible to connect several slave devices on the same i2c line (i2c-0) as the camera? My tests show that the camera (Sony IMX219) periodically outputs data on the same i2c line (i...
by mamor
Thu Apr 18, 2019 1:59 am
Forum: Compute Module
Topic: I2C-0: CM3L connected to Sony IMX219 Camera
Replies: 9
Views: 818

Re: I2C-0: CM3L connected to Sony IMX219 Camera

Hello: I have a Compute Module 3 (CM3L) that use i2c-0 to connect to the Sony IMX219. Here are some questions: 1. Is it possible to connect several slave devices on the same i2c line (i2c-0) as the camera? My tests show that the camera (Sony IMX219) periodically outputs data on the same i2c line (i...
by mamor
Wed Apr 17, 2019 10:21 pm
Forum: Compute Module
Topic: I2C-0: CM3L connected to Sony IMX219 Camera
Replies: 9
Views: 818

Re: I2C-0: CM3L connected to Sony IMX219 Camera

6by9 wrote:
Wed Apr 17, 2019 9:39 pm
mamor wrote:
Wed Apr 17, 2019 9:17 pm
Thank you!!! This helps us alot and help us proceed with our project.
Btw, what is a 'CAMERA_0_UNICAM_PORT'
It selects between using cam0/csi0 or cam1/csi1 for the csi image data.
Thank you! :-)
by mamor
Wed Apr 17, 2019 9:17 pm
Forum: Compute Module
Topic: I2C-0: CM3L connected to Sony IMX219 Camera
Replies: 9
Views: 818

Re: I2C-0: CM3L connected to Sony IMX219 Camera

6by9 wrote:
Wed Apr 17, 2019 7:53 pm
[email protected]_0_I2C_PORT {
Needs to be internal and 1 if you wish it to use i2c-1.
Thank you!!! This helps us alot and help us proceed with our project.
Btw, what is a 'CAMERA_0_UNICAM_PORT'
by mamor
Wed Apr 17, 2019 7:20 pm
Forum: Compute Module
Topic: I2C-0: CM3L connected to Sony IMX219 Camera
Replies: 9
Views: 818

Re: I2C-0: CM3L connected to Sony IMX219 Camera

Thank you so much! So here is my dts file for changing the camera to i2c-1 (SDA=2, SCL=3) I highlighted my changes. Would the change below be ok? /dts-v1/; / { videocore { pins_cm3 { pin_config { [email protected] { polarity = "active_high"; termination = "pull_down"; startup_state = "inactive"; function ...
by mamor
Wed Apr 17, 2019 1:02 am
Forum: Compute Module
Topic: I2C-0: CM3L connected to Sony IMX219 Camera
Replies: 9
Views: 818

I2C-0: CM3L connected to Sony IMX219 Camera

Hello: I have a Compute Module 3 (CM3L) that use i2c-0 to connect to the Sony IMX219. Here are some questions: 1. Is it possible to connect several slave devices on the same i2c line (i2c-0) as the camera? My tests show that the camera (Sony IMX219) periodically outputs data on the same i2c line (i2...
by mamor
Thu Mar 21, 2019 12:19 am
Forum: Camera board
Topic: Omnivision OV5647
Replies: 3
Views: 519

Re: Omnivision OV5647

Ok. I have 1.3.11 from 'raspistill -v'.
It works ok. There are some intermittent behaviors though but maybe its our system.
by mamor
Thu Mar 14, 2019 9:10 pm
Forum: Camera board
Topic: Omnivision OV5647
Replies: 3
Views: 519

Omnivision OV5647

Hello folks:
I have Camera App v1.3.8 using Raspistill. The camera is Omnivision OV5647.
Apparently, the exposure modes are not working (i.e spotlight, auto, backlit, etc). The exposure modes allow for the gains to compensate based on the view.
Do you know why the exposure modes are not working?
by mamor
Tue Jan 15, 2019 7:12 pm
Forum: Camera board
Topic: Sharpness setting on Camera Board V2 Sony IMX219
Replies: 9
Views: 2171

Re: Sharpness setting on Camera Board V2 Sony IMX219

Questions:
1. What is a "sharpness block"?
2. We reduce the sharpness on the V1 (OmniVision), we get the equivalent sharpness on V2 (Sony). Why?
Note:
We have a system that use both V1 and V2 for comparison, knowing that both sensors are in focus.
by mamor
Tue Jan 15, 2019 5:36 pm
Forum: Camera board
Topic: Sharpness setting on Camera Board V2 Sony IMX219
Replies: 9
Views: 2171

Re: Sharpness setting on Camera Board V2 Sony IMX219

Ok. Knowing that the sharpness does not work on the IMX219, is it also safe to assume that the sharpness is not at nominal (default, or middle) setting on bootup?
I observe that the sharpness between the Camera V1 (OmniVision OV5647) has a sharper image than the V2 (Sony IMX219).
Why would that be?
by mamor
Wed Jan 09, 2019 6:37 pm
Forum: Camera board
Topic: Sharpness setting on Camera Board V2 Sony IMX219
Replies: 9
Views: 2171

Re: Sharpness setting on Camera Board V2 Sony IMX219

Hello. Any updates?
by mamor
Fri Jan 04, 2019 12:39 am
Forum: Camera board
Topic: Sharpness setting on Camera Board V2 Sony IMX219
Replies: 9
Views: 2171

Re: Sharpness setting on Camera Board V2 Sony IMX219

Yes please. Thank you for being so diligent in this matter. Much appreciated.
Just let us know asap when the firmware is ready.
by mamor
Tue Dec 04, 2018 5:49 pm
Forum: Camera board
Topic: Sharpness setting on Camera Board V2 Sony IMX219
Replies: 9
Views: 2171

Sharpness setting on Camera Board V2 Sony IMX219

Hello:
Does the sharpness work on the Camera Board V2 (Sony IMX219)?
I had used 'raspistill -sh -100' up to 'raspistill -sh 100' using values in between and my image is not changing.
Is that normal?
by mamor
Mon Oct 22, 2018 6:41 pm
Forum: Camera board
Topic: New feature implemented - forcing the sensor mode
Replies: 19
Views: 6831

Re: New feature implemented - forcing the sensor mode

Hello:
So, what exactly does an 'automatic selection' (mode = 0) do?
Will it ever do binning?
by mamor
Thu Nov 09, 2017 1:55 am
Forum: Compute Module
Topic: Compute module 3 with 3d (3-dimensional) capability with 2 cameras?
Replies: 0
Views: 417

Compute module 3 with 3d (3-dimensional) capability with 2 cameras?

Hello:
I understand that the 'Compute Module 3' has 2 inputs for cameras. So, would it be possible to create 3-D image capture using raspistill since CM3 now has 2 camera inputs?

Go to advanced search