Go to advanced search

by satnerd
Fri Jun 05, 2020 2:59 pm
Forum: General discussion
Topic: Image viewer with transition between images
Replies: 265
Views: 48638

Re: Image viewer with transition between images

Hi Paddy as always: thanks :) PictureFrame2020.py w/ argparse looks versatile. Makes it much easier to try out different options an see their effect. Should not be too much work to merge with my changes. I am also thinking to write a cgi script to facilitate changing PIC_DIR, e.g. from a list of fav...
by satnerd
Fri Jun 05, 2020 1:33 pm
Forum: General discussion
Topic: Image viewer with transition between images
Replies: 265
Views: 48638

Re: Image viewer with transition between images

Hi Paddy meanwhile I managed to get the .PNG based scrolling to work. Now, I noticed that the function tex_load in PictureFrame.py takes quite some time to load the pi3d.Texture: It takes 0.2s for a 100k picture, but whopping 4s for 3Mb. The effect on the scrolling items: The scrolling grinds to a h...
by satnerd
Sat May 23, 2020 5:50 am
Forum: General discussion
Topic: Image viewer with transition between images
Replies: 265
Views: 48638

Re: Image viewer with transition between images

Hi Paddy On the Thai spacing: there is a good article in https://stackoverflow.com/a/30105788 explaining on how to tackle the spacing. I had to use regexp to get the character based scrolling working properly. (But jerky) Yeah, I implemented the PNG rendering. It is a fairly straight forward way wel...
by satnerd
Fri May 22, 2020 12:00 pm
Forum: General discussion
Topic: Image viewer with transition between images
Replies: 265
Views: 48638

Re: Image viewer with transition between images

Hi Paddy For long texts, it would be nice to display a subset of the string as horizontally scrolling text. I implemented scrolling text using pi3d.TextBlock. I just update the text object with a varying substring. The resulting scrolling is very jerky. In ~/pi3d_demos/StringMulti.py is an example a...
by satnerd
Tue May 12, 2020 4:35 pm
Forum: General discussion
Topic: Image viewer with transition between images
Replies: 265
Views: 48638

Re: Image viewer with transition between images

Hi Paddy

Thanks for the swift reply. Much appreciated.
I'd rather know how to blend in a transparent png. Seems more flexible. (Single characters can change color, different font size)

Beat
by satnerd
Tue May 12, 2020 11:15 am
Forum: General discussion
Topic: Image viewer with transition between images
Replies: 265
Views: 48638

Re: Image viewer with transition between images

Hi I am writing a python class allowing me to retrieve weather information from openweathermap.org. I also came across the erikflowers.github.io/weather-icons weather icons and I managed to merge them with another font so I can display text and weather icons. In the end, I want to display weather in...
by satnerd
Tue Nov 07, 2017 8:47 pm
Forum: Troubleshooting
Topic: kodi startup failing
Replies: 4
Views: 564

Re: kodi startup failing

If grep returns below output, you have a different problem. grep :pi /etc/group adm:x:4:pi dialout:x:20:pi cdrom:x:24:pi sudo:x:27:pi audio:x:29:pi video:x:44:pi plugdev:x:46:pi games:x:60:pi users:x:100:pi input:x:101:pi netdev:x:108:pi spi:x:999:pi i2c:x:998:pi gpio:x:997:pi If you don't get above...
by satnerd
Sun Nov 05, 2017 9:53 am
Forum: Troubleshooting
Topic: kodi startup failing
Replies: 4
Views: 564

Re: kodi startup failing

I found the cause: when I was adding a second user with the command useradd, user pi had all its secondary groups revoked.
After adding user pi to the secondary groups adm,dialout,cdrom,sudo,audio,video,plugdev,games,users,input,netdev,spi,i2c,gpio in /etc/group, kodi would startup again.
by satnerd
Sun Oct 29, 2017 9:37 am
Forum: Troubleshooting
Topic: kodi startup failing
Replies: 4
Views: 564

kodi startup failing

Hi all I successfully installed and configured Kodi on Raspbian Stretch. It worked perfectly well until I was adding a second user, logged in again and started Kodi as that second user. Now, I only get a tiny flash. Kodi does not start. It stopped also working for the first user. After setting debug...

Go to advanced search